Auto sync2gitlab import of libdrm-2.4.114-1.el8.src.rpm
This commit is contained in:
parent
f977f28009
commit
930e1bdf2e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
/libdrm-2.4.108.tar.xz
|
/libdrm-2.4.108.tar.xz
|
||||||
/libdrm-2.4.111.tar.xz
|
/libdrm-2.4.111.tar.xz
|
||||||
|
/libdrm-2.4.114.tar.xz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -up libdrm-2.4.103/xf86drm.c.dma libdrm-2.4.103/xf86drm.c
|
diff -up libdrm-2.4.114/xf86drm.c.dma libdrm-2.4.114/xf86drm.c
|
||||||
--- libdrm-2.4.103/xf86drm.c.dma 2020-11-04 13:24:14.000000000 +1000
|
--- libdrm-2.4.114/xf86drm.c.dma 2022-11-03 18:33:36.000000000 +1000
|
||||||
+++ libdrm-2.4.103/xf86drm.c 2020-11-04 13:42:04.190975193 +1000
|
+++ libdrm-2.4.114/xf86drm.c 2022-11-10 05:39:58.652477119 +1000
|
||||||
@@ -507,11 +507,6 @@ drm_public int drmAvailable(void)
|
@@ -930,11 +930,6 @@ drm_public int drmAvailable(void)
|
||||||
int fd;
|
int fd;
|
||||||
|
|
||||||
if ((fd = drmOpenMinor(0, 1, DRM_NODE_PRIMARY)) < 0) {
|
if ((fd = drmOpenMinor(0, 1, DRM_NODE_PRIMARY)) < 0) {
|
||||||
@ -13,7 +13,7 @@ diff -up libdrm-2.4.103/xf86drm.c.dma libdrm-2.4.103/xf86drm.c
|
|||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -704,38 +699,6 @@ static int drmOpenByName(const char *nam
|
@@ -1127,38 +1122,6 @@ static int drmOpenByName(const char *nam
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -25,7 +25,7 @@ diff -up libdrm-2.4.103/xf86drm.c.dma libdrm-2.4.103/xf86drm.c
|
|||||||
- int retcode;
|
- int retcode;
|
||||||
-
|
-
|
||||||
- sprintf(proc_name, "/proc/dri/%d/name", i);
|
- sprintf(proc_name, "/proc/dri/%d/name", i);
|
||||||
- if ((fd = open(proc_name, O_RDONLY, 0)) >= 0) {
|
- if ((fd = open(proc_name, O_RDONLY)) >= 0) {
|
||||||
- retcode = read(fd, buf, sizeof(buf)-1);
|
- retcode = read(fd, buf, sizeof(buf)-1);
|
||||||
- close(fd);
|
- close(fd);
|
||||||
- if (retcode) {
|
- if (retcode) {
|
||||||
|
18
libdrm.spec
18
libdrm.spec
@ -1,4 +1,11 @@
|
|||||||
%define bcond_meson() %{lua: do
|
%define bcond_meson() %{lua: do
|
||||||
|
local option = rpm.expand("%{1}")
|
||||||
|
local with = rpm.expand("%{?with_" .. option .. "}")
|
||||||
|
local value = (with ~= '') and "enabled" or "disabled"
|
||||||
|
option = option:gsub('_', '-')
|
||||||
|
print(string.format("-D%s=%s", option, value))
|
||||||
|
end}
|
||||||
|
%define bcond_meson_tf() %{lua: do
|
||||||
local option = rpm.expand("%{1}")
|
local option = rpm.expand("%{1}")
|
||||||
local with = rpm.expand("%{?with_" .. option .. "}")
|
local with = rpm.expand("%{?with_" .. option .. "}")
|
||||||
local value = (with ~= '') and "true" or "false"
|
local value = (with ~= '') and "true" or "false"
|
||||||
@ -46,7 +53,7 @@ end}
|
|||||||
|
|
||||||
Name: libdrm
|
Name: libdrm
|
||||||
Summary: Direct Rendering Manager runtime library
|
Summary: Direct Rendering Manager runtime library
|
||||||
Version: 2.4.111
|
Version: 2.4.114
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
|
|
||||||
@ -123,9 +130,9 @@ Utility programs for the kernel DRM interface. Will void your warranty.
|
|||||||
%{bcond_meson cairo_tests} \
|
%{bcond_meson cairo_tests} \
|
||||||
%{bcond_meson man_pages} \
|
%{bcond_meson man_pages} \
|
||||||
%{bcond_meson valgrind} \
|
%{bcond_meson valgrind} \
|
||||||
%{bcond_meson freedreno_kgsl} \
|
%{bcond_meson_tf freedreno_kgsl} \
|
||||||
%{bcond_meson install_test_programs} \
|
%{bcond_meson_tf install_test_programs} \
|
||||||
%{bcond_meson udev} \
|
%{bcond_meson_tf udev} \
|
||||||
%{nil}
|
%{nil}
|
||||||
%meson_build
|
%meson_build
|
||||||
|
|
||||||
@ -271,6 +278,9 @@ install -Dpm0644 -t %{buildroot}%{_udevrulesdir} %{S:2}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 10 2022 Dave Airlie <airlied@redhat.com> - 2.4.114-1
|
||||||
|
- Update to 2.4.114
|
||||||
|
|
||||||
* Fri Jun 03 2022 Dave Airlie <airlied@redhat.com> - 2.4.111-1
|
* Fri Jun 03 2022 Dave Airlie <airlied@redhat.com> - 2.4.111-1
|
||||||
- Update to 2.4.111
|
- Update to 2.4.111
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libdrm-2.4.111.tar.xz) = 17e92e9e4ded8031ac222764bed7e9ff430a1a377f5e435f6b62b4a7f45cb4c4b769b3b79fbcba11512c1ac973abf8cdcca8e0b9659ae095e915d3d5efcf5516
|
SHA512 (libdrm-2.4.114.tar.xz) = 8dcd4be5674e3ea2ab4394fa8f461914e5aa7f4f57a2f448c5216d84ee6682e16b45eafabf97b7d9f5c062183d9a6bf3f0c97499d4cb01c19807a51209a0f644
|
||||||
|
Loading…
Reference in New Issue
Block a user