libdrm 2.4.47
- add fix for nouveau with gcc 4.8
This commit is contained in:
parent
249902244a
commit
561819aada
1
.gitignore
vendored
1
.gitignore
vendored
@ -29,3 +29,4 @@ libdrm-20100612.tar.bz2
|
|||||||
/libdrm-2.4.44.tar.bz2
|
/libdrm-2.4.44.tar.bz2
|
||||||
/libdrm-2.4.45.tar.bz2
|
/libdrm-2.4.45.tar.bz2
|
||||||
/libdrm-2.4.46.tar.bz2
|
/libdrm-2.4.46.tar.bz2
|
||||||
|
/libdrm-2.4.47.tar.bz2
|
||||||
|
@ -0,0 +1,31 @@
|
|||||||
|
From 482abbfafb56cbceaf5355c026434e638cddd0f1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Maarten Lankhorst <maarten.lankhorst@canonical.com>
|
||||||
|
Date: Thu, 7 Nov 2013 13:30:19 +0100
|
||||||
|
Subject: [PATCH] nouveau: prevent undefined behavior in nouveau_pushbuf_reloc
|
||||||
|
with gcc-4.8
|
||||||
|
|
||||||
|
Reported-by: ronald645@gmail.com
|
||||||
|
Bisected-by (gcc): Andreas Radke <a.radke@arcor.de>
|
||||||
|
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=71116
|
||||||
|
Signed-off-by: Maarten Lankhorst <maarten.lankhorst@canonical.com>
|
||||||
|
---
|
||||||
|
nouveau/pushbuf.c | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/nouveau/pushbuf.c b/nouveau/pushbuf.c
|
||||||
|
index 0fd0c47..4f77881 100644
|
||||||
|
--- a/nouveau/pushbuf.c
|
||||||
|
+++ b/nouveau/pushbuf.c
|
||||||
|
@@ -739,7 +739,8 @@ void
|
||||||
|
nouveau_pushbuf_reloc(struct nouveau_pushbuf *push, struct nouveau_bo *bo,
|
||||||
|
uint32_t data, uint32_t flags, uint32_t vor, uint32_t tor)
|
||||||
|
{
|
||||||
|
- *push->cur++ = pushbuf_krel(push, bo, data, flags, vor, tor);
|
||||||
|
+ *push->cur = pushbuf_krel(push, bo, data, flags, vor, tor);
|
||||||
|
+ push->cur++;
|
||||||
|
}
|
||||||
|
|
||||||
|
int
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
12
libdrm.spec
12
libdrm.spec
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: Direct Rendering Manager runtime library
|
Summary: Direct Rendering Manager runtime library
|
||||||
Name: libdrm
|
Name: libdrm
|
||||||
Version: 2.4.46
|
Version: 2.4.47
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://dri.sourceforge.net
|
URL: http://dri.sourceforge.net
|
||||||
@ -36,6 +36,8 @@ Patch3: libdrm-make-dri-perms-okay.patch
|
|||||||
Patch4: libdrm-2.4.0-no-bc.patch
|
Patch4: libdrm-2.4.0-no-bc.patch
|
||||||
# make rule to print the list of test programs
|
# make rule to print the list of test programs
|
||||||
Patch5: libdrm-2.4.25-check-programs.patch
|
Patch5: libdrm-2.4.25-check-programs.patch
|
||||||
|
# fix issue with nouveau and gcc-4.8
|
||||||
|
Patch6: 0001-nouveau-prevent-undefined-behavior-in-nouveau_pushbu.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Direct Rendering Manager runtime library
|
Direct Rendering Manager runtime library
|
||||||
@ -62,6 +64,7 @@ Utility programs for the kernel DRM interface. Will void your warranty.
|
|||||||
%patch3 -p1 -b .forceperms
|
%patch3 -p1 -b .forceperms
|
||||||
%patch4 -p1 -b .no-bc
|
%patch4 -p1 -b .no-bc
|
||||||
%patch5 -p1 -b .check
|
%patch5 -p1 -b .check
|
||||||
|
%patch6 -p1 -b .nouveau
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -v --install || exit 1
|
autoreconf -v --install || exit 1
|
||||||
@ -202,7 +205,10 @@ done
|
|||||||
%{_mandir}/man3/drm*.3*
|
%{_mandir}/man3/drm*.3*
|
||||||
%{_mandir}/man7/drm*.7*
|
%{_mandir}/man7/drm*.7*
|
||||||
|
|
||||||
%changelog
|
* Fri Nov 08 2013 Dave Airlie <airlied@redhat.com> 2.4.47-1
|
||||||
|
- libdrm 2.4.47
|
||||||
|
|
||||||
|
- add fix for nouveau with gcc 4.8
|
||||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.46-2
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.46-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user