Add WITH_ZCHUNK flag so LRO_SUPPORTS_CACHEDIR is set in librepo
Signed-off-by: Jonathan Dieter <jdieter@gmail.com>
This commit is contained in:
parent
63b2c4b2a6
commit
fc27f1833c
25
libdnf-0.35-fix-zchunk.patch
Normal file
25
libdnf-0.35-fix-zchunk.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 16b63308..c69026d1 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -30,6 +30,7 @@ option(WITH_BINDINGS "Enables python/SWIG bindings" ON)
|
||||
option(WITH_GTKDOC "Enables libdnf GTK-Doc HTML documentation" ON)
|
||||
option(WITH_HTML "Enables hawkey HTML generation" ON)
|
||||
option(WITH_MAN "Enables hawkey man page generation" ON)
|
||||
+option(WITH_ZCHUNK "Build with zchunk support" ON)
|
||||
option(ENABLE_RHSM_SUPPORT "Build with Red Hat Subscription Manager support?" OFF)
|
||||
option(ENABLE_SOLV_URPMREORDER "Build with support for URPM-like solution reordering?" OFF)
|
||||
|
||||
@@ -66,6 +67,12 @@ pkg_check_modules(SQLite3 REQUIRED sqlite3)
|
||||
# always enable linking with libdnf utils
|
||||
include_directories(${CMAKE_SOURCE_DIR} libdnf/utils/)
|
||||
|
||||
+if (WITH_ZCHUNK)
|
||||
+ pkg_check_modules(ZCHUNKLIB zck>=0.9.11 REQUIRED)
|
||||
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DWITH_ZCHUNK")
|
||||
+ set (CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DWITH_ZCHUNK")
|
||||
+endif ()
|
||||
+
|
||||
if(ENABLE_RHSM_SUPPORT)
|
||||
pkg_check_modules(RHSM REQUIRED librhsm>=0.0.3)
|
||||
include_directories(${RHSM_INCLUDE_DIRS})
|
13
libdnf.spec
13
libdnf.spec
@ -32,6 +32,12 @@
|
||||
%bcond_with rhsm
|
||||
%endif
|
||||
|
||||
%if 0%{?rhel}
|
||||
%bcond_with zchunk
|
||||
%else
|
||||
%bcond_without zchunk
|
||||
%endif
|
||||
|
||||
%global _cmake_opts \\\
|
||||
-DENABLE_RHSM_SUPPORT=%{?with_rhsm:ON}%{!?with_rhsm:OFF} \\\
|
||||
%{nil}
|
||||
@ -181,14 +187,14 @@ mkdir build-py3
|
||||
%build
|
||||
%if %{with python2}
|
||||
pushd build-py2
|
||||
%cmake -DPYTHON_DESIRED:FILEPATH=%{__python2} -DWITH_MAN=OFF ../ %{!?with_valgrind:-DDISABLE_VALGRIND=1} %{_cmake_opts}
|
||||
%cmake -DPYTHON_DESIRED:FILEPATH=%{__python2} -DWITH_MAN=OFF ../ %{?with_zchunk:-DWITH_ZCHUNK=ON} %{!?with_valgrind:-DDISABLE_VALGRIND=1} %{_cmake_opts}
|
||||
%make_build
|
||||
popd
|
||||
%endif # with python2
|
||||
|
||||
%if %{with python3}
|
||||
pushd build-py3
|
||||
%cmake -DPYTHON_DESIRED:FILEPATH=%{__python3} -DWITH_GIR=0 -DWITH_MAN=0 -Dgtkdoc=0 ../ %{!?with_valgrind:-DDISABLE_VALGRIND=1} %{_cmake_opts}
|
||||
%cmake -DPYTHON_DESIRED:FILEPATH=%{__python3} -DWITH_GIR=0 -DWITH_MAN=0 -Dgtkdoc=0 ../ %{?with_zchunk:-DWITH_ZCHUNK=ON} %{!?with_valgrind:-DDISABLE_VALGRIND=1} %{_cmake_opts}
|
||||
%make_build
|
||||
popd
|
||||
%endif
|
||||
@ -271,6 +277,9 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Sep 14 2019 Jonathan Dieter <jdieter@gmail.com> - 0.35.3-5
|
||||
- Set LRO_CACHEDIR so zchunk works again
|
||||
|
||||
* Wed Sep 11 2019 Jaroslav Mracek <jmracek@redhat.com> - 0.35.3-4
|
||||
- Backport patch to fix reinstalling packages with a different buildtime - part II
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user