Remove unused patches

This commit is contained in:
Jaroslav Mracek 2019-10-14 15:17:01 +02:00
parent a3c96879f1
commit c1eff5f3df
3 changed files with 0 additions and 125 deletions

View File

@ -1,31 +0,0 @@
From 0a6de048e9bbb6ec980af16feb3b875aa139128f Mon Sep 17 00:00:00 2001
From: Jaroslav Mracek <jmracek@redhat.com>
Date: Wed, 3 Jul 2019 12:56:31 +0200
Subject: [PATCH] Revert consequences of Fail-Safe mechanism
---
libdnf/dnf-rpmts.cpp | 8 +++-----
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/libdnf/dnf-rpmts.cpp b/libdnf/dnf-rpmts.cpp
index 61bb1a2..b996393 100644
--- a/libdnf/dnf-rpmts.cpp
+++ b/libdnf/dnf-rpmts.cpp
@@ -69,11 +69,9 @@ test_fail_safe(Header * hdr, DnfPackage * pkg, GError **error)
DnfSack * sack = dnf_package_get_sack(pkg);
auto includes = dnf_sack_get_module_includes(sack);
if (!includes || !includes->has(dnf_package_get_id(pkg))) {
- g_set_error(error, DNF_ERROR, DNF_ERROR_INTERNAL_ERROR,
- _("No available modular metadata for modular package '%s'; "
- "cannot be installed on the system"),
- dnf_package_get_nevra(pkg));
- ret = FALSE;
+ g_critical(_("No available modular metadata for modular package '%s'; "
+ "cannot be installed on the system"),
+ dnf_package_get_nevra(pkg));
}
}
}
--
libgit2 0.27.8

View File

@ -1,60 +0,0 @@
From 3f16d57ee5f3cd23a4dd4ea989c64ce3e65aeeb1 Mon Sep 17 00:00:00 2001
From: Jaroslav Mracek <jmracek@redhat.com>
Date: Tue, 3 Sep 2019 11:01:23 +0200
Subject: [PATCH] Mark job goal.upgrade with sltr as targeted
It allows to keep installed packages in upgrade set.
It also prevents from reinstalling of modified packages with same NEVRA.
---
libdnf.spec | 2 +-
libdnf/goal/Goal.cpp | 2 +-
libdnf/goal/Goal.hpp | 6 ++++--
3 files changed, 6 insertions(+), 4 deletions(-)
diff --git a/libdnf.spec b/libdnf.spec
index e37ffe6..9e3964a 100644
--- a/libdnf.spec
+++ b/libdnf.spec
@@ -1,7 +1,7 @@
%global libsolv_version 0.7.4-1
%global libmodulemd_version 1.6.1
%global librepo_version 1.10.0
-%global dnf_conflict 4.2.5
+%global dnf_conflict 4.2.11
%global swig_version 3.0.12
%bcond_with valgrind
diff --git a/libdnf/goal/Goal.cpp b/libdnf/goal/Goal.cpp
index b69be19..a38cbb4 100644
--- a/libdnf/goal/Goal.cpp
+++ b/libdnf/goal/Goal.cpp
@@ -767,7 +767,7 @@ void
Goal::upgrade(HySelector sltr)
{
pImpl->actions = static_cast<DnfGoalActions>(pImpl->actions | DNF_UPGRADE);
- sltrToJob(sltr, &pImpl->staging, SOLVER_UPDATE);
+ sltrToJob(sltr, &pImpl->staging, SOLVER_UPDATE|SOLVER_TARGETED);
}
void
diff --git a/libdnf/goal/Goal.hpp b/libdnf/goal/Goal.hpp
index f33dfa2..d701317 100644
--- a/libdnf/goal/Goal.hpp
+++ b/libdnf/goal/Goal.hpp
@@ -86,8 +86,10 @@ public:
/**
* @brief If selector ill formed, it rises std::runtime_error()
*
- * @param sltr p_sltr: It should contain only upgrades with obsoletes otherwise it can try to
- * reinstall installonly packages.
+ * @param sltr p_sltr: It contains upgrade-to packages and obsoletes. The presence of installed
+ * packages prevents reinstalling packages with the same NEVRA but changed contant. To honor repo
+ * priority all relevant packages must be present. To upgrade package foo from priority repo, all
+ * installed and available packages of the foo must be in selector plus obsoletes of foo.
*/
void upgrade(HySelector sltr);
void userInstalled(DnfPackage *pkg);
--
libgit2 0.28.2

View File

@ -1,34 +0,0 @@
From c235dae84d1b45911f6de1c5d31fedf4856c0d42 Mon Sep 17 00:00:00 2001
From: Jaroslav Mracek <jmracek@redhat.com>
Date: Wed, 11 Sep 2019 13:26:43 +0200
Subject: [PATCH] Apply targeted upgrade only for selector with packages
It resolves problem when selector with name filter is used. Then
targeted transaction ignores obsoletes.
Closes: #793
Approved by: jrohel
---
libdnf/goal/Goal.cpp | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/libdnf/goal/Goal.cpp b/libdnf/goal/Goal.cpp
index a38cbb4..88e7b8c 100644
--- a/libdnf/goal/Goal.cpp
+++ b/libdnf/goal/Goal.cpp
@@ -767,7 +767,11 @@ void
Goal::upgrade(HySelector sltr)
{
pImpl->actions = static_cast<DnfGoalActions>(pImpl->actions | DNF_UPGRADE);
- sltrToJob(sltr, &pImpl->staging, SOLVER_UPDATE|SOLVER_TARGETED);
+ auto flags = SOLVER_UPDATE;
+ if (sltr->getPkgs()) {
+ flags |= SOLVER_TARGETED;
+ }
+ sltrToJob(sltr, &pImpl->staging, flags);
}
void
--
libgit2 0.28.2