Add x86_64_v2 to arch_map
Add link to AlmaLinux bugtracker Fix tests on x86_64_v2
This commit is contained in:
commit
c108ecef0e
60
0007-Add-persistence-config-option.patch
Normal file
60
0007-Add-persistence-config-option.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
From 86804b72c39a47df2cdbf422c93318739773aec9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Evan Goode <mail@evangoo.de>
|
||||||
|
Date: Thu, 7 Nov 2024 02:34:37 +0000
|
||||||
|
Subject: [PATCH] Add `persistence` config option
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Upstream commit: 18a7db66bfc2cf228bdbb484fa92504c2eaefdc6
|
||||||
|
Resolves: https://issues.redhat.com/browse/RHEL-78034
|
||||||
|
|
||||||
|
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||||
|
---
|
||||||
|
libdnf/conf/ConfigMain.cpp | 3 +++
|
||||||
|
libdnf/conf/ConfigMain.hpp | 1 +
|
||||||
|
2 files changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/libdnf/conf/ConfigMain.cpp b/libdnf/conf/ConfigMain.cpp
|
||||||
|
index 3f12762a..b58b2f47 100644
|
||||||
|
--- a/libdnf/conf/ConfigMain.cpp
|
||||||
|
+++ b/libdnf/conf/ConfigMain.cpp
|
||||||
|
@@ -284,6 +284,7 @@ class ConfigMain::Impl {
|
||||||
|
OptionString comment{nullptr};
|
||||||
|
OptionBool downloadonly{false}; // runtime only option
|
||||||
|
OptionBool ignorearch{false};
|
||||||
|
+ OptionEnum<std::string> persistence{"auto", {"auto", "persist", "transient"}};
|
||||||
|
OptionString module_platform_id{nullptr};
|
||||||
|
OptionBool module_stream_switch{false};
|
||||||
|
OptionBool module_obsoletes{false};
|
||||||
|
@@ -458,6 +459,7 @@ ConfigMain::Impl::Impl(Config & owner)
|
||||||
|
owner.optBinds().add("user_agent", user_agent);
|
||||||
|
owner.optBinds().add("countme", countme);
|
||||||
|
owner.optBinds().add("protect_running_kernel", protect_running_kernel);
|
||||||
|
+ owner.optBinds().add("persistence", persistence);
|
||||||
|
|
||||||
|
// Repo main config
|
||||||
|
|
||||||
|
@@ -613,6 +615,7 @@ OptionPath & ConfigMain::destdir() { return pImpl->destdir; }
|
||||||
|
OptionString & ConfigMain::comment() { return pImpl->comment; }
|
||||||
|
OptionBool & ConfigMain::downloadonly() { return pImpl->downloadonly; }
|
||||||
|
OptionBool & ConfigMain::ignorearch() { return pImpl->ignorearch; }
|
||||||
|
+OptionEnum<std::string> & ConfigMain::persistence() { return pImpl->persistence; }
|
||||||
|
|
||||||
|
OptionString & ConfigMain::module_platform_id() { return pImpl->module_platform_id; }
|
||||||
|
OptionBool & ConfigMain::module_stream_switch() { return pImpl->module_stream_switch; }
|
||||||
|
diff --git a/libdnf/conf/ConfigMain.hpp b/libdnf/conf/ConfigMain.hpp
|
||||||
|
index c63c9a82..af6496f3 100644
|
||||||
|
--- a/libdnf/conf/ConfigMain.hpp
|
||||||
|
+++ b/libdnf/conf/ConfigMain.hpp
|
||||||
|
@@ -125,6 +125,7 @@ public:
|
||||||
|
OptionString & comment();
|
||||||
|
OptionBool & downloadonly();
|
||||||
|
OptionBool & ignorearch();
|
||||||
|
+ OptionEnum<std::string> & persistence();
|
||||||
|
|
||||||
|
OptionString & module_platform_id();
|
||||||
|
OptionBool & module_stream_switch();
|
||||||
|
--
|
||||||
|
2.48.1
|
||||||
|
|
15
libdnf.spec
15
libdnf.spec
@ -56,7 +56,7 @@
|
|||||||
|
|
||||||
Name: libdnf
|
Name: libdnf
|
||||||
Version: %{libdnf_major_version}.%{libdnf_minor_version}.%{libdnf_micro_version}
|
Version: %{libdnf_major_version}.%{libdnf_minor_version}.%{libdnf_micro_version}
|
||||||
Release: 6%{?dist}.alma.1
|
Release: 7%{?dist}.alma.1
|
||||||
Summary: Library providing simplified C and Python API to libsolv
|
Summary: Library providing simplified C and Python API to libsolv
|
||||||
License: LGPL-2.1-or-later
|
License: LGPL-2.1-or-later
|
||||||
URL: https://github.com/rpm-software-management/libdnf
|
URL: https://github.com/rpm-software-management/libdnf
|
||||||
@ -67,12 +67,12 @@ Patch3: 0003-MergedTransaction-Fix-invalid-memory-access-when-dro.patch
|
|||||||
Patch4: 0004-Set-pool-flag-to-fix-pool_addfileprovides_queue-with.patch
|
Patch4: 0004-Set-pool-flag-to-fix-pool_addfileprovides_queue-with.patch
|
||||||
Patch5: 0005-ConfigParser-fix-use-out-of-scope-leaks.patch
|
Patch5: 0005-ConfigParser-fix-use-out-of-scope-leaks.patch
|
||||||
Patch6: 0006-Add-tests-for-shell-style-variable-expansion.patch
|
Patch6: 0006-Add-tests-for-shell-style-variable-expansion.patch
|
||||||
|
Patch7: 0007-Add-persistence-config-option.patch
|
||||||
|
|
||||||
|
# AlmaLinux Patch
|
||||||
# AlmaLinux patches
|
|
||||||
Patch1001: 0001-Add-link-to-AlmaLinux-bugtracker.patch
|
Patch1001: 0001-Add-link-to-AlmaLinux-bugtracker.patch
|
||||||
Patch1002: 0001-Add-x86_64_v2-to-tests.patch
|
Patch1002: 0001-Add-x86_64_v2-to-arch_map.patch
|
||||||
Patch1003: 0001-Add-x86_64_v2-to-arch_map.patch
|
Patch1003: 0001-Add-x86_64_v2-to-tests.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -316,11 +316,14 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Dec 09 2024 Eduard Abdullin <eabdullin@almalinux.org> - 0.73.1-6.alma.1
|
* Tue Feb 11 2025 Eduard Abdullin <eabdullin@almalinux.org> - 0.73.1-7.alma.1
|
||||||
- Add x86_64_v2 to arch_map
|
- Add x86_64_v2 to arch_map
|
||||||
- Add link to AlmaLinux bugtracker
|
- Add link to AlmaLinux bugtracker
|
||||||
- Fix tests on x86_64_v2
|
- Fix tests on x86_64_v2
|
||||||
|
|
||||||
|
* Wed Feb 05 2025 Petr Pisar <ppisar@redhat.com> - 0.73.1-7
|
||||||
|
- Add persistence configuration option (RHEL-78034)
|
||||||
|
|
||||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 0.73.1-6
|
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 0.73.1-6
|
||||||
- Bump release for October 2024 mass rebuild:
|
- Bump release for October 2024 mass rebuild:
|
||||||
Resolves: RHEL-64018
|
Resolves: RHEL-64018
|
||||||
|
Loading…
Reference in New Issue
Block a user