- Add link to AlmaLinux bugtracker
This commit is contained in:
parent
4d9a633ed1
commit
798ea17480
38
0001-Add-link-to-AlmaLinux-bugtracker.patch
Normal file
38
0001-Add-link-to-AlmaLinux-bugtracker.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
From 5f7e4b85ed7331eb27654bb3dbab9592a3f8f722 Mon Sep 17 00:00:00 2001
|
||||||
|
From: eabdullin <ed.abdullin.1@gmail.com>
|
||||||
|
Date: Wed, 31 Jul 2024 16:18:32 +0300
|
||||||
|
Subject: [PATCH 1/2] Add link to AlmaLinux bugtracker
|
||||||
|
|
||||||
|
---
|
||||||
|
docs/hawkey/conf.py | 2 +-
|
||||||
|
libdnf/conf/Const.hpp | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/docs/hawkey/conf.py b/docs/hawkey/conf.py
|
||||||
|
index 93330c2..5ea39da 100644
|
||||||
|
--- a/docs/hawkey/conf.py
|
||||||
|
+++ b/docs/hawkey/conf.py
|
||||||
|
@@ -260,6 +260,6 @@ texinfo_documents = [
|
||||||
|
rst_prolog = """
|
||||||
|
.. default-domain:: py
|
||||||
|
.. _libsolv: https://github.com/openSUSE/libsolv
|
||||||
|
-.. _bugzilla: https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=hawkey
|
||||||
|
+.. _bugzilla: https://bugs.almalinux.org/
|
||||||
|
|
||||||
|
"""
|
||||||
|
diff --git a/libdnf/conf/Const.hpp b/libdnf/conf/Const.hpp
|
||||||
|
index ba21bbe..28cfa57 100644
|
||||||
|
--- a/libdnf/conf/Const.hpp
|
||||||
|
+++ b/libdnf/conf/Const.hpp
|
||||||
|
@@ -41,7 +41,7 @@ const std::vector<std::string> INSTALLONLYPKGS{"kernel", "kernel-PAE",
|
||||||
|
"installonlypkg(vm)",
|
||||||
|
"multiversion(kernel)"};
|
||||||
|
|
||||||
|
-constexpr const char * BUGTRACKER="https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=dnf";
|
||||||
|
+constexpr const char * BUGTRACKER="https://bugs.almalinux.org/";
|
||||||
|
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
2.39.3 (Apple Git-146)
|
||||||
|
|
42
0001-Add-x86_64_v2-to-tests.patch
Normal file
42
0001-Add-x86_64_v2-to-tests.patch
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
From 9b2b677bee48f18d41f958f01e00142b0e39e543 Mon Sep 17 00:00:00 2001
|
||||||
|
From: eabdullin <ed.abdullin.1@gmail.com>
|
||||||
|
Date: Wed, 31 Jul 2024 16:34:28 +0300
|
||||||
|
Subject: [PATCH] Add x86_64_v2 to tests
|
||||||
|
|
||||||
|
---
|
||||||
|
tests/hawkey/test_sack.cpp | 12 +++++++++++-
|
||||||
|
1 file changed, 11 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tests/hawkey/test_sack.cpp b/tests/hawkey/test_sack.cpp
|
||||||
|
index 98a8660..5b085f3 100644
|
||||||
|
--- a/tests/hawkey/test_sack.cpp
|
||||||
|
+++ b/tests/hawkey/test_sack.cpp
|
||||||
|
@@ -83,7 +83,7 @@ START_TEST(test_list_arches)
|
||||||
|
const char ** arches = dnf_sack_list_arches(sack);
|
||||||
|
|
||||||
|
/* noarch, x86_64, athlon, i686, i586, i486, i386 */
|
||||||
|
- fail_unless(g_strv_length((gchar**)arches) >= 6 && g_strv_length((gchar**)arches) <= 7);
|
||||||
|
+ fail_unless(g_strv_length((gchar**)arches) >= 6 && g_strv_length((gchar**)arches) <= 8);
|
||||||
|
|
||||||
|
if (g_strv_length((gchar**)arches) == 7) {
|
||||||
|
// Fedora, Mageia
|
||||||
|
@@ -94,6 +94,16 @@ START_TEST(test_list_arches)
|
||||||
|
ck_assert_str_eq(arches[4], "i586");
|
||||||
|
ck_assert_str_eq(arches[5], "i486");
|
||||||
|
ck_assert_str_eq(arches[6], "i386");
|
||||||
|
+ } else if (g_strv_length((gchar**)arches) == 8) {
|
||||||
|
+ // AlmaLinux x86_64_v2 arch is available
|
||||||
|
+ ck_assert_str_eq(arches[0], "noarch");
|
||||||
|
+ ck_assert_str_eq(arches[1], "x86_64");
|
||||||
|
+ ck_assert_str_eq(arches[2], "x86_64_v2");
|
||||||
|
+ ck_assert_str_eq(arches[3], "athlon");
|
||||||
|
+ ck_assert_str_eq(arches[4], "i686");
|
||||||
|
+ ck_assert_str_eq(arches[5], "i586");
|
||||||
|
+ ck_assert_str_eq(arches[6], "i486");
|
||||||
|
+ ck_assert_str_eq(arches[7], "i386");
|
||||||
|
} else {
|
||||||
|
// openSUSE, Debian - "athlon" is not available
|
||||||
|
ck_assert_str_eq(arches[0], "noarch");
|
||||||
|
--
|
||||||
|
2.39.3 (Apple Git-146)
|
||||||
|
|
11
libdnf.spec
11
libdnf.spec
@ -56,7 +56,7 @@
|
|||||||
|
|
||||||
Name: libdnf
|
Name: libdnf
|
||||||
Version: %{libdnf_major_version}.%{libdnf_minor_version}.%{libdnf_micro_version}
|
Version: %{libdnf_major_version}.%{libdnf_minor_version}.%{libdnf_micro_version}
|
||||||
Release: 5%{?dist}
|
Release: 5%{?dist}.alma.1
|
||||||
Summary: Library providing simplified C and Python API to libsolv
|
Summary: Library providing simplified C and Python API to libsolv
|
||||||
License: LGPL-2.1-or-later
|
License: LGPL-2.1-or-later
|
||||||
URL: https://github.com/rpm-software-management/libdnf
|
URL: https://github.com/rpm-software-management/libdnf
|
||||||
@ -68,6 +68,11 @@ Patch4: 0004-Set-pool-flag-to-fix-pool_addfileprovides_queue-with.patch
|
|||||||
Patch5: 0005-ConfigParser-fix-use-out-of-scope-leaks.patch
|
Patch5: 0005-ConfigParser-fix-use-out-of-scope-leaks.patch
|
||||||
Patch6: 0006-Add-tests-for-shell-style-variable-expansion.patch
|
Patch6: 0006-Add-tests-for-shell-style-variable-expansion.patch
|
||||||
|
|
||||||
|
|
||||||
|
# AlmaLinux patches
|
||||||
|
Patch1001: 0001-Add-link-to-AlmaLinux-bugtracker.patch
|
||||||
|
Patch1002: 0001-Add-x86_64_v2-to-tests.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -310,6 +315,10 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 31 2024 Eduard Abdullin <eabdullin@almalinux.org> - 0.73.1-5.alma.1
|
||||||
|
- Add link to AlmaLinux bugtracker
|
||||||
|
- Fix tests on x86_64_v2
|
||||||
|
|
||||||
* Tue Jul 16 2024 Petr Pisar <ppisar@redhat.com> - 0.73.1-5
|
* Tue Jul 16 2024 Petr Pisar <ppisar@redhat.com> - 0.73.1-5
|
||||||
- Fix invalid memory uses in libdnf::ConfigParser::substitute_expression() (RHEL-36777)
|
- Fix invalid memory uses in libdnf::ConfigParser::substitute_expression() (RHEL-36777)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user