Update to 0.45.0
This commit is contained in:
parent
881203c2cd
commit
5d9e345de0
1
.gitignore
vendored
1
.gitignore
vendored
@ -40,3 +40,4 @@
|
||||
/libdnf-0.37.2.tar.gz
|
||||
/libdnf-0.39.1.tar.gz
|
||||
/libdnf-0.43.1.tar.gz
|
||||
/libdnf-0.45.0.tar.gz
|
||||
|
59
887.patch
59
887.patch
@ -1,59 +0,0 @@
|
||||
From f18d11984a91e85369218b2c2361425c04671997 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Rohel <jrohel@redhat.com>
|
||||
Date: Wed, 29 Jan 2020 08:58:17 +0100
|
||||
Subject: [PATCH] [context] Create new repo instead of reusing old one
|
||||
|
||||
Function dnf_repo_check_internal() was reusing a libdnf::Repo objects.
|
||||
They were detached from libsolv repository and reseted for new usage.
|
||||
|
||||
New libdnf::Repo class instantions are created now. The old remain
|
||||
connected with libsolv repository.
|
||||
It can solve some PackageKit problems.
|
||||
eg. https://bugzilla.redhat.com/show_bug.cgi?id=1795004
|
||||
---
|
||||
libdnf/dnf-repo.cpp | 29 +++++++----------------------
|
||||
1 file changed, 7 insertions(+), 22 deletions(-)
|
||||
|
||||
diff --git a/libdnf/dnf-repo.cpp b/libdnf/dnf-repo.cpp
|
||||
index 45f6d0145..4c56fe3a5 100644
|
||||
--- a/libdnf/dnf-repo.cpp
|
||||
+++ b/libdnf/dnf-repo.cpp
|
||||
@@ -1470,31 +1470,16 @@ dnf_repo_check_internal(DnfRepo *repo,
|
||||
}
|
||||
}
|
||||
|
||||
- /* init */
|
||||
- repoImpl->detachLibsolvRepo();
|
||||
- repoImpl->needs_internalizing = false;
|
||||
- repoImpl->state_main = _HY_NEW;
|
||||
- repoImpl->state_filelists = _HY_NEW;
|
||||
- repoImpl->state_presto = _HY_NEW;
|
||||
- repoImpl->state_updateinfo = _HY_NEW;
|
||||
- repoImpl->state_other = _HY_NEW;
|
||||
- repoImpl->filenames_repodata = 0;
|
||||
- repoImpl->presto_repodata = 0;
|
||||
- repoImpl->updateinfo_repodata = 0;
|
||||
- repoImpl->other_repodata = 0;
|
||||
- repoImpl->load_flags = 0;
|
||||
- /* the following three elements are needed for repo rewriting */
|
||||
- repoImpl->main_nsolvables = 0;
|
||||
- repoImpl->main_nrepodata = 0;
|
||||
- repoImpl->main_end = 0;
|
||||
- priv->repo->setUseIncludes(false);
|
||||
-
|
||||
- repoImpl->repomdFn = yum_repo->repomd;
|
||||
- repoImpl->metadataPaths.clear();
|
||||
+ /* init newRepo */
|
||||
+ auto newRepo = hy_repo_create(priv->repo->getId().c_str());
|
||||
+ hy_repo_free(priv->repo);
|
||||
+ priv->repo = newRepo;
|
||||
+ auto newRepoImpl = libdnf::repoGetImpl(newRepo);
|
||||
+ newRepoImpl->repomdFn = yum_repo->repomd;
|
||||
for (auto *elem = yum_repo->paths; elem; elem = g_slist_next(elem)) {
|
||||
if (elem->data) {
|
||||
auto yumrepopath = static_cast<LrYumRepoPath *>(elem->data);
|
||||
- repoImpl->metadataPaths[yumrepopath->type] = yumrepopath->path;
|
||||
+ newRepoImpl->metadataPaths[yumrepopath->type] = yumrepopath->path;
|
||||
}
|
||||
}
|
||||
/* ensure we reset the values from the keyfile */
|
25
libdnf.spec
25
libdnf.spec
@ -1,11 +1,11 @@
|
||||
%global libsolv_version 0.7.7
|
||||
%global libmodulemd_version 1.6.1
|
||||
%global libmodulemd_version 2.5.0
|
||||
%global librepo_version 1.11.0
|
||||
%global dnf_conflict 4.2.13
|
||||
%global swig_version 3.0.12
|
||||
%global libdnf_major_version 0
|
||||
%global libdnf_minor_version 43
|
||||
%global libdnf_micro_version 1
|
||||
%global libdnf_minor_version 45
|
||||
%global libdnf_micro_version 0
|
||||
|
||||
# set sphinx package name according to distro
|
||||
%global requires_python2_sphinx python2-sphinx
|
||||
@ -52,15 +52,11 @@
|
||||
|
||||
Name: libdnf
|
||||
Version: %{libdnf_major_version}.%{libdnf_minor_version}.%{libdnf_micro_version}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Library providing simplified C and Python API to libsolv
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/rpm-software-management/libdnf
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
# https://github.com/rpm-software-management/libdnf/pull/887
|
||||
# Fixes a crash sometimes encountered in Cockpit:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1795004
|
||||
Patch0: 887.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc
|
||||
@ -84,7 +80,7 @@ BuildRequires: pkgconfig(sqlite3)
|
||||
BuildRequires: pkgconfig(json-c)
|
||||
BuildRequires: pkgconfig(cppunit)
|
||||
BuildRequires: pkgconfig(libcrypto)
|
||||
BuildRequires: pkgconfig(modulemd) >= %{libmodulemd_version}
|
||||
BuildRequires: pkgconfig(modulemd-2.0) >= %{libmodulemd_version}
|
||||
BuildRequires: pkgconfig(smartcols)
|
||||
BuildRequires: gettext
|
||||
BuildRequires: gpgme-devel
|
||||
@ -297,6 +293,17 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Feb 24 2020 Ales Matej <amatej@redhat.com> - 0.45.0-1
|
||||
- Config options: only first empty value clears existing (RhBug:1788154)
|
||||
- Make parsing of reldeps more strict (RhBug:1788107)
|
||||
- [context] Support repositories defined in main configuration file
|
||||
- Fix filtering packages by advisory when more versions and arches are available (RhBug:1770125)
|
||||
- Add expanding solvable provides for dependency matching (RhBug:1534123)
|
||||
- DnfRepo: fix module_hotfixes keyfile priority level
|
||||
- Add custom exceptions to libdnf interface
|
||||
- [conf] Set useful default colors when color is enabled
|
||||
- Port to libmodulemd-2 API (RhBug:1693683)
|
||||
|
||||
* Tue Feb 04 2020 Adam Williamson <adamwill@fedoraproject.org> - 0.43.1-3
|
||||
- [context] Create new repo instead of reusing old one (RhBug:1795004)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libdnf-0.43.1.tar.gz) = cb5e4a9aae2471475b8c7e816e8a045c88c17f55e6a278e6ff90b84f1be2e5d6b151d08c96425dcfbed7d992cf589bede1934c3f1d23774d2985ef941062719e
|
||||
SHA512 (libdnf-0.45.0.tar.gz) = c525d3c2ff100c5c1a6d28dbe6f7163702edd6fb60ab00437be8cf155ba3b8400e8cc3c8cbf10876d302fff62fffbac3c42440d86c00369fb7c21f658699646a
|
||||
|
Loading…
Reference in New Issue
Block a user