Update to 0.54.2
This commit is contained in:
parent
13fac8f783
commit
1f06d93bf5
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@
|
|||||||
/libdnf-0.46.2.tar.gz
|
/libdnf-0.46.2.tar.gz
|
||||||
/libdnf-0.47.0.tar.gz
|
/libdnf-0.47.0.tar.gz
|
||||||
/libdnf-0.48.0.tar.gz
|
/libdnf-0.48.0.tar.gz
|
||||||
|
/libdnf-0.54.2.tar.gz
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
From 89930d46c8fe833b9baf1cf76662275bfcb2f0d4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Luk=C3=A1=C5=A1=20Hr=C3=A1zk=C3=BD?= <lhrazky@redhat.com>
|
|
||||||
Date: Thu, 6 Aug 2020 10:59:59 +0200
|
|
||||||
Subject: [PATCH] tests: Fix incorrect usage of the fail_unless macro
|
|
||||||
|
|
||||||
---
|
|
||||||
tests/hawkey/test_query.cpp | 2 +-
|
|
||||||
tests/hawkey/test_sack.cpp | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tests/hawkey/test_query.cpp b/tests/hawkey/test_query.cpp
|
|
||||||
index bf21e3349..12c7733c8 100644
|
|
||||||
--- a/tests/hawkey/test_query.cpp
|
|
||||||
+++ b/tests/hawkey/test_query.cpp
|
|
||||||
@@ -306,7 +306,7 @@ START_TEST(test_query_pkg)
|
|
||||||
hy_query_filter(q, HY_PKG_NAME, HY_EQ, "jay");
|
|
||||||
pset = hy_query_run_set(q);
|
|
||||||
hy_query_free(q);
|
|
||||||
- fail_unless(dnf_packageset_count(pset), 2);
|
|
||||||
+ fail_unless(dnf_packageset_count(pset) == 2);
|
|
||||||
|
|
||||||
// use hy_query_filter_package_in():
|
|
||||||
q = hy_query_create(test_globals.sack);
|
|
||||||
diff --git a/tests/hawkey/test_sack.cpp b/tests/hawkey/test_sack.cpp
|
|
||||||
index ba54602d1..5eab83b3f 100644
|
|
||||||
--- a/tests/hawkey/test_sack.cpp
|
|
||||||
+++ b/tests/hawkey/test_sack.cpp
|
|
||||||
@@ -83,7 +83,7 @@ START_TEST(test_list_arches)
|
|
||||||
const char ** arches = dnf_sack_list_arches(sack);
|
|
||||||
|
|
||||||
/* noarch, x86_64, athlon, i686, i586, i486, i386 */
|
|
||||||
- fail_unless(g_strv_length((gchar**)arches), 7);
|
|
||||||
+ fail_unless(g_strv_length((gchar**)arches) == 7);
|
|
||||||
|
|
||||||
if (strcmp(arches[2], "athlon") == 0) {
|
|
||||||
// Fedora, Mageia
|
|
25
libdnf.spec
25
libdnf.spec
@ -4,8 +4,8 @@
|
|||||||
%global dnf_conflict 4.2.23
|
%global dnf_conflict 4.2.23
|
||||||
%global swig_version 3.0.12
|
%global swig_version 3.0.12
|
||||||
%global libdnf_major_version 0
|
%global libdnf_major_version 0
|
||||||
%global libdnf_minor_version 48
|
%global libdnf_minor_version 54
|
||||||
%global libdnf_micro_version 0
|
%global libdnf_micro_version 2
|
||||||
|
|
||||||
%define __cmake_in_source_build 1
|
%define __cmake_in_source_build 1
|
||||||
|
|
||||||
@ -56,12 +56,11 @@
|
|||||||
|
|
||||||
Name: libdnf
|
Name: libdnf
|
||||||
Version: %{libdnf_major_version}.%{libdnf_minor_version}.%{libdnf_micro_version}
|
Version: %{libdnf_major_version}.%{libdnf_minor_version}.%{libdnf_micro_version}
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Library providing simplified C and Python API to libsolv
|
Summary: Library providing simplified C and Python API to libsolv
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/rpm-software-management/libdnf
|
URL: https://github.com/rpm-software-management/libdnf
|
||||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
Patch1: 0001-tests-Fix-incorrect-usage-of-the-fail-unless-macro.patch
|
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -309,6 +308,24 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 07 2020 Nicola Sella <nsella@redhat.com> - 0.54.2-1
|
||||||
|
- Update to 0.54.2
|
||||||
|
- history: Fix dnf history rollback when a package was removed (RhBug:1683134)
|
||||||
|
- Add support for HY_GT, HY_LT in query nevra_strict
|
||||||
|
- Fix parsing empty lines in config files
|
||||||
|
- Accept '==' as an operator in reldeps (RhBug:1847946)
|
||||||
|
- Add log file level main config option (RhBug:1802074)
|
||||||
|
- Add protect_running_kernel configuration option (RhBug:1698145)
|
||||||
|
- Context part of libdnf cannot assume zchunk is on (RhBug:1851841,1779104)
|
||||||
|
- Fix memory leak of resultingModuleIndex and handle g_object refs
|
||||||
|
- Redirect librepo logs to libdnf logs with different source
|
||||||
|
- Introduce changelog metadata in commit messages
|
||||||
|
- Add hy_goal_lock
|
||||||
|
- Update Copr targets for packit and use alias
|
||||||
|
- Enum/String conversions for Transaction Store/Replay
|
||||||
|
- utils: Add a method to decode URLs
|
||||||
|
- Unify hawkey.log line format with the rest of the logs
|
||||||
|
|
||||||
* Mon Aug 10 2020 Nicola Sella <nsella@redhat.com> - 0.48.0-4
|
* Mon Aug 10 2020 Nicola Sella <nsella@redhat.com> - 0.48.0-4
|
||||||
- spec: Fix building with new cmake macros
|
- spec: Fix building with new cmake macros
|
||||||
- tests: Fix incorrect usage of the fail_unless macros
|
- tests: Fix incorrect usage of the fail_unless macros
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libdnf-0.48.0.tar.gz) = fc1ce2612fb93fd6cfb134dc1348501c6f91b257d5c708c2aa84715c486af12cdd65eb150dec7346ba402c7c5da518f725353d4f9b4b42627abf97ffca2bf40b
|
SHA512 (libdnf-0.54.2.tar.gz) = 1d21440d528b69a4c2865c42dae6d2b001ddd16bc96138a6e2268869831530d6f2c140f6a30baf0bd2a448315fcb04dc3a042889d9b64ca40af5b4e06ebd2196
|
||||||
|
Loading…
Reference in New Issue
Block a user