Remove unused patch

This commit is contained in:
Aleš Matěj 2020-01-15 12:28:44 +01:00
parent 3545d967ac
commit 133bca88c6

View File

@ -1,69 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16b63308..c69026d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,6 +30,7 @@ option(WITH_BINDINGS "Enables python/SWIG bindings" ON)
option(WITH_GTKDOC "Enables libdnf GTK-Doc HTML documentation" ON)
option(WITH_HTML "Enables hawkey HTML generation" ON)
option(WITH_MAN "Enables hawkey man page generation" ON)
+option(WITH_ZCHUNK "Build with zchunk support" ON)
option(ENABLE_RHSM_SUPPORT "Build with Red Hat Subscription Manager support?" OFF)
option(ENABLE_SOLV_URPMREORDER "Build with support for URPM-like solution reordering?" OFF)
@@ -66,6 +67,12 @@ pkg_check_modules(SQLite3 REQUIRED sqlite3)
# always enable linking with libdnf utils
include_directories(${CMAKE_SOURCE_DIR} libdnf/utils/)
+if (WITH_ZCHUNK)
+ pkg_check_modules(ZCHUNKLIB zck>=0.9.11 REQUIRED)
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DWITH_ZCHUNK")
+ set (CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DWITH_ZCHUNK")
+endif ()
+
if(ENABLE_RHSM_SUPPORT)
pkg_check_modules(RHSM REQUIRED librhsm>=0.0.3)
include_directories(${RHSM_INCLUDE_DIRS})
diff --git a/libdnf.spec b/libdnf.spec
index 60091ccf..2e1f958c 100644
--- a/libdnf.spec
+++ b/libdnf.spec
@@ -32,6 +32,12 @@
%bcond_with rhsm
%endif
+%if 0%{?rhel}
+%bcond_with zchunk
+%else
+%bcond_without zchunk
+%endif
+
%global _cmake_opts \\\
-DENABLE_RHSM_SUPPORT=%{?with_rhsm:ON}%{!?with_rhsm:OFF} \\\
%{nil}
@@ -59,6 +65,9 @@ BuildRequires: rpm-devel >= %{rpm_version}
%if %{with rhsm}
BuildRequires: pkgconfig(librhsm) >= 0.0.3
%endif
+%if %{with zchunk}
+BuildRequires: pkgconfig(zck) >= 0.9.11
+%endif
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(json-c)
BuildRequires: pkgconfig(cppunit)
@@ -175,14 +184,14 @@ mkdir build-py3
%build
%if %{with python2}
pushd build-py2
- %cmake -DPYTHON_DESIRED:FILEPATH=%{__python2} -DWITH_MAN=OFF ../ %{!?with_valgrind:-DDISABLE_VALGRIND=1} %{_cmake_opts}
+ %cmake -DPYTHON_DESIRED:FILEPATH=%{__python2} -DWITH_MAN=OFF ../ %{!?with_zchunk:-DWITH_ZCHUNK=OFF} %{!?with_valgrind:-DDISABLE_VALGRIND=1} %{_cmake_opts}
%make_build
popd
%endif # with python2
%if %{with python3}
pushd build-py3
- %cmake -DPYTHON_DESIRED:FILEPATH=%{__python3} -DWITH_GIR=0 -DWITH_MAN=0 -Dgtkdoc=0 ../ %{!?with_valgrind:-DDISABLE_VALGRIND=1} %{_cmake_opts}
+ %cmake -DPYTHON_DESIRED:FILEPATH=%{__python3} -DWITH_GIR=0 -DWITH_MAN=0 -Dgtkdoc=0 ../ %{!?with_zchunk:-DWITH_ZCHUNK=OFF} %{!?with_valgrind:-DDISABLE_VALGRIND=1} %{_cmake_opts}
%make_build
popd
%endif