Update libdex to 0.8.1

Resolves: RHEL-65866
This commit is contained in:
Christian Hergert 2024-11-05 12:02:52 -08:00
parent b8998fb0c6
commit 009fc19738
4 changed files with 4 additions and 44 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@
/libdex-0.4.3.tar.xz
/libdex-0.6.0.tar.xz
/libdex-0.6.1.tar.xz
/libdex-0.8.1.tar.xz

View File

@ -1,39 +0,0 @@
From 95b957d5381ae6b313333f50bb941e9970d55127 Mon Sep 17 00:00:00 2001
From: Christian Hergert <chergert@redhat.com>
Date: Wed, 12 Jun 2024 11:17:52 -0700
Subject: [PATCH] build: avoid asm.S on general Linux when possible
We only use asm.S when on mips when we're on Linux. Removing this means
for the other Linux cases means the compiler can automatically enable some
features we might want like CET for indirect branches.
---
src/meson.build | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/meson.build b/src/meson.build
index 2967968..4a106a1 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -91,10 +91,18 @@ if host_machine.system() != 'windows'
# Not really used on Windows now, see also
# https://github.com/mesonbuild/meson/issues/4366
libdex_sources += [
- 'asm.S',
'dex-unix-signal.c',
'dex-ucontext.c',
]
+
+ # If we're on Linux and mips we might still need asm.S.
+ # But otherwise linux can do it all without any custom
+ # assembler. Failure to do this might result in CET being
+ # disabled for the process by GCC.
+ if host_machine.system() != 'linux' or host_machine.cpu_family() == 'mips'
+ libdex_sources += ['asm.S']
+ endif
+
libdex_headers += ['dex-unix-signal.h']
endif
--
2.45.1

View File

@ -1,13 +1,11 @@
Name: libdex
Version: 0.6.1
Version: 0.8.1
Release: %autorelease
Summary: a library supporting "Deferred Execution" for GNOME and GTK
License: LGPL-2.1-or-later
URL: https://gitlab.gnome.org/GNOME/libdex
Source0: https://download.gnome.org/sources/libdex/0.6/%{name}-%{version}.tar.xz
Patch0: avoid-asm.patch
Source0: https://download.gnome.org/sources/libdex/0.8/%{name}-%{version}.tar.xz
BuildRequires: /usr/bin/vapigen
BuildRequires: gcc

View File

@ -1 +1 @@
SHA512 (libdex-0.6.1.tar.xz) = 36be15d2da9edeae195abcb6f97639dd7fdea74463cdfdf752293007e44ab41a5e5350a7005883f202d70f96047567fba6370f1a2c45a0f898c242bebc88e847
SHA512 (libdex-0.8.1.tar.xz) = fc3f4d81b3a3e5c87758b2f706dc02c558becafc489c620ca491ca3b658f4c00cbc48886c6f5271e7308c4d7255610ec7ece1ad77308b5fac6088402a96543e0