update to 5.1.19
This commit is contained in:
parent
18ca0b1652
commit
abfc24384e
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
db.1.85.tar.gz
|
db.1.85.tar.gz
|
||||||
db-5.0.26.tar.gz
|
db-5.1.19.tar.gz
|
||||||
|
@ -1,14 +1,14 @@
|
|||||||
diff -up db-5.0.21/dist/Makefile.in.185compat db-5.0.21/dist/Makefile.in
|
diff -up db-5.1.19/dist/Makefile.in.185compat db-5.1.19/dist/Makefile.in
|
||||||
--- db-5.0.21/dist/Makefile.in.185compat 2010-03-30 19:36:10.000000000 +0200
|
--- db-5.1.19/dist/Makefile.in.185compat 2010-08-27 17:08:03.000000000 +0200
|
||||||
+++ db-5.0.21/dist/Makefile.in 2010-04-01 08:03:05.000000000 +0200
|
+++ db-5.1.19/dist/Makefile.in 2010-09-10 10:02:32.974640425 +0200
|
||||||
@@ -186,8 +186,8 @@ libtso_major= $(libtcl_base)-$(LIBMAJOR)
|
@@ -193,8 +193,8 @@ libtso_major= $(libtcl_base)-$(LIBMAJOR)
|
||||||
# local libraries, for example. Do that by adding -I options to the DB185INC
|
# local libraries, for example. Do that by adding -I options to the DB185INC
|
||||||
# line, and -l options to the DB185LIB line.
|
# line, and -l options to the DB185LIB line.
|
||||||
##################################################
|
##################################################
|
||||||
-DB185INC= -c @CFLAGS@ -I$(srcdir) @CPPFLAGS@
|
-DB185INC= -c @CFLAGS@ -I$(topdir) @CPPFLAGS@
|
||||||
-DB185LIB=
|
-DB185LIB=
|
||||||
+DB185INC= -c @CFLAGS@ -I$(srcdir) -I$(srcdir)/db.1.85/PORT/linux/include @CPPFLAGS@
|
+DB185INC= -c @CFLAGS@ -I$(srcdir) -I$(srcdir)/db.1.85/PORT/linux/include @CPPFLAGS@
|
||||||
+DB185LIB= ${srcdir}/db.1.85/PORT/linux/libdb.a
|
+DB185LIB= ${srcdir}/db.1.85/PORT/linux/libdb.a
|
||||||
|
|
||||||
##################################################
|
##################################################
|
||||||
# Event tracing definitions
|
# Performance Event Monitoring definitions
|
||||||
|
155
libdb.spec
155
libdb.spec
@ -1,12 +1,10 @@
|
|||||||
# the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
|
|
||||||
%define java_arches %{ix86} alpha ia64 ppc sparc sparcv9 x86_64 s390 s390x
|
|
||||||
%define __soversion_major 5
|
%define __soversion_major 5
|
||||||
%define __soversion %{__soversion_major}.0
|
%define __soversion %{__soversion_major}.1
|
||||||
|
|
||||||
Summary: The Berkeley DB database library for C
|
Summary: The Berkeley DB database library for C
|
||||||
Name: libdb
|
Name: libdb
|
||||||
Version: 5.0.26
|
Version: 5.1.19
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
|
Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
|
||||||
Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
|
Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
|
||||||
# db-1.85 upstream patches
|
# db-1.85 upstream patches
|
||||||
@ -23,10 +21,8 @@ License: BSD
|
|||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
BuildRequires: perl, libtool
|
BuildRequires: perl, libtool
|
||||||
BuildRequires: tcl-devel >= 8.5.2-3
|
BuildRequires: tcl-devel >= 8.5.2-3
|
||||||
%ifarch %{java_arches}
|
|
||||||
BuildRequires: gcc-java
|
BuildRequires: gcc-java
|
||||||
BuildRequires: java-1.6.0-openjdk-devel
|
BuildRequires: java-1.6.0-openjdk-devel
|
||||||
%endif
|
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
BuildRequires: dos2unix
|
BuildRequires: dos2unix
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -41,21 +37,6 @@ recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
|
|||||||
used by many applications, including Python and Perl, so this should
|
used by many applications, including Python and Perl, so this should
|
||||||
be installed on all systems.
|
be installed on all systems.
|
||||||
|
|
||||||
%package cxx
|
|
||||||
Summary: The Berkeley DB database library for C++
|
|
||||||
Group: System Environment/Libraries
|
|
||||||
Requires: %{name} = %{version}-%{release}
|
|
||||||
|
|
||||||
%description cxx
|
|
||||||
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
|
||||||
provides embedded database support for both traditional and
|
|
||||||
client/server applications. The Berkeley DB includes B+tree, Extended
|
|
||||||
Linear Hashing, Fixed and Variable-length record access methods,
|
|
||||||
transactions, locking, logging, shared memory caching, and database
|
|
||||||
recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
|
|
||||||
used by many applications, including Python and Perl, so this should
|
|
||||||
be installed on all systems.
|
|
||||||
|
|
||||||
%package utils
|
%package utils
|
||||||
Summary: Command line tools for managing Berkeley DB databases
|
Summary: Command line tools for managing Berkeley DB databases
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
@ -73,7 +54,6 @@ recovery. DB supports C, C++, Java and Perl APIs.
|
|||||||
Summary: C development files for the Berkeley DB library
|
Summary: C development files for the Berkeley DB library
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: %{name}-cxx = %{version}-%{release}
|
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
||||||
@ -82,46 +62,66 @@ client/server applications. This package contains the header files,
|
|||||||
libraries, and documentation for building programs which use the
|
libraries, and documentation for building programs which use the
|
||||||
Berkeley DB.
|
Berkeley DB.
|
||||||
|
|
||||||
%package devel-static
|
%package static
|
||||||
Summary: Berkeley DB static libraries
|
Summary: Berkeley DB static libraries
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: %{name}-devel = %{version}-%{release}
|
||||||
|
|
||||||
%description devel-static
|
%description static
|
||||||
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
||||||
provides embedded database support for both traditional and
|
provides embedded database support for both traditional and
|
||||||
client/server applications. This package contains static libraries
|
client/server applications. This package contains static libraries
|
||||||
needed for applications that require static linking of
|
needed for applications that require static linking of
|
||||||
Berkeley DB.
|
Berkeley DB.
|
||||||
|
|
||||||
%package tcl
|
%package cxx-devel
|
||||||
|
Summary: The Berkeley DB database library for C++
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: %{name}-devel = %{version}-%{release}
|
||||||
|
|
||||||
|
%description cxx-devel
|
||||||
|
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
||||||
|
provides embedded database support for both traditional and
|
||||||
|
client/server applications. The Berkeley DB includes B+tree, Extended
|
||||||
|
Linear Hashing, Fixed and Variable-length record access methods,
|
||||||
|
transactions, locking, logging, shared memory caching, and database
|
||||||
|
recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
|
||||||
|
used by many applications, including Python and Perl, so this should
|
||||||
|
be installed on all systems.
|
||||||
|
|
||||||
|
%package tcl-devel
|
||||||
Summary: Development files for using the Berkeley DB with tcl
|
Summary: Development files for using the Berkeley DB with tcl
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: %{name}-devel = %{version}-%{release}
|
||||||
|
|
||||||
%description tcl
|
%description tcl-devel
|
||||||
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
||||||
provides embedded database support for both traditional and
|
provides embedded database support for both traditional and
|
||||||
client/server applications. This package contains the libraries
|
client/server applications. This package contains the libraries
|
||||||
for building programs which use the Berkeley DB in Tcl.
|
for building programs which use the Berkeley DB in Tcl.
|
||||||
|
|
||||||
%package sql
|
%package sql-devel
|
||||||
Summary: Development files for using the Berkeley DB with sql
|
Summary: Development files for using the Berkeley DB with sql
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: %{name}-devel = %{version}-%{release}
|
||||||
|
|
||||||
%description sql
|
%description sql-devel
|
||||||
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
||||||
provides embedded database support for both traditional and
|
provides embedded database support for both traditional and
|
||||||
client/server applications. This package contains the libraries
|
client/server applications. This package contains the libraries
|
||||||
for building programs which use the Berkeley DB in SQL.
|
for building programs which use the Berkeley DB in SQL.
|
||||||
|
|
||||||
%package java
|
%package java-devel
|
||||||
Summary: Development files for using the Berkeley DB with Java
|
Summary: Development files for using the Berkeley DB with Java
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: %{name}-devel = %{version}-%{release}
|
||||||
|
|
||||||
%description java
|
%description java-devel
|
||||||
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
|
||||||
provides embedded database support for both traditional and
|
provides embedded database support for both traditional and
|
||||||
client/server applications. This package contains the libraries
|
client/server applications. This package contains the libraries
|
||||||
@ -143,44 +143,6 @@ popd
|
|||||||
%patch22 -p1 -b .185compat
|
%patch22 -p1 -b .185compat
|
||||||
%patch24 -p1 -b .4.5.20.jni
|
%patch24 -p1 -b .4.5.20.jni
|
||||||
|
|
||||||
# fix encoding
|
|
||||||
dos2unix examples_c/bench_001.c
|
|
||||||
|
|
||||||
# Define a shell function for fixing HREF references in the docs, which
|
|
||||||
# would otherwise break when we split the docs up into subpackages.
|
|
||||||
fixup_href() {
|
|
||||||
for doc in $@ ; do
|
|
||||||
chmod u+w ${doc}
|
|
||||||
sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
|
|
||||||
-e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
|
|
||||||
-e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
|
|
||||||
-e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
|
|
||||||
-e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
|
|
||||||
-e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
|
|
||||||
-e 's,="../java/,="../../%{name}-devel-%{version}/java/,g' \
|
|
||||||
-e 's,="java/,="../%{name}-devel-%{version}/java/,g' \
|
|
||||||
-e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
|
|
||||||
-e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
|
|
||||||
-e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
|
|
||||||
-e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
|
|
||||||
-e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
|
|
||||||
-e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
|
|
||||||
-e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
|
|
||||||
-e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
|
|
||||||
-e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
|
|
||||||
-e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
|
|
||||||
touch -r ${doc} ${doc}.new
|
|
||||||
cat ${doc}.new > ${doc}
|
|
||||||
touch -r ${doc}.new ${doc}
|
|
||||||
rm -f ${doc}.new
|
|
||||||
done
|
|
||||||
}
|
|
||||||
|
|
||||||
set +x
|
|
||||||
# Fix all of the HTML files.
|
|
||||||
fixup_href `find . -name "*.html"`
|
|
||||||
set -x
|
|
||||||
|
|
||||||
cd dist
|
cd dist
|
||||||
./s_config
|
./s_config
|
||||||
|
|
||||||
@ -193,7 +155,7 @@ make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
|
|||||||
build() {
|
build() {
|
||||||
test -d dist/$1 || mkdir dist/$1
|
test -d dist/$1 || mkdir dist/$1
|
||||||
# Static link db_dump185 with old db-185 libraries.
|
# Static link db_dump185 with old db-185 libraries.
|
||||||
/bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
|
/bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/$1/db_dump185.lo
|
||||||
/bin/sh libtool --mode=link %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
|
/bin/sh libtool --mode=link %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
|
||||||
|
|
||||||
pushd dist
|
pushd dist
|
||||||
@ -208,11 +170,7 @@ build() {
|
|||||||
--enable-shared --enable-static \
|
--enable-shared --enable-static \
|
||||||
--enable-tcl --with-tcl=%{_libdir} \
|
--enable-tcl --with-tcl=%{_libdir} \
|
||||||
--enable-cxx --enable-sql \
|
--enable-cxx --enable-sql \
|
||||||
%ifarch %{java_arches}
|
|
||||||
--enable-java \
|
--enable-java \
|
||||||
%else
|
|
||||||
--disable-java \
|
|
||||||
%endif
|
|
||||||
--enable-test \
|
--enable-test \
|
||||||
--with-tcl=%{_libdir}/tcl8.5 \
|
--with-tcl=%{_libdir}/tcl8.5 \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
@ -262,7 +220,7 @@ if [ "%{_libdir}" != "/%{_lib}" ]; then
|
|||||||
mkdir -p $RPM_BUILD_ROOT/%{_lib}/
|
mkdir -p $RPM_BUILD_ROOT/%{_lib}/
|
||||||
mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
|
mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
|
||||||
|
|
||||||
# Leave relative symlinks in %{_libdir}.
|
# Leave relative symlinks in %%{_libdir}.
|
||||||
touch $RPM_BUILD_ROOT/rootfile
|
touch $RPM_BUILD_ROOT/rootfile
|
||||||
root=..
|
root=..
|
||||||
while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
|
while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
|
||||||
@ -285,11 +243,9 @@ for i in db.h db_cxx.h db_185.h; do
|
|||||||
ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
|
ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
|
||||||
done
|
done
|
||||||
|
|
||||||
%ifarch %{java_arches}
|
|
||||||
# Move java jar file to the correct place
|
# Move java jar file to the correct place
|
||||||
mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
|
mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
|
||||||
mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
|
mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
|
||||||
%endif
|
|
||||||
|
|
||||||
# Eliminate installed doco
|
# Eliminate installed doco
|
||||||
rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
|
rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
|
||||||
@ -316,21 +272,21 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%post -p /sbin/ldconfig cxx
|
%post -p /sbin/ldconfig cxx-devel
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig cxx
|
%postun -p /sbin/ldconfig cxx-devel
|
||||||
|
|
||||||
%post -p /sbin/ldconfig sql
|
%post -p /sbin/ldconfig sql-devel
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig sql
|
%postun -p /sbin/ldconfig sql-devel
|
||||||
|
|
||||||
%post -p /sbin/ldconfig tcl
|
%post -p /sbin/ldconfig tcl-devel
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig tcl
|
%postun -p /sbin/ldconfig tcl-devel
|
||||||
|
|
||||||
%post -p /sbin/ldconfig java
|
%post -p /sbin/ldconfig java-devel
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig java
|
%postun -p /sbin/ldconfig java-devel
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -338,8 +294,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
/%{_lib}/libdb-%{__soversion}.so
|
/%{_lib}/libdb-%{__soversion}.so
|
||||||
%{_libdir}/libdb-%{__soversion}.so
|
%{_libdir}/libdb-%{__soversion}.so
|
||||||
|
|
||||||
%files cxx
|
%files cxx-devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
|
%doc examples/cxx
|
||||||
|
%{_libdir}/libdb_cxx.so
|
||||||
%{_libdir}/libdb_cxx-%{__soversion}.so
|
%{_libdir}/libdb_cxx-%{__soversion}.so
|
||||||
|
|
||||||
%files utils
|
%files utils
|
||||||
@ -352,6 +310,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_bindir}/db*_load
|
%{_bindir}/db*_load
|
||||||
%{_bindir}/db*_printlog
|
%{_bindir}/db*_printlog
|
||||||
%{_bindir}/db*_recover
|
%{_bindir}/db*_recover
|
||||||
|
%{_bindir}/db*_replicate
|
||||||
%{_bindir}/db*_stat
|
%{_bindir}/db*_stat
|
||||||
%{_bindir}/db*_upgrade
|
%{_bindir}/db*_upgrade
|
||||||
%{_bindir}/db*_verify
|
%{_bindir}/db*_verify
|
||||||
@ -359,9 +318,8 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc docs/*
|
%doc docs/*
|
||||||
%doc examples_c examples_cxx
|
%doc examples/c
|
||||||
%{_libdir}/libdb.so
|
%{_libdir}/libdb.so
|
||||||
%{_libdir}/libdb_cxx.so
|
|
||||||
%dir %{_includedir}/%{name}
|
%dir %{_includedir}/%{name}
|
||||||
%{_includedir}/%{name}/db.h
|
%{_includedir}/%{name}/db.h
|
||||||
%{_includedir}/%{name}/db_185.h
|
%{_includedir}/%{name}/db_185.h
|
||||||
@ -370,37 +328,38 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_includedir}/db_185.h
|
%{_includedir}/db_185.h
|
||||||
%{_includedir}/db_cxx.h
|
%{_includedir}/db_cxx.h
|
||||||
|
|
||||||
%files devel-static
|
%files static
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libdb-%{__soversion}.a
|
%{_libdir}/libdb-%{__soversion}.a
|
||||||
%{_libdir}/libdb_cxx-%{__soversion}.a
|
%{_libdir}/libdb_cxx-%{__soversion}.a
|
||||||
%{_libdir}/libdb_tcl-%{__soversion}.a
|
%{_libdir}/libdb_tcl-%{__soversion}.a
|
||||||
%{_libdir}/libdb_sql-%{__soversion}.a
|
%{_libdir}/libdb_sql-%{__soversion}.a
|
||||||
%ifarch %{java_arches}
|
|
||||||
%{_libdir}/libdb_java-%{__soversion}.a
|
%{_libdir}/libdb_java-%{__soversion}.a
|
||||||
%endif
|
|
||||||
|
|
||||||
%files tcl
|
%files tcl-devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libdb_tcl-%{__soversion}.so
|
%{_libdir}/libdb_tcl-%{__soversion}.so
|
||||||
|
|
||||||
%files sql
|
%files sql-devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
|
%doc examples/sql
|
||||||
%{_bindir}/dbsql
|
%{_bindir}/dbsql
|
||||||
%{_libdir}/libdb_sql.so
|
%{_libdir}/libdb_sql.so
|
||||||
%{_libdir}/libdb_sql-%{__soversion}.so
|
%{_libdir}/libdb_sql-%{__soversion}.so
|
||||||
%{_includedir}/%{name}/dbsql.h
|
%{_includedir}/%{name}/dbsql.h
|
||||||
|
|
||||||
%ifarch %{java_arches}
|
%files java-devel
|
||||||
%files java
|
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc docs/java
|
%doc examples/java
|
||||||
%doc examples_java
|
|
||||||
%{_libdir}/libdb_java*.so
|
%{_libdir}/libdb_java*.so
|
||||||
%{_datadir}/java/*.jar
|
%{_datadir}/java/*.jar
|
||||||
%endif
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
|
||||||
|
- update to 5.1.19
|
||||||
|
- rename -devel-static to -static subpackage (#617800)
|
||||||
|
- build java on all arches
|
||||||
|
|
||||||
* Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
|
* Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
|
||||||
- update to 5.0.26
|
- update to 5.0.26
|
||||||
- drop BR: ed
|
- drop BR: ed
|
||||||
|
Loading…
Reference in New Issue
Block a user