import libdatrie-0.2.9-7.el8
This commit is contained in:
commit
59e01f97b5
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/libdatrie-0.2.9.tar.xz
|
1
.libdatrie.metadata
Normal file
1
.libdatrie.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
d1e14729d950a0a2a484d768cf9eeebaa20f998e SOURCES/libdatrie-0.2.9.tar.xz
|
14
SOURCES/libdatrie-fixes-docs.patch
Normal file
14
SOURCES/libdatrie-fixes-docs.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
Index: libdatrie-0.2.9/configure.ac
|
||||||
|
===================================================================
|
||||||
|
--- libdatrie-0.2.9.orig/configure.ac
|
||||||
|
+++ libdatrie-0.2.9/configure.ac
|
||||||
|
@@ -113,7 +113,8 @@ if test "x$enable_doxygen_doc" = "xyes";
|
||||||
|
else
|
||||||
|
AC_MSG_CHECKING([doxygen >= $DOXYGEN_REQ_VER])
|
||||||
|
DOXYGEN_VER=$($DOXYGEN --version)
|
||||||
|
- if expr $DOXYGEN_VER \< $DOXYGEN_REQ_VER > /dev/null; then
|
||||||
|
+ AS_VERSION_COMPARE($DOXYGEN_VER, $DOXYGEN_REQ_VER, [HAVE_DOXYGEN=0], [HAVE_DOXYGEN=1], [HAVE_DOXYGEN=1])
|
||||||
|
+ if [test "$HAVE_DOXYGEN" = "0"]; then
|
||||||
|
AC_MSG_RESULT([$DOXYGEN_VER, no, documentation disabled])
|
||||||
|
enable_doxygen_doc="no"
|
||||||
|
else
|
107
SPECS/libdatrie.spec
Normal file
107
SPECS/libdatrie.spec
Normal file
@ -0,0 +1,107 @@
|
|||||||
|
Name: libdatrie
|
||||||
|
Version: 0.2.9
|
||||||
|
Release: 7%{?dist}
|
||||||
|
Summary: Implementation of Double-Array structure for representing trie
|
||||||
|
License: LGPLv2+
|
||||||
|
URL: http://linux.thai.net/projects/datrie
|
||||||
|
Source0: http://linux.thai.net/pub/thailinux/software/libthai/%{name}-%{version}.tar.xz
|
||||||
|
Patch0: libdatrie-fixes-docs.patch
|
||||||
|
BuildRequires: autoconf, automake, libtool
|
||||||
|
BuildRequires: doxygen
|
||||||
|
|
||||||
|
%description
|
||||||
|
datrie is an implementation of double-array structure for representing trie.
|
||||||
|
|
||||||
|
Trie is a kind of digital search tree, an efficient indexing method with O(1)
|
||||||
|
time complexity for searching. Comparably as efficient as hashing, trie also
|
||||||
|
provides flexibility on incremental matching and key spelling manipulation.
|
||||||
|
This makes it ideal for lexical analyzers, as well as spelling dictionaries.
|
||||||
|
|
||||||
|
Details of the implementation: http://linux.thai.net/~thep/datrie/datrie.html
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .docs
|
||||||
|
|
||||||
|
%build
|
||||||
|
autoreconf -f -i -v
|
||||||
|
#sed -i '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64|' configure
|
||||||
|
%configure --disable-static \
|
||||||
|
--with-html-docdir=%{_pkgdocdir}-devel
|
||||||
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
|
%make_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install
|
||||||
|
rm -frv %{buildroot}%{_pkgdocdir}
|
||||||
|
find %{buildroot} -name '*.*a' -delete -print
|
||||||
|
|
||||||
|
%check
|
||||||
|
LD_LIBRARY_PATH=../datrie/.libs %make_build check
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license COPYING
|
||||||
|
%{_libdir}/libdatrie.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc AUTHORS ChangeLog NEWS README*
|
||||||
|
%{_includedir}/datrie/
|
||||||
|
%{_libdir}/libdatrie.so
|
||||||
|
%{_libdir}/pkgconfig/datrie-0.2.pc
|
||||||
|
%{_bindir}/trietool*
|
||||||
|
%{_mandir}/man1/trietool*
|
||||||
|
%{_pkgdocdir}-devel/*.{html,css,png,js}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.9-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.9-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.9-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.9-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 6 2016 Peng Wu <pwu@redhat.com> - 0.2.9-3
|
||||||
|
- Fixes docs build
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.9-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Christopher Meng <rpm@cicku.me> - 0.2.9-1
|
||||||
|
- Update to 0.2.9
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.8-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.8-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 18 2014 Christopher Meng <rpm@cicku.me> - 0.2.8-4
|
||||||
|
- Move docs to %%_pkgdocdir
|
||||||
|
|
||||||
|
* Mon Feb 24 2014 Christopher Meng <rpm@cicku.me> - 0.2.8-3
|
||||||
|
- Disable rpath.
|
||||||
|
|
||||||
|
* Sat Feb 08 2014 Christopher Meng <rpm@cicku.me> - 0.2.8-2
|
||||||
|
- Reform the subpackages.
|
||||||
|
- Add check section to ensure the availability.
|
||||||
|
|
||||||
|
* Tue Jan 07 2014 Christopher Meng <rpm@cicku.me> - 0.2.8-1
|
||||||
|
- Initial Package.
|
Loading…
Reference in New Issue
Block a user