libcgroup/libcgroup-tests-unbundle-gtest.patch
Nikola Forró e623b7ca46 New upstream release 3.0
- resolves: #2115990
2022-08-08 18:24:20 +02:00

36 lines
1.2 KiB
Diff

diff --git a/tests/gunit/Makefile.am b/tests/gunit/Makefile.am
index ba91039..e2b88e3 100644
--- a/tests/gunit/Makefile.am
+++ b/tests/gunit/Makefile.am
@@ -9,8 +9,6 @@
AM_CPPFLAGS = -I$(top_srcdir)/include \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/tools \
- -I$(top_srcdir)/googletest/googletest/include \
- -I$(top_srcdir)/googletest/googletest \
-std=c++11 \
-Wno-write-strings \
-DSTATIC= \
@@ -18,10 +16,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/include \
LDADD = $(top_builddir)/src/.libs/libcgroupfortesting.la \
$(top_builddir)/src/tools/.libs/libcgset.la
-EXTRA_DIST = $(top_srcdir)/googletest/googletest/libgtest.so \
- $(top_srcdir)/googletest/googletest/libgtest_main.so \
- $(top_srcdir)/googletest/googletest/include \
- libcgroup_unittest.map
+EXTRA_DIST = libcgroup_unittest.map
check_PROGRAMS = gtest
TESTS = gtest
@@ -43,8 +38,7 @@ gtest_SOURCES = gtest.cpp \
014-cgroupv2_get_subtree_control.cpp \
015-cgroupv2_controller_enabled.cpp \
016-cgset_parse_r_flag.cpp
-gtest_LDFLAGS = -L$(top_srcdir)/googletest/googletest -l:libgtest.so \
- -rpath $(abs_top_srcdir)/googletest/googletest
+gtest_LDFLAGS = -l:libgtest.so
clean-local:
${RM} test-procpidcgroup