Update to latest upstream, v0.33
This commit is contained in:
parent
d43cef0b76
commit
aa629fefaa
@ -1,2 +1 @@
|
|||||||
libcgroup-0.32.2.tar.bz2
|
libcgroup-0.33.tar.bz2
|
||||||
fix_makefile_dep.patch
|
|
||||||
|
16
01-fedora-fix-build.patch
Normal file
16
01-fedora-fix-build.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
---
|
||||||
|
Makefile.in | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
Index: v0.33/Makefile.in
|
||||||
|
===================================================================
|
||||||
|
--- v0.33.orig/Makefile.in
|
||||||
|
+++ v0.33/Makefile.in
|
||||||
|
@@ -26,6 +26,7 @@ datarootdir=@datarootdir@
|
||||||
|
mandir=@mandir@
|
||||||
|
INSTALL=install
|
||||||
|
INSTALL_DATA=install -m 644
|
||||||
|
+PACKAGE_VERSION=@PACKAGE_VERSION@
|
||||||
|
CFLAGS=@CFLAGS@ $(INC)
|
||||||
|
VERSION=1
|
||||||
|
|
30
02-fedora-fix-initscripts.patch
Normal file
30
02-fedora-fix-initscripts.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
---
|
||||||
|
scripts/init.d/cgconfig | 2 +-
|
||||||
|
scripts/init.d/cgred | 1 -
|
||||||
|
2 files changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
|
Index: v0.33/scripts/init.d/cgconfig
|
||||||
|
===================================================================
|
||||||
|
--- v0.33.orig/scripts/init.d/cgconfig
|
||||||
|
+++ v0.33/scripts/init.d/cgconfig
|
||||||
|
@@ -44,7 +44,7 @@ servicename=cgconfig
|
||||||
|
#
|
||||||
|
# Source LSB routines
|
||||||
|
#
|
||||||
|
-. /lib/lsb/init-functions
|
||||||
|
+. /etc/rc.d/init.d/functions
|
||||||
|
|
||||||
|
parse_mounts() {
|
||||||
|
while read name mountpt fs opts other
|
||||||
|
Index: v0.33/scripts/init.d/cgred
|
||||||
|
===================================================================
|
||||||
|
--- v0.33.orig/scripts/init.d/cgred
|
||||||
|
+++ v0.33/scripts/init.d/cgred
|
||||||
|
@@ -43,7 +43,6 @@ CGRED_BIN=${exec_prefix}/${bindir}/cgrul
|
||||||
|
|
||||||
|
# Source function library & LSB routines
|
||||||
|
. /etc/rc.d/init.d/functions
|
||||||
|
-. /lib/lsb/init-functions
|
||||||
|
|
||||||
|
# Read in configuration options.
|
||||||
|
if [ -f "/etc/sysconfig/cgred.conf" ] ; then
|
@ -1,12 +1,13 @@
|
|||||||
Name: libcgroup
|
Name: libcgroup
|
||||||
Summary: Tools and libraries to control and monitor control groups
|
Summary: Tools and libraries to control and monitor control groups
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Version: 0.32.2
|
Version: 0.33
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://libcg.sourceforge.net/
|
URL: http://libcg.sourceforge.net/
|
||||||
Source0: http://downloads.sourceforge.net/libcg/%{name}-%{version}.tar.bz2
|
Source0: http://downloads.sourceforge.net/libcg/%{name}-%{version}.tar.bz2
|
||||||
Patch0: http://downloads.sourceforge.net/libcg/fix_makefile_dep.patch
|
Patch0: http://downloads.sourceforge.net/libcg/01-fedora-fix-build.patch
|
||||||
|
Patch1: http://downloads.sourceforge.net/libcg/02-fedora-fix-initscripts.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: byacc
|
BuildRequires: byacc
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
@ -16,7 +17,6 @@ Requires(post): chkconfig
|
|||||||
Requires(post): initscripts
|
Requires(post): initscripts
|
||||||
Requires(preun): initscripts
|
Requires(preun): initscripts
|
||||||
Requires(preun): chkconfig
|
Requires(preun): chkconfig
|
||||||
Requires: redhat-lsb
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Control groups infrastructure. The tools and library help manipulate, control,
|
Control groups infrastructure. The tools and library help manipulate, control,
|
||||||
@ -35,6 +35,7 @@ provide scripts to manage that configuration.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -47,6 +48,13 @@ make DESTDIR=$RPM_BUILD_ROOT install
|
|||||||
mkdir -p $RPM_BUILD_ROOT/%{_initrddir}
|
mkdir -p $RPM_BUILD_ROOT/%{_initrddir}
|
||||||
cp scripts/init.d/cgconfig $RPM_BUILD_ROOT/%{_initrddir}/cgconfig
|
cp scripts/init.d/cgconfig $RPM_BUILD_ROOT/%{_initrddir}/cgconfig
|
||||||
cp scripts/init.d/cgred $RPM_BUILD_ROOT/%{_initrddir}/cgred
|
cp scripts/init.d/cgred $RPM_BUILD_ROOT/%{_initrddir}/cgred
|
||||||
|
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig
|
||||||
|
cp samples/cgred.conf $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cgred.conf
|
||||||
|
cp samples/cgconfig.conf $RPM_BUILD_ROOT/%{_sysconfdir}/cgconfig.conf
|
||||||
|
cp samples/cgrules.conf $RPM_BUILD_ROOT/%{_sysconfdir}/cgrules.conf
|
||||||
|
mkdir -p $RPM_BUILD_ROOT/%{_lib}/security/
|
||||||
|
mv $RPM_BUILD_ROOT/%{_libdir}/security/pam_cgroup.so \
|
||||||
|
$RPM_BUILD_ROOT/%{_lib}/security/
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -70,14 +78,21 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
|
%config(noreplace) %{_sysconfdir}/sysconfig/cgred.conf
|
||||||
|
%config(noreplace) %{_sysconfdir}/cgconfig.conf
|
||||||
|
%config(noreplace) %{_sysconfdir}/cgrules.conf
|
||||||
%{_libdir}/libcgroup-%{version}.so
|
%{_libdir}/libcgroup-%{version}.so
|
||||||
%{_libdir}/libcgroup.so.*
|
%{_libdir}/libcgroup.so.*
|
||||||
%{_bindir}/cgexec
|
%{_bindir}/cgexec
|
||||||
%{_bindir}/cgclassify
|
%{_bindir}/cgclassify
|
||||||
%{_sbindir}/cgconfigparser
|
%{_sbindir}/cgconfigparser
|
||||||
%{_bindir}/cgrulesengd
|
%{_bindir}/cgrulesengd
|
||||||
|
%attr(0644, root, root) %{_mandir}/man1/*
|
||||||
|
%attr(0644, root, root) %{_mandir}/man5/*
|
||||||
|
%attr(0644, root, root) %{_mandir}/man8/*
|
||||||
%attr(0755,root,root) %{_initrddir}/cgconfig
|
%attr(0755,root,root) %{_initrddir}/cgconfig
|
||||||
%attr(0755,root,root) %{_initrddir}/cgred
|
%attr(0755,root,root) %{_initrddir}/cgred
|
||||||
|
%attr(0755,root,root) /%{_lib}/security/pam_cgroup.so
|
||||||
|
|
||||||
%doc COPYING INSTALL README_daemon
|
%doc COPYING INSTALL README_daemon
|
||||||
|
|
||||||
@ -89,6 +104,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 02 2009 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.33-1
|
||||||
|
- Update to latest upstream
|
||||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.32.2-4
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.32.2-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user