parent
fd20da3288
commit
985de09420
2
.gitignore
vendored
2
.gitignore
vendored
@ -5,3 +5,5 @@
|
||||
/libcgroup-v2.0.1.tar.gz
|
||||
/3c0c7b164b4221d78459fccdd49643a5dcb3f73d.tar.gz
|
||||
/626dfc9e8dbad6dde09f43cfa086f31e945e2c8a.tar.gz
|
||||
/libcgroup-v2.0.2.tar.gz
|
||||
/3d3364813b7b80f42aa74f0bec9de33efadf4200.tar.gz
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --git a/src/api.c b/src/api.c
|
||||
index 0a0f756..5aefe85 100644
|
||||
index 8e6efe6..f41cb7e 100644
|
||||
--- a/src/api.c
|
||||
+++ b/src/api.c
|
||||
@@ -3067,29 +3067,29 @@ static int cg_rd_ctrl_file(const char *subsys, const char *cgroup,
|
||||
@@ -3084,29 +3084,29 @@ static int cg_rd_ctrl_file(const char *subsys, const char *cgroup,
|
||||
const char *file, char **value)
|
||||
{
|
||||
char path[FILENAME_MAX];
|
||||
@ -39,7 +39,7 @@ index 0a0f756..5aefe85 100644
|
||||
if (ret < 0) {
|
||||
free(*value);
|
||||
*value = NULL;
|
||||
@@ -3099,7 +3099,7 @@ static int cg_rd_ctrl_file(const char *subsys, const char *cgroup,
|
||||
@@ -3116,7 +3116,7 @@ static int cg_rd_ctrl_file(const char *subsys, const char *cgroup,
|
||||
(*value)[ret-1] = '\0';
|
||||
}
|
||||
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --git a/src/api.c b/src/api.c
|
||||
index 5aefe85..753f5ce 100644
|
||||
index f41cb7e..5088c58 100644
|
||||
--- a/src/api.c
|
||||
+++ b/src/api.c
|
||||
@@ -4059,10 +4059,10 @@ int cgroup_change_cgroup_flags(uid_t uid, gid_t gid,
|
||||
@@ -4076,10 +4076,10 @@ int cgroup_change_cgroup_flags(uid_t uid, gid_t gid,
|
||||
available, "%d", pid);
|
||||
break;
|
||||
case 'p':
|
||||
|
34
libcgroup-2.0.2-configure.ac.patch
Normal file
34
libcgroup-2.0.2-configure.ac.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From f97b7af366bd07c17fb63606116f5dfae665e08c Mon Sep 17 00:00:00 2001
|
||||
From: Tom Hromatka <tom.hromatka@oracle.com>
|
||||
Date: Wed, 23 Feb 2022 08:00:29 -0700
|
||||
Subject: [PATCH] configure: Delete legacy test artifacts
|
||||
|
||||
The legacy tests (now located in the libcgroup-tests)
|
||||
repository have been moved to
|
||||
https://github.com/libcgroup/libcgroup-tests/tree/main/examples
|
||||
and are no longer being run. Remove all references to
|
||||
the tests from the configure.ac file.
|
||||
|
||||
Signed-off-by: Tom Hromatka <tom.hromatka@oracle.com>
|
||||
Reviewed-by: Kamalesh Babulal <kamalesh.babulal@oracle.com>
|
||||
---
|
||||
configure.ac | 6 ------
|
||||
1 file changed, 6 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 30932001..ce8a7850 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -207,12 +207,6 @@ AC_CONFIG_FILES([Makefile
|
||||
tests/Makefile
|
||||
tests/ftests/Makefile
|
||||
tests/gunit/Makefile
|
||||
- tests/tools/testenv.sh
|
||||
- tests/tools/Makefile
|
||||
- tests/tools/cgconfigparser/Makefile
|
||||
- tests/tools/cgclassify/Makefile
|
||||
- tests/tools/multimount/Makefile
|
||||
- tests/runlibcgrouptest.sh
|
||||
src/Makefile
|
||||
src/daemon/Makefile
|
||||
src/tools/Makefile
|
@ -1,10 +1,10 @@
|
||||
%bcond_with tests
|
||||
|
||||
%global tests_commit 626dfc9e8dbad6dde09f43cfa086f31e945e2c8a
|
||||
%global tests_commit 3d3364813b7b80f42aa74f0bec9de33efadf4200
|
||||
|
||||
Summary: Library to control and monitor control groups
|
||||
Name: libcgroup
|
||||
Version: 2.0.1
|
||||
Version: 2.0.2
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: http://libcg.sourceforge.net/
|
||||
@ -17,7 +17,9 @@ Patch1: libcgroup-0.37-chmod.patch
|
||||
Patch2: libcgroup-0.40.rc1-coverity.patch
|
||||
Patch3: libcgroup-0.40.rc1-fread.patch
|
||||
Patch4: libcgroup-0.40.rc1-templates-fix.patch
|
||||
Patch5: libcgroup-tests-unbundle-gtest.patch
|
||||
Patch5: libcgroup-2.0.2-configure.ac.patch
|
||||
|
||||
Patch100: libcgroup-tests-unbundle-gtest.patch
|
||||
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
BuildRequires: gcc, gcc-c++
|
||||
@ -69,10 +71,11 @@ provide scripts to manage that configuration.
|
||||
%patch2 -p1 -b .coverity
|
||||
%patch3 -p1 -b .fread
|
||||
%patch4 -p1 -b .templates-fix
|
||||
%patch5 -p1 -b .configure.ac
|
||||
|
||||
%setup -D -T -a 1
|
||||
mv -T %{name}-tests-%{tests_commit} tests
|
||||
%patch5 -p1 -b .tests-unbundle-gtest
|
||||
%patch100 -p1 -b .tests-unbundle-gtest
|
||||
|
||||
%build
|
||||
autoreconf -vif
|
||||
@ -173,6 +176,10 @@ make -C tests/gunit check
|
||||
%{_libdir}/pkgconfig/libcgroup.pc
|
||||
|
||||
%changelog
|
||||
* Wed May 25 2022 Nikola Forró <nforro@redhat.com> - 2.0.2-1
|
||||
- New upstream release 2.0.2
|
||||
resolves: #2085318
|
||||
|
||||
* Sat Mar 12 2022 Nikola Forró <nforro@redhat.com> - 2.0.1-1
|
||||
- New upstream release 2.0.1
|
||||
resolves: #2063319
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (libcgroup-v2.0.1.tar.gz) = 2cb9df75e51b865e07c1f237b534a933d26cb923bf9db0d6924b0190fa71e66b9d416fa80767d88cf640e2dc6a7d6b1c5523ac54eadd3357d63853c60a1877e7
|
||||
SHA512 (626dfc9e8dbad6dde09f43cfa086f31e945e2c8a.tar.gz) = c3bebd2b54112547e1662243fb112d65dbbaf0b1ae1e04cf79d7588df2aee884165fa2b5a870a6925d343f763d0723327e395320054dcbabd133ec0dad59b5af
|
||||
SHA512 (libcgroup-v2.0.2.tar.gz) = ffda4212c93388f838c4b93a5820b6de4fce96e786b14f4c7476336f552ff7a390675fdf210f2b194ecbbab4801c7c688e9a668a96696cde681682cff45a0119
|
||||
SHA512 (3d3364813b7b80f42aa74f0bec9de33efadf4200.tar.gz) = 7eae070c1ce4c8af7ef9daa252088dbe6d871f8979ac0d0876c70dbb89c55bef7cd437e6c878de8db8ddb54c82f79b60c643fc936ffabde5ee952cee4f463326
|
||||
|
Loading…
Reference in New Issue
Block a user