libcgroup package is retired on c9s for CS-546
This commit is contained in:
parent
94f2ec094b
commit
0bef1c632c
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,5 +0,0 @@
|
||||
/libcgroup-0.41.tar.bz2
|
||||
/libcgroup-v0.42.1.tar.gz
|
||||
/libcgroup-v0.42.2.tar.gz
|
||||
/libcgroup-v2.0.tar.gz
|
||||
/3c0c7b164b4221d78459fccdd49643a5dcb3f73d.tar.gz
|
@ -1,18 +0,0 @@
|
||||
[Unit]
|
||||
Description=Control Group configuration service
|
||||
|
||||
# The service should be able to start as soon as possible,
|
||||
# before any 'normal' services:
|
||||
DefaultDependencies=no
|
||||
Conflicts=shutdown.target
|
||||
Before=basic.target shutdown.target
|
||||
|
||||
[Service]
|
||||
Type=oneshot
|
||||
RemainAfterExit=yes
|
||||
Delegate=yes
|
||||
ExecStart=/usr/sbin/cgconfigparser -l /etc/cgconfig.conf -s 1664
|
||||
ExecStop=/usr/sbin/cgclear -l /etc/cgconfig.conf -e
|
||||
|
||||
[Install]
|
||||
WantedBy=sysinit.target
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
||||
libcgroup package is retired on c9s for CS-546
|
@ -1,65 +0,0 @@
|
||||
Fedora specific configuration - we want to mount all controllers by default for libvirt.
|
||||
|
||||
diff -up libcgroup-0.34/samples/cgconfig.conf.orig libcgroup-0.34/samples/cgconfig.conf
|
||||
--- libcgroup-0.34/samples/cgconfig.conf.orig 2009-03-04 10:40:06.000000000 +0100
|
||||
+++ libcgroup-0.34/samples/cgconfig.conf 2009-10-19 10:17:37.000000000 +0200
|
||||
@@ -10,39 +10,8 @@
|
||||
# WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
|
||||
#
|
||||
-#group daemons/www {
|
||||
-# perm {
|
||||
-# task {
|
||||
-# uid = root;
|
||||
-# gid = webmaster;
|
||||
-# }
|
||||
-# admin {
|
||||
-# uid = root;
|
||||
-# gid = root;
|
||||
-# }
|
||||
-# }
|
||||
-# cpu {
|
||||
-# cpu.shares = 1000;
|
||||
-# }
|
||||
-#}
|
||||
#
|
||||
-#group daemons/ftp {
|
||||
-# perm {
|
||||
-# task {
|
||||
-# uid = root;
|
||||
-# gid = ftpmaster;
|
||||
-# }
|
||||
-# admin {
|
||||
-# uid = root;
|
||||
-# gid = root;
|
||||
-# }
|
||||
-# }
|
||||
-# cpu {
|
||||
-# cpu.shares = 500;
|
||||
-# }
|
||||
-#}
|
||||
-#
|
||||
-#mount {
|
||||
-# cpu = /mnt/cgroups/cpu;
|
||||
-# cpuacct = /mnt/cgroups/cpuacct;
|
||||
-#}
|
||||
+# By default, we expect systemd mounts everything on boot,
|
||||
+# so there is not much to do.
|
||||
+# See man cgconfig.conf for further details, how to create groups
|
||||
+# on system boot using this file.
|
||||
+
|
||||
diff -up libcgroup-0.35.1/samples/cgconfig.sysconfig.orig libcgroup-0.35.1/samples/cgconfig.sysconfig
|
||||
--- libcgroup-0.35.1/samples/cgconfig.sysconfig.orig 2010-03-09 14:56:34.000000000 +0100
|
||||
+++ libcgroup-0.35.1/samples/cgconfig.sysconfig 2010-03-09 16:30:12.000000000 +0100
|
||||
@@ -5,8 +5,6 @@
|
||||
# controller to limit cpu.shares of this default group and allowing some more
|
||||
# important group take most of the CPU.
|
||||
#
|
||||
-# By default, create these groups:
|
||||
-CREATE_DEFAULT=yes
|
||||
-
|
||||
-# Uncomment following line to disable creation of the default group on startup:
|
||||
-# CREATE_DEFAULT=no
|
||||
+# By default, do not create these groups:
|
||||
+# CREATE_DEFAULT=yes
|
||||
+CREATE_DEFAULT=no
|
@ -1,32 +0,0 @@
|
||||
diff --git a/src/api.c b/src/api.c
|
||||
index 4a980a1..df9afe8 100644
|
||||
--- a/src/api.c
|
||||
+++ b/src/api.c
|
||||
@@ -170,6 +170,10 @@ static int cg_chown_file(FTS *fts, FTSENT *ent, uid_t owner, gid_t group)
|
||||
return ret;
|
||||
}
|
||||
|
||||
+int cg_chmod_file(FTS *fts, FTSENT *ent, mode_t dir_mode,
|
||||
+ int dirm_change, mode_t file_mode, int filem_change,
|
||||
+ int owner_is_umask);
|
||||
+
|
||||
/*
|
||||
* TODO: Need to decide a better place to put this function.
|
||||
*/
|
||||
@@ -177,6 +181,8 @@ static int cg_chown_recursive(char **path, uid_t owner, gid_t group)
|
||||
{
|
||||
int ret = 0;
|
||||
FTS *fts;
|
||||
+ /* mode 664 */
|
||||
+ mode_t mode = S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH;
|
||||
|
||||
cgroup_dbg("chown: path is %s\n", *path);
|
||||
fts = fts_open(path, FTS_PHYSICAL | FTS_NOCHDIR |
|
||||
@@ -194,6 +200,7 @@ static int cg_chown_recursive(char **path, uid_t owner, gid_t group)
|
||||
cgroup_warn("Warning: fts_read failed\n");
|
||||
break;
|
||||
}
|
||||
+ cg_chmod_file(fts, ent, mode, 0, mode, 1, 1);
|
||||
ret = cg_chown_file(fts, ent, owner, group);
|
||||
}
|
||||
fts_close(fts);
|
@ -1,61 +0,0 @@
|
||||
diff --git a/src/config.c b/src/config.c
|
||||
index 1306033..88cc5dd 100644
|
||||
--- a/src/config.c
|
||||
+++ b/src/config.c
|
||||
@@ -326,7 +326,7 @@ int config_group_task_perm(char *perm_type, char *value, int flag)
|
||||
long val = atoi(value);
|
||||
char buffer[CGROUP_BUFFER_LEN];
|
||||
struct cgroup *config_cgroup;
|
||||
- int table_index;
|
||||
+ int table_index, ret;
|
||||
|
||||
switch (flag) {
|
||||
case CGROUP:
|
||||
@@ -370,10 +370,10 @@ int config_group_task_perm(char *perm_type, char *value, int flag)
|
||||
if (!group)
|
||||
goto group_task_error;
|
||||
|
||||
- getgrnam_r(value, group, buffer,
|
||||
+ ret = getgrnam_r(value, group, buffer,
|
||||
CGROUP_BUFFER_LEN, &group_buffer);
|
||||
|
||||
- if (group_buffer == NULL) {
|
||||
+ if (ret != 0 || group_buffer == NULL) {
|
||||
free(group);
|
||||
goto group_task_error;
|
||||
}
|
||||
@@ -439,7 +439,7 @@ int config_group_admin_perm(char *perm_type, char *value, int flag)
|
||||
struct cgroup *config_cgroup;
|
||||
long val = atoi(value);
|
||||
char buffer[CGROUP_BUFFER_LEN];
|
||||
- int table_index;
|
||||
+ int table_index, ret;
|
||||
|
||||
switch (flag) {
|
||||
case CGROUP:
|
||||
@@ -482,10 +482,10 @@ int config_group_admin_perm(char *perm_type, char *value, int flag)
|
||||
if (!group)
|
||||
goto admin_error;
|
||||
|
||||
- getgrnam_r(value, group, buffer,
|
||||
+ ret = getgrnam_r(value, group, buffer,
|
||||
CGROUP_BUFFER_LEN, &group_buffer);
|
||||
|
||||
- if (group_buffer == NULL) {
|
||||
+ if (ret != 0 || group_buffer == NULL) {
|
||||
free(group);
|
||||
goto admin_error;
|
||||
}
|
||||
diff --git a/src/daemon/cgrulesengd.c b/src/daemon/cgrulesengd.c
|
||||
index 4cef53e..90920d1 100644
|
||||
--- a/src/daemon/cgrulesengd.c
|
||||
+++ b/src/daemon/cgrulesengd.c
|
||||
@@ -654,7 +654,7 @@ close:
|
||||
|
||||
static int cgre_create_netlink_socket_process_msg(void)
|
||||
{
|
||||
- int sk_nl = 0, sk_unix = 0, sk_max;
|
||||
+ int sk_nl = -1, sk_unix = -1, sk_max;
|
||||
struct sockaddr_nl my_nla;
|
||||
char buff[BUFF_SIZE];
|
||||
int rc = -1;
|
@ -1,50 +0,0 @@
|
||||
diff --git a/src/api.c b/src/api.c
|
||||
index df9afe8..537cf10 100644
|
||||
--- a/src/api.c
|
||||
+++ b/src/api.c
|
||||
@@ -2981,29 +2981,29 @@ static int cg_rd_ctrl_file(const char *subsys, const char *cgroup,
|
||||
const char *file, char **value)
|
||||
{
|
||||
char path[FILENAME_MAX];
|
||||
- FILE *ctrl_file = NULL;
|
||||
- int ret;
|
||||
+ int ctrl_file = -1;
|
||||
+ ssize_t ret;
|
||||
|
||||
if (!cg_build_path_locked(cgroup, path, subsys))
|
||||
return ECGFAIL;
|
||||
|
||||
strncat(path, file, sizeof(path) - strlen(path));
|
||||
- ctrl_file = fopen(path, "re");
|
||||
- if (!ctrl_file)
|
||||
+ ctrl_file = open(path, O_RDONLY | O_CLOEXEC);
|
||||
+ if (ctrl_file < 0)
|
||||
return ECGROUPVALUENOTEXIST;
|
||||
|
||||
*value = calloc(CG_CONTROL_VALUE_MAX, 1);
|
||||
if (!*value) {
|
||||
- fclose(ctrl_file);
|
||||
+ close(ctrl_file);
|
||||
last_errno = errno;
|
||||
return ECGOTHER;
|
||||
}
|
||||
|
||||
/*
|
||||
- * using %as crashes when we try to read from files like
|
||||
+ * using %as or fread crashes when we try to read from files like
|
||||
* memory.stat
|
||||
*/
|
||||
- ret = fread(*value, 1, CG_CONTROL_VALUE_MAX-1, ctrl_file);
|
||||
+ ret = read(ctrl_file, *value, CG_CONTROL_VALUE_MAX-1);
|
||||
if (ret < 0) {
|
||||
free(*value);
|
||||
*value = NULL;
|
||||
@@ -3013,7 +3013,7 @@ static int cg_rd_ctrl_file(const char *subsys, const char *cgroup,
|
||||
(*value)[ret-1] = '\0';
|
||||
}
|
||||
|
||||
- fclose(ctrl_file);
|
||||
+ close(ctrl_file);
|
||||
|
||||
return 0;
|
||||
}
|
@ -1,17 +0,0 @@
|
||||
diff --git a/src/api.c b/src/api.c
|
||||
index 537cf10..483eabc 100644
|
||||
--- a/src/api.c
|
||||
+++ b/src/api.c
|
||||
@@ -3959,10 +3959,10 @@ int cgroup_change_cgroup_flags(uid_t uid, gid_t gid,
|
||||
available, "%d", pid);
|
||||
break;
|
||||
case 'p':
|
||||
- if(procname) {
|
||||
+ if(procname && strlen(basename(procname))) {
|
||||
written = snprintf(newdest + j,
|
||||
available, "%s",
|
||||
- procname);
|
||||
+ basename(procname));
|
||||
} else {
|
||||
written = snprintf(newdest + j,
|
||||
available, "%d", pid);
|
@ -1,32 +0,0 @@
|
||||
diff --git a/tests/gunit/Makefile.am b/tests/gunit/Makefile.am
|
||||
index 654002c..96399e9 100644
|
||||
--- a/tests/gunit/Makefile.am
|
||||
+++ b/tests/gunit/Makefile.am
|
||||
@@ -22,8 +22,6 @@
|
||||
AM_CPPFLAGS = -I$(top_srcdir)/include \
|
||||
-I$(top_srcdir)/src \
|
||||
-I$(top_srcdir)/src/tools \
|
||||
- -I$(top_builddir)/googletest/googletest/include \
|
||||
- -I$(top_builddir)/googletest/googletest \
|
||||
-std=c++11 \
|
||||
-Wno-write-strings \
|
||||
-DSTATIC= \
|
||||
@@ -31,10 +29,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/include \
|
||||
LDADD = $(top_builddir)/src/.libs/libcgroupfortesting.la \
|
||||
$(top_builddir)/src/tools/.libs/libcgset.la
|
||||
|
||||
-EXTRA_DIST = $(top_srcdir)/googletest/googletest/libgtest.so \
|
||||
- $(top_srcdir)/googletest/googletest/libgtest_main.so \
|
||||
- $(top_srcdir)/googletest/googletest/include \
|
||||
- libcgroup_unittest.map
|
||||
+EXTRA_DIST = libcgroup_unittest.map
|
||||
|
||||
check_PROGRAMS = gtest
|
||||
TESTS = gtest
|
||||
@@ -56,5 +51,4 @@ gtest_SOURCES = gtest.cpp \
|
||||
014-cgroupv2_get_subtree_control.cpp \
|
||||
015-cgroupv2_controller_enabled.cpp \
|
||||
016-cgset_parse_r_flag.cpp
|
||||
-gtest_LDFLAGS = -L$(top_builddir)/googletest/googletest -l:libgtest.so \
|
||||
- -rpath $(abs_top_builddir)/googletest/googletest
|
||||
+gtest_LDFLAGS = -l:libgtest.so
|
403
libcgroup.spec
403
libcgroup.spec
@ -1,403 +0,0 @@
|
||||
%bcond_with tests
|
||||
|
||||
%global tests_commit 3c0c7b164b4221d78459fccdd49643a5dcb3f73d
|
||||
|
||||
Summary: Library to control and monitor control groups
|
||||
Name: libcgroup
|
||||
Version: 2.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: http://libcg.sourceforge.net/
|
||||
Source0: https://github.com/%{name}/%{name}/archive/v%{version}/%{name}-v%{version}.tar.gz
|
||||
Source1: https://github.com/%{name}/%{name}-tests/archive/%{tests_commit}.tar.gz
|
||||
Source2: cgconfig.service
|
||||
|
||||
Patch0: fedora-config.patch
|
||||
Patch1: libcgroup-0.37-chmod.patch
|
||||
Patch2: libcgroup-0.40.rc1-coverity.patch
|
||||
Patch3: libcgroup-0.40.rc1-fread.patch
|
||||
Patch4: libcgroup-0.40.rc1-templates-fix.patch
|
||||
Patch5: libcgroup-tests-unbundle-gtest.patch
|
||||
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
BuildRequires: gcc, gcc-c++
|
||||
BuildRequires: byacc, coreutils, flex, pam-devel, systemd-units
|
||||
BuildRequires: make
|
||||
%if %{with tests}
|
||||
BuildRequires: gtest-devel
|
||||
%endif
|
||||
Requires(pre): shadow-utils
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
|
||||
%description
|
||||
Control groups infrastructure. The library helps manipulate, control,
|
||||
administrate and monitor control groups and the associated controllers.
|
||||
|
||||
%package tools
|
||||
Summary: Command-line utility programs, services and daemons for libcgroup
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
# needed for Delegate property in cgconfig.service
|
||||
Requires: systemd >= 217-0.2
|
||||
|
||||
%description tools
|
||||
This package contains command-line programs, services and a daemon for
|
||||
manipulating control groups using the libcgroup library.
|
||||
|
||||
%package pam
|
||||
Summary: A Pluggable Authentication Module for libcgroup
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description pam
|
||||
Linux-PAM module, which allows administrators to classify the user's login
|
||||
processes to pre-configured control group.
|
||||
|
||||
%package devel
|
||||
Summary: Development libraries to develop applications that utilize control groups
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
It provides API to create/delete and modify cgroup nodes. It will also in the
|
||||
future allow creation of persistent configuration for control groups and
|
||||
provide scripts to manage that configuration.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1 -b .config-patch
|
||||
%patch1 -p1 -b .chmod
|
||||
%patch2 -p1 -b .coverity
|
||||
%patch3 -p1 -b .fread
|
||||
%patch4 -p1 -b .templates-fix
|
||||
|
||||
%setup -D -T -a 1
|
||||
mv -T %{name}-tests-%{tests_commit} tests
|
||||
%patch5 -p1 -b .tests-unbundle-gtest
|
||||
|
||||
%build
|
||||
autoreconf -vif
|
||||
%configure --enable-pam-module-dir=%{_libdir}/security \
|
||||
--enable-opaque-hierarchy="name=systemd" \
|
||||
--disable-daemon
|
||||
%make_build
|
||||
|
||||
%install
|
||||
%make_install
|
||||
|
||||
# install config files
|
||||
install -d ${RPM_BUILD_ROOT}%{_sysconfdir}
|
||||
install -m 644 samples/cgconfig.conf $RPM_BUILD_ROOT/%{_sysconfdir}/cgconfig.conf
|
||||
install -m 644 samples/cgsnapshot_blacklist.conf $RPM_BUILD_ROOT/%{_sysconfdir}/cgsnapshot_blacklist.conf
|
||||
|
||||
# sanitize pam module, we need only pam_cgroup.so
|
||||
mv -f $RPM_BUILD_ROOT%{_libdir}/security/pam_cgroup.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/security/pam_cgroup.so
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/security/pam_cgroup.{,l}a $RPM_BUILD_ROOT/%{_libdir}/security/pam_cgroup.so.*
|
||||
|
||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.{,l}a
|
||||
|
||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/libcgroupfortesting.*
|
||||
|
||||
rm -f $RPM_BUILD_ROOT/%{_mandir}/man5/cgred.conf.5*
|
||||
rm -f $RPM_BUILD_ROOT/%{_mandir}/man5/cgrules.conf.5*
|
||||
rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/cgrulesengd.8*
|
||||
|
||||
# install unit and sysconfig files
|
||||
install -d ${RPM_BUILD_ROOT}%{_unitdir}
|
||||
install -m 644 %SOURCE2 ${RPM_BUILD_ROOT}%{_unitdir}/
|
||||
install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
|
||||
|
||||
%check
|
||||
%if %{with tests}
|
||||
make -C tests/gunit check
|
||||
%endif
|
||||
|
||||
%post tools
|
||||
%systemd_post cgconfig.service
|
||||
|
||||
%preun tools
|
||||
%systemd_preun cgconfig.service
|
||||
|
||||
%postun tools
|
||||
%systemd_postun_with_restart cgconfig.service
|
||||
|
||||
%triggerun -- libcgroup < 0.38
|
||||
# Save the current service runlevel info
|
||||
# User must manually run systemd-sysv-convert --apply cgconfig
|
||||
# to migrate them to systemd targets
|
||||
/usr/bin/systemd-sysv-convert --save cgconfig >/dev/null 2>&1 ||:
|
||||
|
||||
# Run these because the SysV package being removed won't do them
|
||||
/sbin/chkconfig --del cgconfig >/dev/null 2>&1 || :
|
||||
/bin/systemctl try-restart cgconfig.service >/dev/null 2>&1 || :
|
||||
|
||||
%files
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc README
|
||||
%{_libdir}/libcgroup.so.1*
|
||||
%{_libdir}/libcgset.so.0*
|
||||
|
||||
%files tools
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc README README_systemd
|
||||
%config(noreplace) %{_sysconfdir}/cgconfig.conf
|
||||
%config(noreplace) %{_sysconfdir}/cgsnapshot_blacklist.conf
|
||||
%{_bindir}/cgcreate
|
||||
%{_bindir}/cgget
|
||||
%{_bindir}/cgset
|
||||
%{_bindir}/cgdelete
|
||||
%{_bindir}/lscgroup
|
||||
%{_bindir}/lssubsys
|
||||
%{_sbindir}/cgconfigparser
|
||||
%{_sbindir}/cgclear
|
||||
%{_bindir}/cgsnapshot
|
||||
%{_bindir}/cgclassify
|
||||
%attr(0755, root, root) %{_bindir}/cgexec
|
||||
%attr(0644, root, root) %{_mandir}/man1/*
|
||||
%attr(0644, root, root) %{_mandir}/man5/*
|
||||
%attr(0644, root, root) %{_mandir}/man8/*
|
||||
%{_unitdir}/cgconfig.service
|
||||
|
||||
%files pam
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc README
|
||||
%attr(0755,root,root) %{_libdir}/security/pam_cgroup.so
|
||||
|
||||
%files devel
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc README
|
||||
%{_includedir}/libcgroup.h
|
||||
%{_includedir}/libcgroup/*.h
|
||||
%{_libdir}/libcgroup.so
|
||||
%{_libdir}/libcgset.so
|
||||
%{_libdir}/pkgconfig/libcgroup.pc
|
||||
|
||||
%changelog
|
||||
* Sun May 16 2021 Nikola Forró <nforro@redhat.com> - 2.0-1
|
||||
- Rebase to 2.0
|
||||
resolves: #1961665
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.42.2-5
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.42.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.42.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 0.42.2-2
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Thu Feb 06 2020 Nikola Forró <nforro@redhat.com> - 0.42.2-1
|
||||
- resolves: #1798286
|
||||
new upstream release 0.42.2
|
||||
|
||||
* Mon Feb 03 2020 Nikola Forró <nforro@redhat.com> - 0.42.1-1
|
||||
- resolves: #1792190
|
||||
new upstream release 0.42.1
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-22
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Aug 02 2018 Nikola Forró <nforro@redhat.com> - 0.41-20
|
||||
- resolves: #1611121
|
||||
fix CVE-2018-14348
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Jun 28 2018 Nikola Forró <nforro@redhat.com> - 0.41-18
|
||||
- remove ldconfig scriptlets
|
||||
|
||||
* Tue Apr 17 2018 Nikola Forró <nforro@redhat.com> - 0.41-17
|
||||
- backport several upstream fixes
|
||||
- set Delegate property for cgconfig service to make sure complete
|
||||
cgroup hierarchy is always created by systemd
|
||||
|
||||
* Tue Feb 20 2018 Nikola Forró <nforro@redhat.com> - 0.41-16
|
||||
- add missing gcc-c++ build dependency
|
||||
|
||||
* Tue Feb 20 2018 Nikola Forró <nforro@redhat.com> - 0.41-15
|
||||
- add missing gcc build dependency
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Oct 13 2016 Nikola Forró <nforro@redhat.com> - 0.41-10
|
||||
- resolves: #1384504
|
||||
api.c: preserve dirty flag when copying controller values
|
||||
|
||||
* Fri Jul 01 2016 Nikola Forró <nforro@redhat.com> - 0.41-9
|
||||
- resolves: #1348874
|
||||
api.c: fix order of memory subsystem parameters generated by cgsnapshot
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.41-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Sep 23 2014 jchaloup <jchaloup@redhat.com> - 0.41-6
|
||||
- resolves: #647107
|
||||
api.c: support for setting multiline values in control files
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.41-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Thu Jul 17 2014 Tom Callaway <spot@fedoraproject.org> - 0.41-4
|
||||
- fix license handling
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.41-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Mar 03 2014 jchaloup <jchaloup@redhat.com> - 0.41-2
|
||||
- lex.l update: add \ character into regexp for ID token
|
||||
|
||||
* Tue Jan 14 2014 Peter Schiffer <pschiffe@redhat.com> 0.41-1
|
||||
- resolves: #966008
|
||||
updated to 0.41
|
||||
- removed deprecated cgred service
|
||||
please use Control Group Interface in Systemd instead
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.38-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Jul 18 2013 Karsten Hopp <karsten@redhat.com> 0.38-6
|
||||
- add BR: systemd-units
|
||||
|
||||
* Tue Jul 09 2013 Karsten Hopp <karsten@redhat.com> 0.38-5
|
||||
- bump release and rebuild to fix some dependencies on PPC
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.38-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Nov 23 2012 Peter Schiffer <pschiffe@redhat.com> - 0.38-3
|
||||
- resolves: #850183
|
||||
scriptlets replaced with new systemd macros (thanks to vpavlin)
|
||||
- cleaned .spec file
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.38-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Feb 20 2012 Jan Safranek <jsafrane@redhat.com> 0.38-1
|
||||
- updated to 0.38
|
||||
|
||||
* Fri Feb 3 2012 Jan Safranek <jsafrane@redhat.com> 0.38-0.rc1
|
||||
- updated to 0.38.rc1
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.37.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon May 30 2011 Jan Safranek <jsafrane@redhat.com> 0.37.1-4
|
||||
- fixed cgconfig service not to unmount stuff it did not mount
|
||||
- added better sample cgconfig.conf file to reflect systemd
|
||||
mounting all controllers during boot (#702111)
|
||||
|
||||
* Wed May 25 2011 Ivana Hutarova Varekova <varekova@redhat.com> 0.37.1-3
|
||||
- split tools part from libcgroup package
|
||||
|
||||
* Fri Apr 8 2011 Jan Safranek <jsafrane@redhat.com> 0.37.1-2
|
||||
- Remove /cgroup directory, groups are created in /sys/fs/cgroup
|
||||
(#694687)
|
||||
|
||||
* Thu Mar 3 2011 Jan Safranek <jsafrane@redhat.com> 0.37.1-1
|
||||
- Update to 0.37.1
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.37-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Jan 17 2011 Jan Safranek <jsafrane@redhat.com> 0.37-2
|
||||
- Create the 'cgred' group as system group, not as user
|
||||
- Fix cgclassify exit code
|
||||
|
||||
* Mon Dec 13 2010 Jan Safranek <jsafrane@redhat.com> 0.37-1
|
||||
- Update to 0.37
|
||||
- use /sys/fs/cgroup as default directory to mount control groups (and rely on
|
||||
systemd mounting tmpfs there)
|
||||
|
||||
* Fri Nov 12 2010 Jan Safranek <jsafrane@redhat.com> 0.36.2-3
|
||||
- Ignore systemd hierarchy - it's now invisible to libcgroup (#627378)
|
||||
|
||||
* Mon Aug 2 2010 Jan Safranek <jsafrane@redhat.com> 0.36.2-2
|
||||
- Fix initscripts to report stopped cgconfig service as not running
|
||||
(#619091)
|
||||
|
||||
* Tue Jun 22 2010 Jan Safranek <jsafrane@redhat.com> 0.36.2-1
|
||||
- Update to 0.36.2, fixing packaging the libraries (#605434)
|
||||
- Remove the dependency on redhat-lsb (#603578)
|
||||
|
||||
* Fri May 21 2010 Jan Safranek <jsafrane@redhat.com> 0.36-1
|
||||
- Update to 0.36.1
|
||||
|
||||
* Tue Mar 9 2010 Jan Safranek <jsafrane@redhat.com> 0.35-1
|
||||
- Update to 0.35.1
|
||||
- Separate pam module to its own subpackage
|
||||
|
||||
* Mon Jan 18 2010 Jan Safranek <jsafrane@redhat.com> 0.34-4
|
||||
- Added README.Fedora to describe initscript integration
|
||||
|
||||
* Mon Oct 19 2009 Jan Safranek <jsafrane@redhat.com> 0.34-3
|
||||
- Change the default configuration to mount everything to /cgroup
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.34-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Jul 7 2009 Jan Safranek <jsafrane@redhat.com> 0.34-1
|
||||
- Update to 0.34
|
||||
* Mon Mar 09 2009 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.33-3
|
||||
- Add a workaround for rt cgroup controller.
|
||||
* Mon Mar 09 2009 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.33-2
|
||||
- Change the cgconfig script to start earlier
|
||||
- Move the binaries to /bin and /sbin
|
||||
* Mon Mar 02 2009 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.33-1
|
||||
- Update to latest upstream
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.32.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Mon Jan 05 2009 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32.2-3
|
||||
- Fix redhat-lsb dependency
|
||||
* Mon Dec 29 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32.2-2
|
||||
- Fix build dependencies
|
||||
* Mon Dec 29 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32.2-1
|
||||
- Update to latest upstream
|
||||
* Thu Oct 23 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32.1-1
|
||||
* Tue Feb 24 2009 Balbir Singh <balbir@linux.vnet.ibm.com> 0.33-1
|
||||
- Update to 0.33, spec file changes to add Makefiles and pam_cgroup module
|
||||
* Fri Oct 10 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32-1
|
||||
- Update to latest upstream
|
||||
* Thu Sep 11 2008 Dhaval Giani <dhaval@linux-vnet.ibm.com> 0.31-1
|
||||
- Update to latest upstream
|
||||
* Sat Aug 2 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.1c-3
|
||||
- Change release to fix broken upgrade path
|
||||
* Wed Jun 11 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.1c-1
|
||||
- Update to latest upstream version
|
||||
* Tue Jun 3 2008 Balbir Singh <balbir@linux.vnet.ibm.com> 0.1b-3
|
||||
- Add post and postun. Also fix Requires for devel to depend on base n-v-r
|
||||
* Sat May 31 2008 Balbir Singh <balbir@linux.vnet.ibm.com> 0.1b-2
|
||||
- Fix makeinstall, Source0 and URL (review comments from Tom)
|
||||
* Mon May 26 2008 Balbir Singh <balbir@linux.vnet.ibm.com> 0.1b-1
|
||||
- Add a generatable spec file
|
||||
* Tue May 20 2008 Balbir Singh <balbir@linux.vnet.ibm.com> 0.1-1
|
||||
- Get the spec file to work
|
||||
* Tue May 20 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.01-1
|
||||
- The first version of libcg
|
2
sources
2
sources
@ -1,2 +0,0 @@
|
||||
SHA512 (libcgroup-v2.0.tar.gz) = 22d867c6ff939d919c14d0e4af68b747bc21e9760344f12e9ed52574173d46822e85bace3976addd8a2826b4a985507eb78eb54c10df07442232bde30ba2181e
|
||||
SHA512 (3c0c7b164b4221d78459fccdd49643a5dcb3f73d.tar.gz) = db69e13f1814134bdc73af64e07adf7097da284a82d4733209b955f59bacd7970e223408703dff59f358b11b4fd7bdb6b6adab759065a40cc098802f90c0afce
|
Loading…
Reference in New Issue
Block a user