Fix the realpath test failure (upstream patch)
This commit is contained in:
parent
e06410eeb1
commit
d49ccdd9c8
10
libcdio.spec
10
libcdio.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libcdio
|
Name: libcdio
|
||||||
Version: 2.1.0
|
Version: 2.1.0
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
Summary: CD-ROM input and control library
|
Summary: CD-ROM input and control library
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/libcdio/
|
URL: http://www.gnu.org/software/libcdio/
|
||||||
@ -10,7 +10,10 @@ Source2: libcdio-no_date_footer.hml
|
|||||||
Source3: cdio_config.h
|
Source3: cdio_config.h
|
||||||
# Fixed upstream but not in a stable release yet.
|
# Fixed upstream but not in a stable release yet.
|
||||||
# http://git.savannah.gnu.org/cgit/libcdio.git/commit/?id=2adb43c60afc6e98e94d86dad9f93d3df52862b1
|
# http://git.savannah.gnu.org/cgit/libcdio.git/commit/?id=2adb43c60afc6e98e94d86dad9f93d3df52862b1
|
||||||
Patch: format-security.patch
|
Patch0: format-security.patch
|
||||||
|
# http://git.savannah.gnu.org/cgit/libcdio.git/commit/?id=56335fff0f21d294cd0e478d49542a43e9495ed0
|
||||||
|
Patch1: realpath-test-fix.patch
|
||||||
|
|
||||||
BuildRequires: gcc gcc-c++
|
BuildRequires: gcc gcc-c++
|
||||||
BuildRequires: pkgconfig doxygen
|
BuildRequires: pkgconfig doxygen
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
@ -117,6 +120,9 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 30 2022 Parag Nemade <pnemade AT redhat DOT com> - 2.1.0-8
|
||||||
|
- Fix the realpath test failure (upstream patch)
|
||||||
|
|
||||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-7
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
52
realpath-test-fix.patch
Normal file
52
realpath-test-fix.patch
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
From 56335fff0f21d294cd0e478d49542a43e9495ed0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "R. Bernstein" <rocky@gnu.org>
|
||||||
|
Date: Wed, 24 Aug 2022 14:34:33 -0400
|
||||||
|
Subject: Correct realpath test failure
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
See https://savannah.gnu.org/bugs/?62948
|
||||||
|
Patch courtesy of Martin Liška <marxin>
|
||||||
|
---
|
||||||
|
test/driver/realpath.c | 13 ++++++++-----
|
||||||
|
1 file changed, 8 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/test/driver/realpath.c b/test/driver/realpath.c
|
||||||
|
index 289253e..cd46d62 100644
|
||||||
|
--- a/test/driver/realpath.c
|
||||||
|
+++ b/test/driver/realpath.c
|
||||||
|
@@ -1,5 +1,7 @@
|
||||||
|
/* -*- C -*-
|
||||||
|
- Copyright (C) 2010-2012, 2015, 2017 Rocky Bernstein <rocky@gnu.org>
|
||||||
|
+
|
||||||
|
+ Copyright (C) 2010-2012, 2015, 2017, 2022 Rocky Bernstein
|
||||||
|
+ <rocky@gnu.org>
|
||||||
|
|
||||||
|
This program is free software: you can redistribute it and/or modify
|
||||||
|
it under the terms of the GNU General Public License as published by
|
||||||
|
@@ -175,16 +177,17 @@ main(int argc, const char *argv[])
|
||||||
|
rc = check_rc(symlink(psz_symlink_file, psz_symlink_file),
|
||||||
|
"symlink", psz_symlink_file);
|
||||||
|
if (0 == rc) {
|
||||||
|
- cdio_realpath(psz_symlink_file, psz_file_check);
|
||||||
|
- if (0 != strncmp(psz_file_check, symlink_file, PATH_MAX)) {
|
||||||
|
+ char *retvalue = cdio_realpath(psz_symlink_file, psz_file_check);
|
||||||
|
+ if (0 != retvalue) {
|
||||||
|
+ if (0 != strncmp(psz_file_check, symlink_file, PATH_MAX)) {
|
||||||
|
fprintf(stderr, "direct cdio_realpath cycle test failed. %s vs %s\n",
|
||||||
|
psz_file_check, symlink_file);
|
||||||
|
rc = 5;
|
||||||
|
goto err_exit;
|
||||||
|
+ }
|
||||||
|
+ check_rc(unlink(psz_symlink_file), "unlink", psz_symlink_file);
|
||||||
|
}
|
||||||
|
- check_rc(unlink(psz_symlink_file), "unlink", psz_symlink_file);
|
||||||
|
}
|
||||||
|
-
|
||||||
|
}
|
||||||
|
|
||||||
|
check_rc(unlink(psz_orig_file), "unlink", psz_orig_file);
|
||||||
|
--
|
||||||
|
cgit v1.1
|
||||||
|
|
Loading…
Reference in New Issue
Block a user