- updated to 0.81

- license changed to GPLv3+
- fixed #477288 (libcdio-devel multilib conflict)
- applied patch to fix endless loop in mock
This commit is contained in:
Adrian Reber 2009-01-13 08:19:26 +00:00
parent c0c432f4ea
commit 9b849b2bf6
5 changed files with 36 additions and 54 deletions

View File

@ -1,2 +1,2 @@
libcdio-0.80.tar.gz
libcdio-0.80.tar.gz.sig
libcdio-0.81.tar.gz.sig
libcdio-0.81.tar.gz

View File

@ -1,33 +0,0 @@
diff -up libcdio-0.80/Makefile.am.bak libcdio-0.80/Makefile.am
--- libcdio-0.80/Makefile.am.bak 2008-03-15 17:21:28.000000000 +0100
+++ libcdio-0.80/Makefile.am 2008-06-04 17:23:13.942500222 +0200
@@ -20,6 +20,10 @@
## which configure then turns into a Makefile ...
## which make can then use to produce stuff. Isn't configuration simple?
+if BUILD_CD_PARANOIA
+paranoiadist = libcdio_paranoia.pc.in
+endif
+
EXTRA_DIST = \
MSVC/README MSVC/cd-info.vcproj \
MSVC/config.h \
@@ -34,7 +38,8 @@ EXTRA_DIST = \
libiso9660.pc.in \
libiso9660++.pc.in \
libudf.pc.in \
- package/libcdio.spec.in
+ package/libcdio.spec.in \
+ $(paranoiadist)
SUBDIRS = doc include lib src test example
@@ -48,7 +53,7 @@ pkgconfig_DATA = libcdio.pc \
libcdio++.pc \
libiso9660.pc \
libiso9660++.pc \
- libudf.pc
+ libudf.pc \
$(paranoiapcs)

View File

@ -0,0 +1,13 @@
diff --git a/lib/driver/gnu_linux.c b/lib/driver/gnu_linux.c
index 7e2f3c4..092af0d 100644
--- a/lib/driver/gnu_linux.c
+++ b/lib/driver/gnu_linux.c
@@ -1448,7 +1448,7 @@ cdio_get_default_device_linux(void)
/* Scan the system for CD-ROM drives.
Not always 100% reliable, so use the USE_MNTENT code above first.
*/
- for ( i=0; checklist2[i].format; ++i ) {
+ for ( i=0; i < checklist2_size; ++i ) {
unsigned int j;
for ( j=checklist2[i].num_min; j<=checklist2[i].num_max; ++j ) {
if (snprintf(drive, sizeof(drive), checklist2[i].format, j) < 0)

View File

@ -1,13 +1,14 @@
Name: libcdio
Version: 0.80
Release: 5%{?dist}
Version: 0.81
Release: 1%{?dist}
Summary: CD-ROM input and control library
Group: System Environment/Libraries
License: GPLv2+
License: GPLv3+
URL: http://www.gnu.org/software/libcdio/
Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-0.80.tar.gz
Source1: http://ftp.gnu.org/gnu/libcdio/libcdio-0.80.tar.gz.sig
Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-0.81.tar.gz
Source1: http://ftp.gnu.org/gnu/libcdio/libcdio-0.81.tar.gz.sig
Source2: libcdio-no_date_footer.hml
Patch0: libcdio-0.81-cdio_get_default_device_linux.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: pkgconfig doxygen
BuildRequires: ncurses-devel
@ -15,12 +16,7 @@ BuildRequires: help2man
Requires(post): /sbin/ldconfig
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
# The patch touches Makefile.am files:
BuildRequires: automake autoconf
BuildRequires: libtool
BuildRequires: gettext-devel
Patch1: libcdio-0.80-paranoia-fix.patch
%description
@ -40,24 +36,23 @@ This package contains header files and static libraries for %{name}.
%prep
%setup -q
%patch1 -p1 -b .paranoia_pc
%patch0 -p1
f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
%build
libtoolize --force || :
aclocal || :
autoheader || :
automake || :
autoconf || :
%configure \
--disable-vcd-info \
--disable-dependency-tracking \
--disable-cddb \
--disable-rpath
make %{?_smp_mflags}
# another multilib fix; remove the architecture information from version.h
sed -i -e "s,%{version}.*$,%{version}\\\",g" include/cdio/version.h
cd doc/doxygen
sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
cp %{SOURCE2} .
@ -90,6 +85,7 @@ done
%check
# disable test using local CDROM
%{__sed} -i -e "s,testiso9660\$(EXEEXT),,g" \
-e "s,testisocd\$(EXEEXT),,g" \
-e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
test/Makefile
make check
@ -133,6 +129,12 @@ fi
%changelog
* Tue Oct 07 2008 Adrian Reber <adrian@lisas.de> - 0.81-1
- updated to 0.81
- license changed to GPLv3+
- fixed #477288 (libcdio-devel multilib conflict)
- applied patch to fix endless loop in mock
* Tue Oct 07 2008 Adrian Reber <adrian@lisas.de> - 0.80-5
- fixed #462125 (Multilib conflict) - really, really, really
(also remove architecture information from man pages)

View File

@ -1,2 +1,2 @@
6495add276ed11b7ac8a88092799ab4f libcdio-0.80.tar.gz
8eb4a8d3d1bb1ceec336863980171c8c libcdio-0.80.tar.gz.sig
57c2ba8e6132a39b18ee7d320b9aa484 libcdio-0.81.tar.gz.sig
2ad1622b672ccf53a3444a0c55724d38 libcdio-0.81.tar.gz