- updated to 0.79
- fixes #427197 (Long Joliet file name overflows cdio's buffer) - fixes #341981 (multiarch conflicts in libcdio)
This commit is contained in:
parent
5b9e39e0d9
commit
7d4c83498b
@ -1,2 +1,2 @@
|
||||
libcdio-0.78.2.tar.gz
|
||||
libcdio-0.78.2.tar.gz.sig
|
||||
libcdio-0.79.tar.gz.sig
|
||||
libcdio-0.79.tar.gz
|
||||
|
25
libcdio-info-buffer.patch
Normal file
25
libcdio-info-buffer.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -Naur libcdio-0.78.2-orig/work/libcdio-0.78.2/src/cd-info.c libcdio-0.78.2/work/libcdio-0.78.2/src/cd-info.c
|
||||
--- libcdio-0.78.2-orig/work/libcdio-0.78.2/src/cd-info.c 2006-03-17 14:37:08.000000000 -0500
|
||||
+++ libcdio-0.78.2/work/libcdio-0.78.2/src/cd-info.c 2007-12-30 10:49:40.000000000 -0500
|
||||
@@ -539,7 +539,7 @@
|
||||
iso9660_stat_t *p_statbuf = _cdio_list_node_data (entnode);
|
||||
char *psz_iso_name = p_statbuf->filename;
|
||||
char _fullname[4096] = { 0, };
|
||||
- char translated_name[MAX_ISONAME+1];
|
||||
+ char *translated_name = (char *) alloca(strlen(psz_iso_name+1));
|
||||
|
||||
if (yep != p_statbuf->rr.b3_rock || 1 == opts.no_rock_ridge) {
|
||||
iso9660_name_translate_ext(psz_iso_name, translated_name,
|
||||
diff -Naur libcdio-0.78.2-orig/work/libcdio-0.78.2/src/iso-info.c libcdio-0.78.2/work/libcdio-0.78.2/src/iso-info.c
|
||||
--- libcdio-0.78.2-orig/work/libcdio-0.78.2/src/iso-info.c 2006-03-17 14:37:08.000000000 -0500
|
||||
+++ libcdio-0.78.2/work/libcdio-0.78.2/src/iso-info.c 2007-12-30 10:49:50.000000000 -0500
|
||||
@@ -224,7 +224,8 @@
|
||||
iso9660_stat_t *p_statbuf = _cdio_list_node_data (entnode);
|
||||
char *psz_iso_name = p_statbuf->filename;
|
||||
char _fullname[4096] = { 0, };
|
||||
- char translated_name[MAX_ISONAME+1];
|
||||
+ char *translated_name = (char *) alloca(strlen(psz_iso_name+1));
|
||||
+
|
||||
|
||||
if (yep != p_statbuf->rr.b3_rock || 1 == opts.no_rock_ridge) {
|
||||
iso9660_name_translate_ext(psz_iso_name, translated_name,
|
4
libcdio-no_date_footer.hml
Normal file
4
libcdio-no_date_footer.hml
Normal file
@ -0,0 +1,4 @@
|
||||
<hr size="1"><address style="text-align: right;"><small>
|
||||
Generated for $projectname by <a href="http://www.doxygen.org/
|
||||
index.html"><img src="doxygen.png" alt="doxygen" align="middle" border="0"></a>
|
||||
$doxygenversion</small></address></body></html>
|
18
libcdio.spec
18
libcdio.spec
@ -1,14 +1,16 @@
|
||||
Name: libcdio
|
||||
Version: 0.78.2
|
||||
Release: 3%{?dist}
|
||||
Version: 0.79
|
||||
Release: 1%{?dist}
|
||||
Summary: CD-ROM input and control library
|
||||
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv2+
|
||||
URL: http://www.gnu.org/software/libcdio/
|
||||
Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-0.78.2.tar.gz
|
||||
Source1: http://ftp.gnu.org/gnu/libcdio/libcdio-0.78.2.tar.gz.sig
|
||||
Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-0.79.tar.gz
|
||||
Source1: http://ftp.gnu.org/gnu/libcdio/libcdio-0.79.tar.gz.sig
|
||||
Source2: libcdio-no_date_footer.hml
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Patch: libcdio-info-buffer.patch
|
||||
|
||||
#BuildRequires: libcddb-devel >= 0.9.4
|
||||
BuildRequires: pkgconfig doxygen
|
||||
@ -34,6 +36,7 @@ This package contains header files and static libraries for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p3
|
||||
f=src/cd-paranoia/doc/jp/cd-paranoia.1.in
|
||||
iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
|
||||
|
||||
@ -46,6 +49,8 @@ iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
|
||||
--disable-rpath
|
||||
make %{?_smp_mflags}
|
||||
cd doc/doxygen
|
||||
sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
|
||||
cp %{SOURCE2} .
|
||||
./run_doxygen
|
||||
|
||||
|
||||
@ -108,6 +113,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
|
||||
- updated to 0.79
|
||||
- fixes #427197 (Long Joliet file name overflows cdio's buffer)
|
||||
- fixes #341981 (multiarch conflicts in libcdio)
|
||||
|
||||
* Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user