Updated to 0.73
This commit is contained in:
parent
910093846b
commit
2b74698e5f
@ -1 +1 @@
|
|||||||
libcdio-0.70.tar.gz
|
libcdio-0.73.tar.gz
|
||||||
|
@ -1,57 +0,0 @@
|
|||||||
diff -Naru libcdio-0.70.orig/lib/cdio.c libcdio-0.70.new/lib/cdio.c
|
|
||||||
--- libcdio-0.70.orig/lib/cdio.c 2004-08-29 06:55:24.000000000 +0300
|
|
||||||
+++ libcdio-0.70.new/lib/cdio.c 2005-03-18 15:48:40.000000000 +0200
|
|
||||||
@@ -848,7 +848,7 @@
|
|
||||||
if (cdio == NULL) return -1;
|
|
||||||
|
|
||||||
if (cdio->op.read)
|
|
||||||
- return cdio->op.read (cdio->env, buf, size);
|
|
||||||
+ return (cdio->op.read) (cdio->env, buf, size);
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff -Naru libcdio-0.70.orig/lib/_cdio_stream.c libcdio-0.70.new/lib/_cdio_stream.c
|
|
||||||
--- libcdio-0.70.orig/lib/_cdio_stream.c 2004-02-07 20:53:02.000000000 +0200
|
|
||||||
+++ libcdio-0.70.new/lib/_cdio_stream.c 2005-03-18 15:46:44.000000000 +0200
|
|
||||||
@@ -145,7 +145,7 @@
|
|
||||||
|
|
||||||
if (!_cdio_stream_open_if_necessary(obj)) return 0;
|
|
||||||
|
|
||||||
- read_bytes = obj->op.read(obj->user_data, ptr, size*nmemb);
|
|
||||||
+ read_bytes = (obj->op.read)(obj->user_data, ptr, size*nmemb);
|
|
||||||
obj->position += read_bytes;
|
|
||||||
|
|
||||||
return read_bytes;
|
|
||||||
diff -Naru libcdio-0.70.orig/src/cd-drive.c libcdio-0.70.new/src/cd-drive.c
|
|
||||||
--- libcdio-0.70.orig/src/cd-drive.c 2004-08-27 14:53:38.000000000 +0300
|
|
||||||
+++ libcdio-0.70.new/src/cd-drive.c 2005-03-18 15:51:43.000000000 +0200
|
|
||||||
@@ -140,7 +140,6 @@
|
|
||||||
|
|
||||||
/* CDIO logging routines */
|
|
||||||
|
|
||||||
-static cdio_log_handler_t gl_default_cdio_log_handler = NULL;
|
|
||||||
|
|
||||||
static void
|
|
||||||
_log_handler (cdio_log_level_t level, const char message[])
|
|
||||||
diff -Naru libcdio-0.70.orig/src/cd-info.c libcdio-0.70.new/src/cd-info.c
|
|
||||||
--- libcdio-0.70.orig/src/cd-info.c 2004-09-02 04:33:57.000000000 +0300
|
|
||||||
+++ libcdio-0.70.new/src/cd-info.c 2005-03-18 15:53:49.000000000 +0200
|
|
||||||
@@ -371,7 +371,6 @@
|
|
||||||
|
|
||||||
/* CDIO logging routines */
|
|
||||||
|
|
||||||
-static cdio_log_handler_t gl_default_cdio_log_handler = NULL;
|
|
||||||
#ifdef HAVE_CDDB
|
|
||||||
static cddb_log_handler_t gl_default_cddb_log_handler = NULL;
|
|
||||||
#endif
|
|
||||||
diff -Naru libcdio-0.70.orig/src/iso-info.c libcdio-0.70.new/src/iso-info.c
|
|
||||||
--- libcdio-0.70.orig/src/iso-info.c 2004-06-19 22:15:15.000000000 +0300
|
|
||||||
+++ libcdio-0.70.new/src/iso-info.c 2005-03-18 15:55:57.000000000 +0200
|
|
||||||
@@ -133,7 +133,6 @@
|
|
||||||
|
|
||||||
/* CDIO logging routines */
|
|
||||||
|
|
||||||
-static cdio_log_handler_t gl_default_cdio_log_handler = NULL;
|
|
||||||
|
|
||||||
static void
|
|
||||||
_log_handler (cdio_log_level_t level, const char message[])
|
|
18
libcdio.spec
18
libcdio.spec
@ -1,13 +1,12 @@
|
|||||||
Name: libcdio
|
Name: libcdio
|
||||||
Version: 0.70
|
Version: 0.73
|
||||||
Release: 2
|
Release: 1
|
||||||
Summary: CD-ROM input and control library
|
Summary: CD-ROM input and control library
|
||||||
|
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
License: GPL
|
License: GPL
|
||||||
URL: http://www.gnu.org/software/libcdio/
|
URL: http://www.gnu.org/software/libcdio/
|
||||||
Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-0.70.tar.gz
|
Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-0.73.tar.gz
|
||||||
Patch0: %{name}-gcc4.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: libcddb-devel >= 0.9.4
|
BuildRequires: libcddb-devel >= 0.9.4
|
||||||
@ -34,13 +33,11 @@ This package contains header files and static libraries for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-vcd-info --disable-dependency-tracking
|
%configure --disable-vcd-info --disable-dependency-tracking
|
||||||
# Parallel build fails
|
make %{_smp_mflags}
|
||||||
make
|
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -50,6 +47,9 @@ make install DESTDIR=$RPM_BUILD_ROOT
|
|||||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||||
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
|
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
|
||||||
|
|
||||||
|
# I don't know what to do with jp manpages
|
||||||
|
rm -rf $RPM_BUILD_ROOT%{_mandir}/jp
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -75,6 +75,7 @@ fi
|
|||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
%{_infodir}/*
|
%{_infodir}/*
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
@ -86,6 +87,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
|
||||||
|
- Updated to 0.73.
|
||||||
|
|
||||||
* Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
|
* Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
|
||||||
- Fix FC4 build (#151468).
|
- Fix FC4 build (#151468).
|
||||||
- Build with dependency tracking disabled.
|
- Build with dependency tracking disabled.
|
||||||
|
Loading…
Reference in New Issue
Block a user