update to 2.44
remove additional getpcaps manpage as it now included in the sources update license tag Signed-off-by: Karsten Hopp <karsten.hopp@targens.de>
This commit is contained in:
parent
67e96608f2
commit
366827aa94
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ libcap-2.17.tar.gz
|
||||
/libcap-2.24.tar.gz
|
||||
/libcap-2.25.tar.gz
|
||||
/libcap-2.26.tar.gz
|
||||
/libcap-2.44.tar.gz
|
||||
|
@ -1,22 +0,0 @@
|
||||
diff -up libcap-2.25/Make.Rules.rh libcap-2.25/Make.Rules
|
||||
--- libcap-2.25/Make.Rules.rh 2016-04-11 18:52:01.418065682 +0200
|
||||
+++ libcap-2.25/Make.Rules 2016-04-11 18:52:10.790113866 +0200
|
||||
@@ -49,7 +49,8 @@ KERNEL_HEADERS := $(topdir)/libcap/inclu
|
||||
IPATH += -fPIC -I$(KERNEL_HEADERS) -I$(topdir)/libcap/include
|
||||
|
||||
CC := gcc
|
||||
-CFLAGS := -O2 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
|
||||
+CFLAGS := $(RPM_OPT_FLAGS) -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
|
||||
+
|
||||
BUILD_CC := $(CC)
|
||||
BUILD_CFLAGS := $(CFLAGS) $(IPATH)
|
||||
AR := ar
|
||||
@@ -60,7 +61,7 @@ WARNINGS=-Wall -Wwrite-strings \
|
||||
-Wstrict-prototypes -Wmissing-prototypes \
|
||||
-Wnested-externs -Winline -Wshadow
|
||||
LD=$(CC) -Wl,-x -shared
|
||||
-LDFLAGS := #-g
|
||||
+LDFLAGS := $(RPM_LD_FLAGS) #-g
|
||||
BUILD_GPERF := $(shell which gperf >/dev/null 2>/dev/null && echo yes)
|
||||
|
||||
SYSTEM_HEADERS = /usr/include
|
25
libcap-2.44-buildflags.patch
Normal file
25
libcap-2.44-buildflags.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -up ./Make.Rules.rh ./Make.Rules
|
||||
--- ./Make.Rules.rh 2020-10-21 14:35:56.645593319 +0200
|
||||
+++ ./Make.Rules 2020-10-21 14:38:34.794968440 +0200
|
||||
@@ -56,10 +56,10 @@ IPATH += -fPIC -I$(KERNEL_HEADERS) -I$(t
|
||||
|
||||
CC := $(CROSS_COMPILE)gcc
|
||||
DEFINES := -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
|
||||
-COPTS ?= -O2
|
||||
+COPTS ?= $(RPM_OPT_FLAGS)
|
||||
CFLAGS ?= $(COPTS) $(DEFINES)
|
||||
BUILD_CC ?= $(CC)
|
||||
-BUILD_COPTS ?= -O2
|
||||
+BUILD_COPTS ?= $(RPM_OPT_FLAGS)
|
||||
BUILD_CFLAGS ?= $(BUILD_COPTS) $(DEFINES) $(IPATH)
|
||||
AR := $(CROSS_COMPILE)ar
|
||||
RANLIB := $(CROSS_COMPILE)ranlib
|
||||
@@ -69,7 +69,7 @@ WARNINGS=-Wall -Wwrite-strings \
|
||||
-Wstrict-prototypes -Wmissing-prototypes \
|
||||
-Wnested-externs -Winline -Wshadow
|
||||
LD=$(CC) -Wl,-x -shared
|
||||
-LDFLAGS ?= #-g
|
||||
+LDFLAGS ?= $(RPM_LD_FLAGS)
|
||||
LIBCAPLIB := -L$(topdir)/libcap -lcap
|
||||
LIBPSXLIB := -L$(topdir)/libcap -lpsx -lpthread -Wl,-wrap,pthread_create
|
||||
|
17
libcap.spec
17
libcap.spec
@ -1,14 +1,13 @@
|
||||
Name: libcap
|
||||
Version: 2.26
|
||||
Release: 8%{?dist}
|
||||
Version: 2.44
|
||||
Release: 1%{?dist}
|
||||
Summary: Library for getting and setting POSIX.1e capabilities
|
||||
URL: https://sites.google.com/site/fullycapable/
|
||||
License: GPLv2
|
||||
License: BSD or GPLv2
|
||||
|
||||
Source: https://git.kernel.org/pub/scm/libs/libcap/libcap.git/snapshot/%{name}-%{version}.tar.gz
|
||||
# http://manned.org/getpcaps/299a4949/src:
|
||||
Source1: getpcaps.8
|
||||
Patch0: libcap-2.25-buildflags.patch
|
||||
Patch0: libcap-2.44-buildflags.patch
|
||||
|
||||
BuildRequires: libattr-devel pam-devel perl-interpreter gcc
|
||||
|
||||
@ -58,7 +57,6 @@ make install RAISE_SETFCAP=no \
|
||||
|
||||
mkdir -p %{buildroot}/%{_mandir}/man{2,3,8}
|
||||
mv -f doc/*.3 %{buildroot}/%{_mandir}/man3/
|
||||
cp -f %{SOURCE1} %{buildroot}/%{_mandir}/man8/
|
||||
|
||||
chmod +x %{buildroot}/%{_libdir}/*.so.*
|
||||
|
||||
@ -76,14 +74,21 @@ chmod +x %{buildroot}/%{_libdir}/*.so.*
|
||||
|
||||
%files static
|
||||
%{_libdir}/libcap.a
|
||||
%{_libdir}/libpsx.a
|
||||
|
||||
%files devel
|
||||
%{_includedir}/*
|
||||
%{_libdir}/*.so
|
||||
%{_mandir}/man3/*
|
||||
%{_libdir}/pkgconfig/libcap.pc
|
||||
%{_libdir}/pkgconfig/libpsx.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 21 2020 Karsten Hopp <karsten@fedoraproject.org> - 2.44-1
|
||||
- update to 2.44
|
||||
- remove additional getpcaps manpage as it now included in the sources
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.26-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libcap-2.26.tar.gz) = 4a0bfbc1c3efb009a309d9b894aa553009a229323da4780caa424bd70d0579d6b156e2034bc4dee8dc3b2caaf8617a18c74a01095a4c2a8fbe732e5e8a304603
|
||||
SHA512 (libcap-2.44.tar.gz) = 29feb4a503aee7b86dba882175b0b76f05aed39c63ddcf47a7db7d62ab517a40c506dadfc40ddd1911f551dbe5bb26e447bb4c1024b298658a86750caab67144
|
||||
|
Loading…
Reference in New Issue
Block a user