libcacard-1.2.1-2
Fix building for i686 after rebasing on qemu sources.
This commit is contained in:
parent
98b8d661f0
commit
ecee9a24d4
@ -0,0 +1,40 @@
|
|||||||
|
From d227beb4202b6907e4d6eba1d1e6e99ef772587e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Alon Levy <alevy@redhat.com>
|
||||||
|
Date: Mon, 26 Nov 2012 14:54:09 +0200
|
||||||
|
Subject: [PATCH] libcacard: use LDFLAGS to produce i686 with --cpu=i386
|
||||||
|
|
||||||
|
Signed-off-by: Alon Levy <alevy@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile | 2 +-
|
||||||
|
libcacard/Makefile | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index dd11e3c..2bed319 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -169,7 +169,7 @@ qemu-io$(EXESUF): qemu-io.o cmd.o $(tools-obj-y) $(block-obj-y)
|
||||||
|
qemu-bridge-helper$(EXESUF): qemu-bridge-helper.o
|
||||||
|
|
||||||
|
vscclient$(EXESUF): $(libcacard-y) $(oslib-obj-y) $(trace-obj-y) $(tools-obj-y) qemu-timer-common.o libcacard/vscclient.o
|
||||||
|
- $(call quiet-command,$(CC) $(LDFLAGS) -o $@ $^ $(libcacard_libs) $(LIBS)," LINK $@")
|
||||||
|
+ $(call quiet-command,$(CC) $(LDFLAGS) -o $@ $^ $(libcacard_libs) $(LDFLAGS) $(LIBS)," LINK $@")
|
||||||
|
|
||||||
|
fsdev/virtfs-proxy-helper$(EXESUF): fsdev/virtfs-proxy-helper.o fsdev/virtio-9p-marshal.o oslib-posix.o $(trace-obj-y)
|
||||||
|
fsdev/virtfs-proxy-helper$(EXESUF): LIBS += -lcap
|
||||||
|
diff --git a/libcacard/Makefile b/libcacard/Makefile
|
||||||
|
index faca3ca..ce9a921 100644
|
||||||
|
--- a/libcacard/Makefile
|
||||||
|
+++ b/libcacard/Makefile
|
||||||
|
@@ -37,7 +37,7 @@ install-libcacard:
|
||||||
|
@echo "libtool is missing, please install and rerun configure"; exit 1
|
||||||
|
else
|
||||||
|
libcacard.la: $(libcacard.lib-y) $(QEMU_OBJS_LIB)
|
||||||
|
- $(call quiet-command,$(LIBTOOL) --mode=link --quiet --tag=CC $(CC) -rpath $(libdir) -o $@ $^ $(libcacard_libs)," lt LINK $@")
|
||||||
|
+ $(call quiet-command,$(LIBTOOL) --mode=link --quiet --tag=CC $(CC) $(LDFLAGS) -rpath $(libdir) -o $@ $^ $(libcacard_libs)," lt LINK $@")
|
||||||
|
|
||||||
|
libcacard_srcpath=$(SRC_PATH)/libcacard
|
||||||
|
libcacard.pc: $(libcacard_srcpath)/libcacard.pc.in
|
||||||
|
--
|
||||||
|
1.8.0
|
||||||
|
|
@ -1,12 +1,13 @@
|
|||||||
Name: libcacard
|
Name: libcacard
|
||||||
Version: 1.2.1
|
Version: 1.2.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Common Access Card (CAC) Emulation
|
Summary: Common Access Card (CAC) Emulation
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://www.qemu.org/
|
URL: http://www.qemu.org/
|
||||||
Source0: http://wiki.qemu.org/download/qemu-%{version}.tar.bz2
|
Source0: http://wiki.qemu.org/download/qemu-%{version}.tar.bz2
|
||||||
Patch00: 0001-libcacard-build-vscclient-from-root-only.patch
|
Patch00: 0001-libcacard-build-vscclient-from-root-only.patch
|
||||||
|
Patch01: 0002-libcacard-use-LDFLAGS-to-produce-i686-with-cpu-i386.patch
|
||||||
BuildRequires: nss-devel >= 3.12.8-2 libtool python zlib-devel glib2-devel
|
BuildRequires: nss-devel >= 3.12.8-2 libtool python zlib-devel glib2-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -31,9 +32,10 @@ CAC emulation development files.
|
|||||||
%prep
|
%prep
|
||||||
%setup -n qemu-%{version} -q
|
%setup -n qemu-%{version} -q
|
||||||
%patch00 -p1
|
%patch00 -p1
|
||||||
|
%patch01 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./configure --prefix=%{_prefix} --libdir=%{_libdir} --disable-guest-agent --target-list=
|
./configure --prefix=%{_prefix} --libdir=%{_libdir} --disable-guest-agent --target-list= --cpu=%{_arch}
|
||||||
make libcacard.la %{?_smp_mflags}
|
make libcacard.la %{?_smp_mflags}
|
||||||
make vscclient
|
make vscclient
|
||||||
|
|
||||||
@ -63,7 +65,10 @@ chmod +x $RPM_BUILD_ROOT/%{_libdir}/libcacard.so.*
|
|||||||
%{_bindir}/vscclient
|
%{_bindir}/vscclient
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Nov 20 2012 Alon Levy <alevy@redhat.com> 1.2.0-1
|
* Mon Nov 26 2012 Alon Levy <alevy@redhat.com> 1.2.1-2
|
||||||
|
- fix building for i686 target.
|
||||||
|
|
||||||
|
* Tue Nov 20 2012 Alon Levy <alevy@redhat.com> 1.2.1-1
|
||||||
- libcacard independent repository is no longer used, qemu contains it as
|
- libcacard independent repository is no longer used, qemu contains it as
|
||||||
a subdirectory. Switch and update version number to qemu's.
|
a subdirectory. Switch and update version number to qemu's.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user