replaced by qemu subpackage

This commit is contained in:
Hans de Goede 2013-03-09 16:50:44 +01:00
parent 951358e9dc
commit d0cc6415a3
6 changed files with 1 additions and 186 deletions

3
.gitignore vendored
View File

@ -1,3 +0,0 @@
/libcacard-0.1.0.tar.bz2
/libcacard-0.1.2.tar.bz2
/qemu-1.2.1.tar.bz2

View File

@ -1,40 +0,0 @@
From d2d3d10a1422a99f55994dc6de3731b984241acb Mon Sep 17 00:00:00 2001
From: Alon Levy <alevy@redhat.com>
Date: Tue, 20 Nov 2012 18:04:32 +0200
Subject: [PATCH] libcacard: build vscclient from root only
Signed-off-by: Alon Levy <alevy@redhat.com>
---
libcacard/Makefile | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/libcacard/Makefile b/libcacard/Makefile
index 63990b7..faca3ca 100644
--- a/libcacard/Makefile
+++ b/libcacard/Makefile
@@ -1,3 +1,7 @@
+ifeq ($(BUILD_DIR),)
+ BUILD_DIR=$(CURDIR)/../
+endif
+
-include ../config-host.mak
-include $(SRC_PATH)/Makefile.objs
-include $(SRC_PATH)/rules.mak
@@ -46,12 +50,12 @@ libcacard.pc: $(libcacard_srcpath)/libcacard.pc.in
.PHONY: install-libcacard
-install-libcacard: libcacard.pc libcacard.la vscclient
+install-libcacard: libcacard.pc libcacard.la ../vscclient
$(INSTALL_DIR) "$(DESTDIR)$(libdir)"
$(INSTALL_DIR) "$(DESTDIR)$(libdir)/pkgconfig"
$(INSTALL_DIR) "$(DESTDIR)$(libcacard_includedir)"
$(INSTALL_DIR) "$(DESTDIR)$(bindir)"
- $(LIBTOOL) --mode=install $(INSTALL_PROG) vscclient "$(DESTDIR)$(bindir)"
+ $(LIBTOOL) --mode=install $(INSTALL_PROG) ../vscclient "$(DESTDIR)$(bindir)"
$(LIBTOOL) --mode=install $(INSTALL_DATA) libcacard.la "$(DESTDIR)$(libdir)"
$(LIBTOOL) --mode=install $(INSTALL_DATA) libcacard.pc "$(DESTDIR)$(libdir)/pkgconfig"
for inc in *.h; do \
--
1.8.0

View File

@ -1,40 +0,0 @@
From d227beb4202b6907e4d6eba1d1e6e99ef772587e Mon Sep 17 00:00:00 2001
From: Alon Levy <alevy@redhat.com>
Date: Mon, 26 Nov 2012 14:54:09 +0200
Subject: [PATCH] libcacard: use LDFLAGS to produce i686 with --cpu=i386
Signed-off-by: Alon Levy <alevy@redhat.com>
---
Makefile | 2 +-
libcacard/Makefile | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index dd11e3c..2bed319 100644
--- a/Makefile
+++ b/Makefile
@@ -169,7 +169,7 @@ qemu-io$(EXESUF): qemu-io.o cmd.o $(tools-obj-y) $(block-obj-y)
qemu-bridge-helper$(EXESUF): qemu-bridge-helper.o
vscclient$(EXESUF): $(libcacard-y) $(oslib-obj-y) $(trace-obj-y) $(tools-obj-y) qemu-timer-common.o libcacard/vscclient.o
- $(call quiet-command,$(CC) $(LDFLAGS) -o $@ $^ $(libcacard_libs) $(LIBS)," LINK $@")
+ $(call quiet-command,$(CC) $(LDFLAGS) -o $@ $^ $(libcacard_libs) $(LDFLAGS) $(LIBS)," LINK $@")
fsdev/virtfs-proxy-helper$(EXESUF): fsdev/virtfs-proxy-helper.o fsdev/virtio-9p-marshal.o oslib-posix.o $(trace-obj-y)
fsdev/virtfs-proxy-helper$(EXESUF): LIBS += -lcap
diff --git a/libcacard/Makefile b/libcacard/Makefile
index faca3ca..ce9a921 100644
--- a/libcacard/Makefile
+++ b/libcacard/Makefile
@@ -37,7 +37,7 @@ install-libcacard:
@echo "libtool is missing, please install and rerun configure"; exit 1
else
libcacard.la: $(libcacard.lib-y) $(QEMU_OBJS_LIB)
- $(call quiet-command,$(LIBTOOL) --mode=link --quiet --tag=CC $(CC) -rpath $(libdir) -o $@ $^ $(libcacard_libs)," lt LINK $@")
+ $(call quiet-command,$(LIBTOOL) --mode=link --quiet --tag=CC $(CC) $(LDFLAGS) -rpath $(libdir) -o $@ $^ $(libcacard_libs)," lt LINK $@")
libcacard_srcpath=$(SRC_PATH)/libcacard
libcacard.pc: $(libcacard_srcpath)/libcacard.pc.in
--
1.8.0

1
dead.package Normal file
View File

@ -0,0 +1 @@
replaced by qemu subpackage

View File

@ -1,102 +0,0 @@
Name: libcacard
Version: 1.2.1
Release: 3%{?dist}
Summary: Common Access Card (CAC) Emulation
Group: System Environment/Libraries
License: LGPLv2+
URL: http://www.qemu.org/
Source0: http://wiki.qemu.org/download/qemu-%{version}.tar.bz2
Patch00: 0001-libcacard-build-vscclient-from-root-only.patch
Patch01: 0002-libcacard-use-LDFLAGS-to-produce-i686-with-cpu-i386.patch
BuildRequires: nss-devel >= 3.12.8-2 libtool python zlib-devel glib2-devel
%description
Common Access Card (CAC) emulation library.
%package tools
Summary: CAC Emulation tools
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description tools
CAC emulation tools.
%package devel
Summary: CAC Emulation devel
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description devel
CAC emulation development files.
%prep
%setup -n qemu-%{version} -q
%patch00 -p1
%patch01 -p1
%build
./configure --prefix=%{_prefix} --libdir=%{_libdir} --disable-guest-agent --target-list= --cpu=%{_arch}
make libcacard.la %{?_smp_mflags}
make vscclient
%install
rm -rf $RPM_BUILD_ROOT
make install-libcacard DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
chmod +x $RPM_BUILD_ROOT/%{_libdir}/libcacard.so.*
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc COPYING README
%{_libdir}/libcacard.so.*
%files devel
%defattr(-,root,root,-)
%{_includedir}/cacard
%{_libdir}/pkgconfig/libcacard.pc
%{_libdir}/libcacard.so
%files tools
%defattr(-,root,root,-)
%{_bindir}/vscclient
%changelog
* Mon Jan 28 2013 Richard W.M. Jones <rjones@redhat.com> - 1.2.1-3
- Bump and rebuild for updated libseccomp.
* Mon Nov 26 2012 Alon Levy <alevy@redhat.com> 1.2.1-2
- fix building for i686 target.
* Tue Nov 20 2012 Alon Levy <alevy@redhat.com> 1.2.1-1
- libcacard independent repository is no longer used, qemu contains it as
a subdirectory. Switch and update version number to qemu's.
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Feb 09 2011 Alon Levy <alevy@redhat.com> - 0.1.2-1
- upstream update
- upstream updated to 0.1.2 (no rpm was done for this version)
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Sun Dec 12 2010 Alon Levy <alevy@redhat.com> - 0.1.0-4
- address review issues:
- Group for main and devel and tools
- Requires for devel and tools
- fix changelog for previous entry (day was wrong, and macro quoting)
* Sat Dec 11 2010 Alon Levy <alevy@redhat.com> - 0.1.0-3
- address review issues: defattr typo, %%doc at %%files, remove .*a from install
* Thu Dec 9 2010 Alon Levy <alevy@redhat.com> - 0.1.0-2
- address prereview issues.
* Thu Dec 9 2010 Alon Levy <alevy@redhat.com> - 0.1.0-1
- initial package.

View File

@ -1 +0,0 @@
189bc5b87281a72f8c72a0f7ebaa6d00 qemu-1.2.1.tar.bz2