diff --git a/.gitignore b/.gitignore
index f98ffb8..89d8421 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
/libbluray-20110514git46ee2766038e9.tar.bz2
/libbluray-20110710git51d7d60a96d06.tar.bz2
/libbluray-20111023gite037110f11e70.tar.bz2
+/libbluray-0.2.1.tar.bz2
diff --git a/libbluray-0.2.1-bdj_build.xml b/libbluray-0.2.1-bdj_build.xml
new file mode 100644
index 0000000..9ad3dc8
--- /dev/null
+++ b/libbluray-0.2.1-bdj_build.xml
@@ -0,0 +1,31 @@
+
+
+ Build file for the java portion of libBDJ
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
diff --git a/libbluray-0.2.1-bdj_java_subdir.tar.bz2 b/libbluray-0.2.1-bdj_java_subdir.tar.bz2
new file mode 100644
index 0000000..ca59384
Binary files /dev/null and b/libbluray-0.2.1-bdj_java_subdir.tar.bz2 differ
diff --git a/libbluray.spec b/libbluray.spec
index 7fe7807..94c6bbd 100644
--- a/libbluray.spec
+++ b/libbluray.spec
@@ -1,24 +1,38 @@
+%global snapshot 0
%global tarball_date 20111023
%global git_hash e037110f11e707e223b715f70920913afecfe297
%global git_short %(echo '%{git_hash}' | cut -c -13)
Name: libbluray
-Version: 0.2
+Version: 0.2.1
+%if %{snapshot}
Release: 0.7.%{tarball_date}git%{git_short}%{?dist}
+%else
+Release: 1%{?dist}
+%endif
Summary: Library to access Blu-Ray disks for video playback
Group: System Environment/Libraries
License: LGPLv2+
URL: http://www.videolan.org/developers/libbluray.html
-# No release yet. Use the commands below to generate a tarball.
+%if %{snapshot}
+# Use the commands below to generate a tarball.
# git clone git://git.videolan.org/libbluray.git
# cd libbluray
# git archive --format=tar %{git_hash} --prefix=libbluray/ | bzip2 > ../libbluray-$( date +%Y%m%d )git%{git_short}.tar.bz2
Source0: %{name}-%{tarball_date}git%{git_short}.tar.bz2
+%else
+Source0: ftp://ftp.videolan.org/pub/videolan/%{name}/%{version}/%{name}-%{version}.tar.bz2
+%endif
+# Fixed upstream, will not be needed for next upstream release
+Source1: libbluray-0.2.1-bdj_build.xml
+Source2: libbluray-0.2.1-bdj_java_subdir.tar.bz2
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
+%if %{snapshot}
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
+%endif
%ifnarch ppc64
BuildRequires: java-1.6.0-devel
BuildRequires: jpackage-utils
@@ -42,7 +56,7 @@ such as mplayer and vlc.
%package java
Summary: BDJ support for %{name}
Group: Development/Libraries
-Requires: %{name} = %{version}-%{release}
+Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: java-1.6.0
Requires: jpackage-utils
@@ -55,7 +69,7 @@ The %{name}-java package contains the jar file needed to add BDJ support to
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
-Requires: %{name} = %{version}-%{release}
+Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for
@@ -63,11 +77,19 @@ developing applications that use %{name}.
%prep
+%if %{snapshot}
%setup -q -n %{name}
+%else
+%setup -q
+install -Dp -m 644 %{SOURCE1} src/libbluray/bdj/build.xml
+tar xjf %{SOURCE2}
+%endif
%build
+%if %{snapshot}
autoreconf -vif
+%endif
%configure --disable-static \
--enable-examples \
%ifnarch ppc64
@@ -111,7 +133,7 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
-%doc COPYING doc/README player_wrappers README.txt TODO.txt
+%doc COPYING player_wrappers README.txt
%{_libdir}/*.so.*
%{_bindir}/*
@@ -132,6 +154,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog
+* Thu Dec 01 2011 Xavier Bachelot
+- First upstream official release.
+- Fix BD-J build (missing files in upstream tarball).
+- Have subpackages require an arch-specific base package.
+
* Sun Oct 23 2011 Xavier Bachelot 0.2-0.7.20111023gite037110f11e70
- Update to latest snapshot.
diff --git a/sources b/sources
index a659b3d..6cf2801 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-8ee8e0b1a94a7bc00283c77ccfe105ed libbluray-20111023gite037110f11e70.tar.bz2
+d4cfcf3f110e9d2afe01d29feb8c842b libbluray-0.2.1.tar.bz2