- Fix passing size for pvresize over DBus Resolves: RHEL-45872 - Upstream kernel VDO support Resolves: RHEL-31953
87 lines
4.0 KiB
Diff
87 lines
4.0 KiB
Diff
From e1c3c3e3555963104a8de00b510b69375eee5ced Mon Sep 17 00:00:00 2001
|
|
From: Vojtech Trefny <vtrefny@redhat.com>
|
|
Date: Fri, 7 Jun 2024 10:06:22 +0200
|
|
Subject: [PATCH 1/3] fs: Ignore unused-parameter warning in the FS plugin
|
|
|
|
There are some unused parameters in the libext2fs header which
|
|
together with Wall and Werror means the plugin compilation fails.
|
|
As a workaround we'll disable the unused-parameter warning for
|
|
now.
|
|
|
|
Fixes: #1026
|
|
---
|
|
src/plugins/fs/Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/plugins/fs/Makefile.am b/src/plugins/fs/Makefile.am
|
|
index 7d4849c0..00474d5a 100644
|
|
--- a/src/plugins/fs/Makefile.am
|
|
+++ b/src/plugins/fs/Makefile.am
|
|
@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
|
|
|
|
lib_LTLIBRARIES = libbd_fs.la
|
|
|
|
-libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror
|
|
+libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter
|
|
libbd_fs_la_LIBADD = ${builddir}/../../utils/libbd_utils.la $(GLIB_LIBS) $(GIO_LIBS) $(BLKID_LIBS) $(MOUNT_LIBS) $(UUID_LIBS) $(EXT2FS_LIBS)
|
|
libbd_fs_la_LDFLAGS = -L${srcdir}/../../utils/ -version-info 3:0:0 -Wl,--no-undefined -export-symbols-regex '^bd_.*'
|
|
libbd_fs_la_CPPFLAGS = -I${builddir}/../../../include/ -I${srcdir}/../
|
|
--
|
|
2.45.2
|
|
|
|
|
|
From 30e7d0bd7b78b5d9a2ddd031d0cdf9f45187a717 Mon Sep 17 00:00:00 2001
|
|
From: Vojtech Trefny <vtrefny@redhat.com>
|
|
Date: Fri, 7 Jun 2024 15:21:09 +0200
|
|
Subject: [PATCH 2/3] fs: Ignore shift-count-overflow warning in FS plugin
|
|
|
|
The warning happens in the libext2fs header.
|
|
---
|
|
src/plugins/fs/Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/plugins/fs/Makefile.am b/src/plugins/fs/Makefile.am
|
|
index 00474d5a..42e1c777 100644
|
|
--- a/src/plugins/fs/Makefile.am
|
|
+++ b/src/plugins/fs/Makefile.am
|
|
@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
|
|
|
|
lib_LTLIBRARIES = libbd_fs.la
|
|
|
|
-libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter
|
|
+libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter -Wno-shift-count-overflow
|
|
libbd_fs_la_LIBADD = ${builddir}/../../utils/libbd_utils.la $(GLIB_LIBS) $(GIO_LIBS) $(BLKID_LIBS) $(MOUNT_LIBS) $(UUID_LIBS) $(EXT2FS_LIBS)
|
|
libbd_fs_la_LDFLAGS = -L${srcdir}/../../utils/ -version-info 3:0:0 -Wl,--no-undefined -export-symbols-regex '^bd_.*'
|
|
libbd_fs_la_CPPFLAGS = -I${builddir}/../../../include/ -I${srcdir}/../
|
|
--
|
|
2.45.2
|
|
|
|
|
|
From b40ce052f98c9afb3e5bd0f91e7eb8bf6cbacd90 Mon Sep 17 00:00:00 2001
|
|
From: Vojtech Trefny <vtrefny@redhat.com>
|
|
Date: Wed, 12 Jun 2024 15:34:02 +0200
|
|
Subject: [PATCH 3/3] fs: Fix ignoring errors from libext2fs
|
|
|
|
Follow-up for #1028, we still want to show the warning and not
|
|
completely supress it.
|
|
---
|
|
src/plugins/fs/Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/plugins/fs/Makefile.am b/src/plugins/fs/Makefile.am
|
|
index 42e1c777..1ee256f0 100644
|
|
--- a/src/plugins/fs/Makefile.am
|
|
+++ b/src/plugins/fs/Makefile.am
|
|
@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
|
|
|
|
lib_LTLIBRARIES = libbd_fs.la
|
|
|
|
-libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-unused-parameter -Wno-shift-count-overflow
|
|
+libbd_fs_la_CFLAGS = $(GLIB_CFLAGS) $(GIO_CFLAGS) $(BLKID_CFLAGS) $(MOUNT_CFLAGS) $(UUID_CFLAGS) $(EXT2FS_CFLAGS) -Wall -Wextra -Werror -Wno-error=unused-parameter -Wno-error=shift-count-overflow
|
|
libbd_fs_la_LIBADD = ${builddir}/../../utils/libbd_utils.la $(GLIB_LIBS) $(GIO_LIBS) $(BLKID_LIBS) $(MOUNT_LIBS) $(UUID_LIBS) $(EXT2FS_LIBS)
|
|
libbd_fs_la_LDFLAGS = -L${srcdir}/../../utils/ -version-info 3:0:0 -Wl,--no-undefined -export-symbols-regex '^bd_.*'
|
|
libbd_fs_la_CPPFLAGS = -I${builddir}/../../../include/ -I${srcdir}/../
|
|
--
|
|
2.45.2
|
|
|