Add patch for previous commit to dist-git
This commit is contained in:
parent
6d2d2ca1e5
commit
7f1c202819
@ -1,4 +1,4 @@
|
||||
From 9ae286f69df95235fa2534fbb08e0f8c399ac6a5 Mon Sep 17 00:00:00 2001
|
||||
From d05deed377b4e793c8c319eb028b8343fb317586 Mon Sep 17 00:00:00 2001
|
||||
From: Vojtech Trefny <vtrefny@redhat.com>
|
||||
Date: Wed, 16 Jun 2021 16:15:38 +0200
|
||||
Subject: [PATCH] crypto: Let cryptsetup autodect encryption sector size when
|
||||
@ -12,7 +12,7 @@ Thanks to this 4k sector size will be used on 4k drives.
|
||||
3 files changed, 89 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index abe1412f..ad71a46d 100644
|
||||
index abe1412..ad71a46 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -211,6 +211,8 @@ AS_IF([test "x$with_crypto" != "xno"],
|
||||
@ -25,12 +25,12 @@ index abe1412f..ad71a46d 100644
|
||||
[LIBBLOCKDEV_PKG_CHECK_MODULES([NSS], [nss >= 3.18.0])
|
||||
LIBBLOCKDEV_CHECK_HEADER([volume_key/libvolume_key.h], [$GLIB_CFLAGS $NSS_CFLAGS], [libvolume_key.h not available])],
|
||||
diff --git a/src/plugins/crypto.h b/src/plugins/crypto.h
|
||||
index a38724d9..1c8f47ea 100644
|
||||
index 71a1438..fef1e73 100644
|
||||
--- a/src/plugins/crypto.h
|
||||
+++ b/src/plugins/crypto.h
|
||||
@@ -38,7 +38,13 @@ typedef enum {
|
||||
|
||||
#define DEFAULT_LUKS_KEYSIZE_BITS 256
|
||||
#define DEFAULT_LUKS_KEYSIZE_BITS 512
|
||||
#define DEFAULT_LUKS_CIPHER "aes-xts-plain64"
|
||||
+
|
||||
+#ifdef LIBCRYPTSETUP_24
|
||||
@ -43,10 +43,10 @@ index a38724d9..1c8f47ea 100644
|
||||
typedef enum {
|
||||
BD_CRYPTO_TECH_LUKS = 0,
|
||||
diff --git a/tests/crypto_test.py b/tests/crypto_test.py
|
||||
index 0aecc032..66934505 100644
|
||||
index 0609a07..3e99a2d 100644
|
||||
--- a/tests/crypto_test.py
|
||||
+++ b/tests/crypto_test.py
|
||||
@@ -16,26 +16,18 @@
|
||||
@@ -16,26 +16,18 @@ PASSWD = "myshinylittlepassword"
|
||||
PASSWD2 = "myshinylittlepassword2"
|
||||
PASSWD3 = "myshinylittlepassword3"
|
||||
|
||||
@ -77,7 +77,7 @@ index 0aecc032..66934505 100644
|
||||
|
||||
|
||||
class CryptoTestCase(unittest.TestCase):
|
||||
@@ -964,6 +956,83 @@ def test_luks2_format(self):
|
||||
@@ -928,6 +920,83 @@ class CryptoTestInfo(CryptoTestCase):
|
||||
succ = BlockDev.crypto_luks_close("libblockdevTestLUKS")
|
||||
self.assertTrue(succ)
|
||||
|
||||
@ -161,3 +161,6 @@ index 0aecc032..66934505 100644
|
||||
class CryptoTestIntegrity(CryptoTestCase):
|
||||
@tag_test(TestTags.SLOW)
|
||||
@unittest.skipUnless(HAVE_LUKS2, "LUKS 2 not supported")
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user