- Update to 2.8.4
This commit is contained in:
parent
d2d6c8492b
commit
46f6ae9375
@ -1 +1 @@
|
||||
libarchive-2.8.0.tar.gz
|
||||
libarchive-2.8.4.tar.gz
|
||||
|
33
libarchive-2.8.4-iso9660-data-types.patch
Normal file
33
libarchive-2.8.4-iso9660-data-types.patch
Normal file
@ -0,0 +1,33 @@
|
||||
Index: libarchive/archive_read_support_format_iso9660.c
|
||||
===================================================================
|
||||
--- libarchive/archive_read_support_format_iso9660.c (revision 1983)
|
||||
+++ libarchive/archive_read_support_format_iso9660.c (revision 1984)
|
||||
@@ -924,7 +924,7 @@
|
||||
if (parent->offset + parent->size > iso9660->volume_size) {
|
||||
archive_set_error(&a->archive, ARCHIVE_ERRNO_MISC,
|
||||
"Directory is beyond end-of-media: %s",
|
||||
- parent->name);
|
||||
+ parent->name.s);
|
||||
return (ARCHIVE_WARN);
|
||||
}
|
||||
if (iso9660->current_position < parent->offset) {
|
||||
@@ -1220,7 +1220,7 @@
|
||||
|
||||
if (file->offset + file->size > iso9660->volume_size) {
|
||||
archive_set_error(&a->archive, ARCHIVE_ERRNO_MISC,
|
||||
- "File is beyond end-of-media: %s", file->name);
|
||||
+ "File is beyond end-of-media: %s", file->name.s);
|
||||
iso9660->entry_bytes_remaining = 0;
|
||||
iso9660->entry_sparse_offset = 0;
|
||||
return (ARCHIVE_WARN);
|
||||
@@ -1279,8 +1279,8 @@
|
||||
if ((file->mode & AE_IFMT) != AE_IFDIR &&
|
||||
file->offset < iso9660->current_position) {
|
||||
archive_set_error(&a->archive, ARCHIVE_ERRNO_MISC,
|
||||
- "Ignoring out-of-order file @%x (%s) %jd < %jd",
|
||||
- file,
|
||||
+ "Ignoring out-of-order file @%jx (%s) %jd < %jd",
|
||||
+ (intmax_t)file->number,
|
||||
iso9660->pathname.s,
|
||||
file->offset, iso9660->current_position);
|
||||
iso9660->entry_bytes_remaining = 0;
|
@ -1,5 +1,5 @@
|
||||
Name: libarchive
|
||||
Version: 2.8.3
|
||||
Version: 2.8.4
|
||||
Release: 1%{?dist}
|
||||
Summary: A library for handling streaming archive formats
|
||||
|
||||
@ -21,9 +21,11 @@ BuildRequires: libattr-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: libxml2-devel
|
||||
|
||||
# The patch touches Makefile.am files:
|
||||
BuildRequires: automake autoconf
|
||||
BuildRequires: libtool
|
||||
|
||||
# from upstream
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=597243
|
||||
Patch0: libarchive-2.8.4-iso9660-data-types.patch
|
||||
|
||||
|
||||
%description
|
||||
Libarchive is a programming library that can create and read several different
|
||||
@ -43,11 +45,10 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0 -b .iso9660-testsuite
|
||||
|
||||
|
||||
%build
|
||||
libtoolize --force || :
|
||||
autoreconf || :
|
||||
%configure --disable-static --disable-bsdtar --disable-bsdcpio
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -87,6 +88,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 30 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.8.4-1
|
||||
- Update to 2.8.4
|
||||
|
||||
* Fri Jun 25 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.8.3-2
|
||||
- Fix ISO9660 reader data type mismatches (#597243)
|
||||
|
||||
* Tue Mar 16 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.8.3-1
|
||||
- Update to 2.8.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user