Do not support RIPEMD-160 on OpenSSL 3.0
It is relegated to the Legacy provider. Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
c77e99481f
commit
34b814314e
29
0001-Drop-rmd160-from-OpenSSL.patch
Normal file
29
0001-Drop-rmd160-from-OpenSSL.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From ec97aebcd2a3c4ed3a2fbb0037364b349bf9e84a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
|
Date: Fri, 3 Dec 2021 11:07:55 -0500
|
||||||
|
Subject: [PATCH] Drop rmd160 from OpenSSL
|
||||||
|
|
||||||
|
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
|
---
|
||||||
|
configure.ac | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index cb89c3ee81530e63e18f12aec2bbf04e8c0a1a34..b4d8ceabba4131a93589c0cf6bcd29bed8bdc774 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -1205,11 +1205,10 @@ if test "x$with_openssl" != "xno"; then
|
||||||
|
*)
|
||||||
|
AC_CHECK_LIB(crypto,OPENSSL_config)
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
CRYPTO_CHECK(MD5, OPENSSL, md5)
|
||||||
|
- CRYPTO_CHECK(RMD160, OPENSSL, rmd160)
|
||||||
|
CRYPTO_CHECK(SHA1, OPENSSL, sha1)
|
||||||
|
CRYPTO_CHECK(SHA256, OPENSSL, sha256)
|
||||||
|
CRYPTO_CHECK(SHA384, OPENSSL, sha384)
|
||||||
|
CRYPTO_CHECK(SHA512, OPENSSL, sha512)
|
||||||
|
AC_CHECK_FUNCS([PKCS5_PBKDF2_HMAC_SHA1])
|
||||||
|
--
|
||||||
|
2.33.1
|
||||||
|
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: libarchive
|
Name: libarchive
|
||||||
Version: 3.5.2
|
Version: 3.5.2
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: A library for handling streaming archive formats
|
Summary: A library for handling streaming archive formats
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -11,6 +11,7 @@ Source0: https://libarchive.org/downloads/%{name}-%{version}.tar.gz
|
|||||||
|
|
||||||
Patch0: libarchive-3.5.2-symlink-fix.patch
|
Patch0: libarchive-3.5.2-symlink-fix.patch
|
||||||
|
|
||||||
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: bzip2-devel
|
BuildRequires: bzip2-devel
|
||||||
@ -18,6 +19,7 @@ BuildRequires: e2fsprogs-devel
|
|||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: libacl-devel
|
BuildRequires: libacl-devel
|
||||||
BuildRequires: libattr-devel
|
BuildRequires: libattr-devel
|
||||||
|
BuildRequires: libtool
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libzstd-devel
|
BuildRequires: libzstd-devel
|
||||||
BuildRequires: lz4-devel
|
BuildRequires: lz4-devel
|
||||||
@ -31,6 +33,14 @@ BuildRequires: xz-devel
|
|||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
|
|
||||||
|
# When configured against OpenSSL 1.1, the RIPEMD-160 support was not detected,
|
||||||
|
# so it was not compiled in previously. With OpenSSL 3.0, it's now detected as
|
||||||
|
# being available, but it only actually works when the legacy provider is
|
||||||
|
# loaded, which breaks the RIPEMD-160 test. This patch disables the RIPEMD-160
|
||||||
|
# support explicitly.
|
||||||
|
Patch0001: 0001-Drop-rmd160-from-OpenSSL.patch
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Libarchive is a programming library that can create and read several different
|
Libarchive is a programming library that can create and read several different
|
||||||
streaming archive formats, including most popular tar variants, several cpio
|
streaming archive formats, including most popular tar variants, several cpio
|
||||||
@ -80,6 +90,7 @@ standard output.
|
|||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
autoreconf -ifv
|
||||||
%configure --disable-static LT_SYS_LIBRARY_PATH=%_libdir
|
%configure --disable-static LT_SYS_LIBRARY_PATH=%_libdir
|
||||||
%make_build
|
%make_build
|
||||||
|
|
||||||
@ -213,6 +224,9 @@ run_testsuite
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 03 2021 Stephen Gallagher <sgallagh@redhat.com> - 3.5.2-5
|
||||||
|
- Drop RIPEMD-160 support for OpenSSL 3.0
|
||||||
|
|
||||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 3.5.2-3
|
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 3.5.2-3
|
||||||
- Rebuilt with OpenSSL 3.0.0
|
- Rebuilt with OpenSSL 3.0.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user