Version bump to 1.0.2 (#1504372)

This commit is contained in:
Christoph Junghans 2017-10-24 16:09:51 -06:00
parent 2c28e95cc9
commit c5b9b70242
4 changed files with 8 additions and 35 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/libaec-1.0.0.tar.gz
/libaec-*.src.rpm
/libaec-1.0.1.tar.gz
/libaec-1.0.2.tar.gz

View File

@ -1,29 +0,0 @@
From a3d42317b104f7dc12dd9821293ddd079df352d4 Mon Sep 17 00:00:00 2001
From: Christoph Junghans <junghans@votca.org>
Date: Sat, 12 Aug 2017 10:36:24 -0600
Subject: [PATCH] cmake: require c99 standard
Some files, e.g. encode_accessors.c, use loop initial declarations
that are only allowed in C99 mode. Newer compilers enable that mode
automatically, but olders might fail. CMAKE_C_STANDARD got add in
CMake-3.1, so let's increase the minimal version by 0.1.
Signed-off-by: Christoph Junghans <junghans@votca.org>
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8b0e93..22f24e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,5 @@
-cmake_minimum_required(VERSION 3.0.0)
+cmake_minimum_required(VERSION 3.1)
+set(CMAKE_C_STANDARD 99)
include(CheckIncludeFiles)
include(TestBigEndian)
include(CheckCSourceCompiles)
--
2.13.0

View File

@ -1,11 +1,10 @@
Name: libaec
Version: 1.0.1
Release: 4%{?dist}
Version: 1.0.2
Release: 1%{?dist}
Summary: Adaptive Entropy Coding library
License: BSD
Url: https://gitlab.dkrz.de/k202009/libaec
Source: https://gitlab.dkrz.de/k202009/libaec/repository/archive.tar.gz?ref=v%{version}/%{name}-%{version}.tar.gz
Patch0: c99.patch
BuildRequires: %{?fedora:cmake >= 3.1}%{?rhel:cmake3 >= 3.1}
@ -34,7 +33,6 @@ Devel files for libaec (Adaptive Entropy Coding library).
%prep
%setup -q -T -a 0 -c
mv %{name}-v%{version}-*/* .
%patch0 -p1
%build
mkdir build
@ -65,7 +63,10 @@ make -C build test ARGS="-E \(check_szcomp\|sampledata.sh\)"
%{_libdir}/lib*.so
%changelog
* Sun Aug 13 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-4
* Tue Oct 24 2017 Christoph Junghans <junghans@votca.org> - 1.0.2-1
- Version bump to 1.0.2 (#1504372)
* Sun Aug 13 2017 Christoph Junghans <junghans@votca.org>- 1.0.1-4
- Tweaks for EPEL7
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3

View File

@ -1 +1 @@
SHA512 (libaec-1.0.1.tar.gz) = e3e38298d8d1fdf86332612c4dd62cafb8fa59ec8de00ed96aabee5bfbb46fd2396fcc0ad7fa2e4f89f9a22de538e58be5017d214b42176c0450dcc7c35bfedb
SHA512 (libaec-1.0.2.tar.gz) = 28a8839089e4b643b259cb8679b96e602a35098d1129baae6b3923767060e5deabfa33256d628a8bcbf205368cda5f2e6701078de0caccf44e0597d932a67ba2