Remove 0001-Fix-fedabipkgdiff-configure-check-for-Python-3.12.patch

Signed-off-by: Dodji Seketeli <dodji@redhat.com>
This commit is contained in:
Dodji Seketeli 2023-10-20 23:31:31 +02:00
parent 5915efec7c
commit 539cc0746a

View File

@ -1,40 +0,0 @@
From 020f008cc58f9cb61baaa175ae1fcb6c4faca55b Mon Sep 17 00:00:00 2001
From: Yaakov Selkowitz <yselkowi@redhat.com>
Date: Fri, 7 Jul 2023 13:57:28 -0400
Subject: [PATCH] Fix fedabipkgdiff configure check for Python 3.12
importlib is the Python 3 replacement to imp, which was deprecated in
Python 3.4 and removed in 3.12.
* configure.ac (REQUIRED_PYTHON_MODULES_FOR_FEDABIPKGDIFF):
Test for importlib.machinery instead of imp with python3.
Signed-off-by: Yaakov Selkowitz <yselkowi@redhat.com>
---
configure.ac | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index b4e7e38e..b3f97ba2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -739,13 +739,15 @@ if test x$CHECK_DEPS_FOR_FEDABIPKGDIFF = xyes; then
# urllib.parse. Oh well.
if test x$PYTHON = xpython3; then
URLPARSE_MODULE=urllib.parse
+ IMPORT_MODULE=importlib.machinery
else
URLPARSE_MODULE=urlparse
+ IMPORT_MODULE=imp
fi
REQUIRED_PYTHON_MODULES_FOR_FEDABIPKGDIFF="\
argparse logging os re subprocess sys $URLPARSE_MODULE \
- xdg koji mock rpm imp tempfile mimetypes shutil six"
+ xdg koji mock rpm $IMPORT_MODULE tempfile mimetypes shutil six"
AX_CHECK_PYTHON_MODULES([$REQUIRED_PYTHON_MODULES_FOR_FEDABIPKGDIFF],
[$PYTHON],
--
2.41.0