import libXres-1.2.0-14.el9
This commit is contained in:
commit
259b821c57
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/libXres-1.2.0.tar.bz2
|
1
.libXres.metadata
Normal file
1
.libXres.metadata
Normal file
@ -0,0 +1 @@
|
||||
b6996ab05460a3b7311f02da23ddf117a5442fd9 SOURCES/libXres-1.2.0.tar.bz2
|
@ -0,0 +1,33 @@
|
||||
From 3e6bdd90c604e061c71715865eb403ffdd0dd7f0 Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Wed, 21 Oct 2020 10:03:23 -0400
|
||||
Subject: [PATCH] XRes: Use _XRead instead of _XRead32 for reading pid
|
||||
|
||||
_XRead32 requires the output variable to be a long, but
|
||||
`ReadClientValues` feeds it client->value which is a
|
||||
32-bit allocation.
|
||||
|
||||
This commit changes the code to use _XRead instead, which
|
||||
properly handles 32-bit output variables.
|
||||
|
||||
https://gitlab.freedesktop.org/xorg/lib/libxres/-/issues/3
|
||||
---
|
||||
src/XRes.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/XRes.c b/src/XRes.c
|
||||
index 2bee277..90e72c9 100644
|
||||
--- a/src/XRes.c
|
||||
+++ b/src/XRes.c
|
||||
@@ -256,7 +256,7 @@ static Bool ReadClientValues(
|
||||
_XRead32 (dpy, &value, 4);
|
||||
client->length = value;
|
||||
client->value = malloc(client->length);
|
||||
- _XRead32 (dpy, client->value, client->length);
|
||||
+ _XRead (dpy, client->value, client->length);
|
||||
}
|
||||
return True;
|
||||
}
|
||||
--
|
||||
2.28.0
|
||||
|
271
SPECS/libXres.spec
Normal file
271
SPECS/libXres.spec
Normal file
@ -0,0 +1,271 @@
|
||||
%global tarball libXres
|
||||
#global gitdate 20130524
|
||||
#global gitversion f46818496
|
||||
|
||||
Summary: X-Resource extension client library
|
||||
Name: libXres
|
||||
Version: 1.2.0
|
||||
Release: 14%{?gitdate:.%{gitdate}git%{gitversion}}%{?dist}
|
||||
License: MIT
|
||||
URL: http://www.x.org
|
||||
|
||||
%if 0%{?gitdate}
|
||||
Source0: %{tarball}-%{gitdate}.tar.bz2
|
||||
Source1: make-git-snapshot.sh
|
||||
Source2: commitid
|
||||
%else
|
||||
Source0: https://www.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
|
||||
%endif
|
||||
# Fixes a bug which causes metacity 3.38.0+ to crash on startup:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1888993
|
||||
# https://gitlab.freedesktop.org/xorg/lib/libxres/-/issues/3
|
||||
# https://gitlab.freedesktop.org/xorg/lib/libxres/-/merge_requests/1
|
||||
Patch0: 0001-XRes-Use-_XRead-instead-of-_XRead32-for-reading-pid.patch
|
||||
|
||||
Requires: libX11 >= 1.5.99.902
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: xorg-x11-util-macros
|
||||
BuildRequires: autoconf automake libtool
|
||||
BuildRequires: pkgconfig(xext)
|
||||
BuildRequires: pkgconfig(x11) >= 1.5.99.902
|
||||
|
||||
%description
|
||||
X-Resource is an extension that allows a client to query
|
||||
the X server about its usage of various resources.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
X.Org X11 libXres development package
|
||||
|
||||
%prep
|
||||
%setup -q -n %{tarball}-%{?gitdate:%{gitdate}}%{!?gitdate:%{version}}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
autoreconf -v --install --force
|
||||
%configure --disable-static
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
# We intentionally don't ship *.la files
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
|
||||
%ldconfig_post
|
||||
%ldconfig_postun
|
||||
|
||||
%files
|
||||
%doc AUTHORS COPYING
|
||||
%{_libdir}/libXRes.so.1
|
||||
%{_libdir}/libXRes.so.1.0.0
|
||||
|
||||
%files devel
|
||||
%{_includedir}/X11/extensions/XRes.h
|
||||
%{_libdir}/libXRes.so
|
||||
%{_libdir}/pkgconfig/xres.pc
|
||||
%{_mandir}/man3/*.3*
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.2.0-14
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.2.0-13
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Thu Nov 5 12:16:29 AEST 2020 Peter Hutterer <peter.hutterer@redhat.com> - 1.2.0-11
|
||||
- Add BuildRequires for make
|
||||
|
||||
* Wed Oct 21 2020 Adam Williamson <awilliam@redhat.com> - 1.2.0-10
|
||||
- Backport upstream MR #1 to fix RHBZ #1888993 (metacity crash)
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Jul 05 2018 Adam Jackson <ajax@redhat.com> - 1.2.0-4
|
||||
- Drop useless %%defattr
|
||||
|
||||
* Fri Jun 29 2018 Adam Jackson <ajax@redhat.com> - 1.2.0-3
|
||||
- Use ldconfig scriptlet macros
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Oct 11 2017 Adam Jackson <ajax@redhat.com> - 1.2.0-1
|
||||
- libXres 1.2.0
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri May 31 2013 Peter Hutterer <peter.hutterer@redhat.com> 1.0.7-1
|
||||
- libXres 1.0.7
|
||||
|
||||
* Mon May 27 2013 Peter Hutterer <peter.hutterer@redhat.com> - 1.0.6-6.20130524gitf46818496
|
||||
- Require libX11 1.6RC2 for _XEatDataWords
|
||||
|
||||
* Fri May 24 2013 Dave Airlie <airlied@redhat.com> 1.0.6-5.20130524gitf46818496
|
||||
- update for CVE fixes (CVE-2013-1988)
|
||||
|
||||
* Thu Mar 07 2013 Peter Hutterer <peter.hutterer@redhat.com> - 1.0.6-4
|
||||
- autoreconf for aarch64
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Thu Mar 08 2012 Adam Jackson <ajax@redhat.com> 1.0.6-1
|
||||
- libXres 1.0.6
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Nov 08 2010 Adam Jackson <ajax@redhat.com> 1.0.5-1
|
||||
- libXres 1.0.5
|
||||
|
||||
* Tue Oct 13 2009 Adam Jackson <ajax@redhat.com> 1.0.4-1
|
||||
- libXres 1.0.4
|
||||
|
||||
* Thu Aug 13 2009 Parag <paragn@fedoraproject.org> 1.0.3-9
|
||||
- Merge-review cleanups #226086
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Thu Jul 23 2009 Adam Jackson <ajax@redhat.com> 1.0.3-7
|
||||
- Un-require xorg-x11-filesystem
|
||||
- Remove useless %%dir
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Tue Jul 15 2008 Adam Jackson <ajax@redhat.com> 1.0.3-5
|
||||
- Fix license tag.
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.3-4
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
|
||||
- Rebuild for build id
|
||||
|
||||
* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
|
||||
- Don't install INSTALL
|
||||
|
||||
* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
|
||||
- Update to 1.0.3
|
||||
|
||||
* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1
|
||||
- Update to 1.0.2
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-3.1
|
||||
- rebuild
|
||||
|
||||
* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
|
||||
- Added "Requires: xorg-x11-proto-devel" to devel package for xres.pc
|
||||
|
||||
* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
|
||||
- Added "BuildRequires: pkgconfig" for (#193502)
|
||||
- Replace "makeinstall" with "make install DESTDIR=..." for (#192725)
|
||||
- Remove package ownership of mandir/libdir/etc.
|
||||
|
||||
* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
|
||||
- Update to 1.0.1
|
||||
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.2
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.1
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
|
||||
- Bumped and rebuilt
|
||||
|
||||
* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
|
||||
- Updated libXres to version 1.0.0 from X11R7 RC4
|
||||
|
||||
* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
|
||||
- Updated libXres to version 0.99.3 from X11R7 RC3
|
||||
- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
|
||||
that /usr/lib/X11 and /usr/include/X11 pre-exist.
|
||||
- Removed 'x' suffix from manpage directories to match RC3 upstream.
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
|
||||
- Updated libXres to version 0.99.2 from X11R7 RC2
|
||||
- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
|
||||
- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
|
||||
|
||||
* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
|
||||
- Updated libXres to version 0.99.1 from X11R7 RC1
|
||||
- Updated file manifest to find manpages in "man3x"
|
||||
|
||||
* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
|
||||
- Renamed package to remove xorg-x11 from the name due to unanimous decision
|
||||
between developers.
|
||||
- Use Fedora Extras style BuildRoot tag.
|
||||
- Disable static library creation by default.
|
||||
- Add missing defattr to devel subpackage
|
||||
- Add missing documentation files to doc macro
|
||||
|
||||
* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
|
||||
- Renamed package to prepend "xorg-x11" to the name for consistency with
|
||||
the rest of the X11R7 packages.
|
||||
- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
|
||||
subpackage to ensure the devel package matches the installed shared libs.
|
||||
- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
|
||||
allow applications to use implementation agnostic dependencies.
|
||||
- Added post/postun scripts which call ldconfig.
|
||||
- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
|
||||
and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
|
||||
|
||||
* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
|
||||
- Initial build.
|
Loading…
Reference in New Issue
Block a user