Auto sync2gitlab import of libXpm-3.5.12-8.el8.src.rpm
This commit is contained in:
parent
ee8a247bc6
commit
6e03727b8c
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
/libXpm-3.5.12.tar.bz2
|
@ -0,0 +1,40 @@
|
|||||||
|
From e00066fb973a1796dd3989e356e17c8b51add521 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Alan Coopersmith <alan.coopersmith@oracle.com>
|
||||||
|
Date: Sun, 30 Sep 2018 15:09:29 -0700
|
||||||
|
Subject: [PATCH 1/3] After fdopen(), use fclose() instead of close() in error
|
||||||
|
path
|
||||||
|
|
||||||
|
Found by Oracle's Parfait 2.2 static analyzer:
|
||||||
|
|
||||||
|
Error: File Leak
|
||||||
|
File Leak [file-ptr-leak]:
|
||||||
|
Leaked File fp
|
||||||
|
at line 94 of lib/libXpm/src/RdFToBuf.c in function 'XpmReadFileToBuffer
|
||||||
|
'.
|
||||||
|
fp initialized at line 86 with fdopen
|
||||||
|
fp leaks when len < 0 at line 92.
|
||||||
|
|
||||||
|
Introduced-by: commit 8b3024e6871ce50b34bf2dff924774bd654703bc
|
||||||
|
|
||||||
|
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
|
||||||
|
Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
|
||||||
|
---
|
||||||
|
src/RdFToBuf.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/RdFToBuf.c b/src/RdFToBuf.c
|
||||||
|
index 69e3347d24f2..1b386f81fde3 100644
|
||||||
|
--- a/src/RdFToBuf.c
|
||||||
|
+++ b/src/RdFToBuf.c
|
||||||
|
@@ -90,7 +90,7 @@ XpmReadFileToBuffer(
|
||||||
|
}
|
||||||
|
len = stats.st_size;
|
||||||
|
if (len < 0 || len >= SIZE_MAX) {
|
||||||
|
- close(fd);
|
||||||
|
+ fclose(fp);
|
||||||
|
return XpmOpenFailed;
|
||||||
|
}
|
||||||
|
ptr = (char *) XpmMalloc(len + 1);
|
||||||
|
--
|
||||||
|
2.23.0
|
||||||
|
|
118
libXpm.spec
Normal file
118
libXpm.spec
Normal file
@ -0,0 +1,118 @@
|
|||||||
|
Summary: X.Org X11 libXpm runtime library
|
||||||
|
Name: libXpm
|
||||||
|
Version: 3.5.12
|
||||||
|
Release: 8%{?dist}
|
||||||
|
License: MIT
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
URL: http://www.x.org
|
||||||
|
|
||||||
|
Source0: https://www.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
|
||||||
|
|
||||||
|
BuildRequires: xorg-x11-util-macros
|
||||||
|
BuildRequires: autoconf automake libtool
|
||||||
|
BuildRequires: gettext
|
||||||
|
BuildRequires: pkgconfig(xext) pkgconfig(xt) pkgconfig(xau)
|
||||||
|
|
||||||
|
Patch0: 0001-After-fdopen-use-fclose-instead-of-close-in-error-pa.patch
|
||||||
|
|
||||||
|
%description
|
||||||
|
X.Org X11 libXpm runtime library
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: X.Org X11 libXpm development package
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
X.Org X11 libXpm development package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .covscan
|
||||||
|
|
||||||
|
%build
|
||||||
|
autoreconf -v --install --force
|
||||||
|
%configure --disable-static
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
# We intentionally don't ship *.la files
|
||||||
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
|
|
||||||
|
%ldconfig_post
|
||||||
|
%ldconfig_postun
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc AUTHORS COPYING ChangeLog
|
||||||
|
%{_libdir}/libXpm.so.4
|
||||||
|
%{_libdir}/libXpm.so.4.11.0
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_bindir}/cxpm
|
||||||
|
%{_bindir}/sxpm
|
||||||
|
%{_includedir}/X11/xpm.h
|
||||||
|
%{_libdir}/libXpm.so
|
||||||
|
%{_libdir}/pkgconfig/xpm.pc
|
||||||
|
#%dir %{_mandir}/man1x
|
||||||
|
%{_mandir}/man1/*.1*
|
||||||
|
#%{_mandir}/man1/*.1x*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Dec 09 2019 Benjamin Tissoires <benjamin.tissoires@redhat.com> 3.5.12-8%{?dist}
|
||||||
|
- add covscan fixes (#1602606)
|
||||||
|
|
||||||
|
* Thu Jul 05 2018 Adam Jackson <ajax@redhat.com> - 3.5.12-7
|
||||||
|
- Drop useless %%defattr
|
||||||
|
|
||||||
|
* Fri Jun 29 2018 Adam Jackson <ajax@redhat.com> - 3.5.12-6
|
||||||
|
- Use ldconfig scriptlet macros
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.12-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.12-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.12-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.12-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 05 2017 Benjamin Tissoires <benjamin.tissoires@redhat.com> 3.5.12-1
|
||||||
|
- libXpm 3.5.12
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.11-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.11-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.11-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.11-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 12 2014 Adam Jackson <ajax@redhat.com> 3.5.11-1
|
||||||
|
- libXpm 3.5.11
|
||||||
|
- Drop pre-F18 changelog
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.10-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 07 2013 Peter Hutterer <peter.hutterer@redhat.com> - 3.5.10-4
|
||||||
|
- autoreconf for aarch64
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.10-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.10-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 08 2012 Adam Jackson <ajax@redhat.com> 3.5.10-1
|
||||||
|
- libXpm 3.5.10
|
Loading…
Reference in New Issue
Block a user