libXp 1.0.4-1
This commit is contained in:
parent
1f4c94d861
commit
9d736e2105
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ libXp-1.0.0.tar.bz2
|
|||||||
printproto-1.0.3.tar.bz2
|
printproto-1.0.3.tar.bz2
|
||||||
/libXp-1.0.2.tar.bz2
|
/libXp-1.0.2.tar.bz2
|
||||||
/libXp-1.0.3.tar.bz2
|
/libXp-1.0.3.tar.bz2
|
||||||
|
/libXp-1.0.4.tar.xz
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
From a1e1a7b0b9a7bcededfc9166df58541675615699 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adam Jackson <ajax@redhat.com>
|
|
||||||
Date: Tue, 16 Oct 2018 12:39:26 -0400
|
|
||||||
Subject: [PATCH] Fix a memory leak on the error path in XpGetLocaleNetString
|
|
||||||
|
|
||||||
After Data() we own the pointer again, so we can just free it before
|
|
||||||
getting the reply.
|
|
||||||
|
|
||||||
Signed-off-by: Adam Jackson <ajax@redhat.com>
|
|
||||||
---
|
|
||||||
src/XpPrinter.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/XpPrinter.c b/src/XpPrinter.c
|
|
||||||
index 03b18c4..4e8cdc9 100644
|
|
||||||
--- a/src/XpPrinter.c
|
|
||||||
+++ b/src/XpPrinter.c
|
|
||||||
@@ -118,14 +118,14 @@ XpGetPrinterList (
|
|
||||||
if (req->localeLen)
|
|
||||||
Data( dpy, (char *) locale, (long) req->localeLen );
|
|
||||||
|
|
||||||
+ XFree(locale);
|
|
||||||
+
|
|
||||||
if (! _XReply (dpy, (xReply *) &rep, 0, xFalse)) {
|
|
||||||
UnlockDisplay(dpy);
|
|
||||||
SyncHandle();
|
|
||||||
return ( (XPPrinterList) NULL ); /* error */
|
|
||||||
}
|
|
||||||
|
|
||||||
- XFree(locale);
|
|
||||||
-
|
|
||||||
*list_count = rep.listCount;
|
|
||||||
|
|
||||||
if (*list_count) {
|
|
||||||
--
|
|
||||||
2.19.0
|
|
||||||
|
|
@ -1374,8 +1374,8 @@ diff -up libXp-1.0.3/Makefile.am.jx libXp-1.0.3/Makefile.am
|
|||||||
-pkgconfig_DATA = xp.pc
|
-pkgconfig_DATA = xp.pc
|
||||||
+pkgconfig_DATA = xp.pc printproto.pc
|
+pkgconfig_DATA = xp.pc printproto.pc
|
||||||
|
|
||||||
-EXTRA_DIST = xp.pc.in ChangeLog
|
-EXTRA_DIST = xp.pc.in ChangeLog README.md
|
||||||
+EXTRA_DIST = xp.pc.in printproto.pc.in ChangeLog
|
+EXTRA_DIST = xp.pc.in printproto.pc.in ChangeLog README.md
|
||||||
MAINTAINERCLEANFILES = ChangeLog
|
MAINTAINERCLEANFILES = ChangeLog
|
||||||
|
|
||||||
.PHONY: ChangeLog
|
.PHONY: ChangeLog
|
||||||
|
11
libXp.spec
11
libXp.spec
@ -9,12 +9,12 @@
|
|||||||
|
|
||||||
Summary: X.Org X11 libXp runtime library
|
Summary: X.Org X11 libXp runtime library
|
||||||
Name: libXp
|
Name: libXp
|
||||||
Version: 1.0.3
|
Version: 1.0.4
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.x.org
|
URL: http://www.x.org
|
||||||
|
|
||||||
Source0: https://www.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
|
Source0: https://www.x.org/pub/individual/lib/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: xorg-x11-util-macros
|
BuildRequires: xorg-x11-util-macros
|
||||||
@ -25,7 +25,6 @@ BuildRequires: libXau-devel
|
|||||||
BuildRequires: libtool automake autoconf gettext
|
BuildRequires: libtool automake autoconf gettext
|
||||||
|
|
||||||
Patch0: add-proto-files.patch
|
Patch0: add-proto-files.patch
|
||||||
Patch1: 0001-Fix-a-memory-leak-on-the-error-path-in-XpGetLocaleNe.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
X.Org X11 libXp runtime library
|
X.Org X11 libXp runtime library
|
||||||
@ -44,7 +43,6 @@ X.Org X11 libXp development package
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .add-proto-files
|
%patch0 -p1 -b .add-proto-files
|
||||||
%patch1 -p1 -b .leak
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
|
CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
|
||||||
@ -82,6 +80,9 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
|||||||
%{_libdir}/pkgconfig/xp.pc
|
%{_libdir}/pkgconfig/xp.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 04 2022 Benjamin Tissoires <benjamin.tissoires@redhat.com> 1.0.4-1
|
||||||
|
- libXp 1.0.4-1
|
||||||
|
|
||||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-12
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-12
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libXp-1.0.3.tar.bz2) = 502a2500ec0f519dae69ac035bf93c65c47e3bc301604aacb350e90043455f3485626194db45208e5521300b282843825e08b7f7c412a7497ffa02f5f1560c8d
|
SHA512 (libXp-1.0.4.tar.xz) = 50e82e7ee7222db13a04f6223ae8653eb783593c3b28825d7fc233af188960bec53d2b11ced281e01140d283d840d0e3822d71f95f5045d594fb704485fd0f89
|
||||||
|
Loading…
Reference in New Issue
Block a user