Put the include files under include/X11/extensions
This commit is contained in:
parent
2b5a97d9cf
commit
3ac1bbecd4
@ -1,5 +1,5 @@
|
|||||||
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
|
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
|
||||||
+++ libXp-1.0.0/printproto.pc.in 2006-08-18 19:28:36.000000000 -0400
|
+++ libXp-1.0.0/printproto.pc.in 2006-08-18 20:01:28.000000000 -0400
|
||||||
@@ -0,0 +1,10 @@
|
@@ -0,0 +1,10 @@
|
||||||
+prefix=@prefix@
|
+prefix=@prefix@
|
||||||
+exec_prefix=@exec_prefix@
|
+exec_prefix=@exec_prefix@
|
||||||
@ -11,8 +11,54 @@
|
|||||||
+Version: @PACKAGE_VERSION@
|
+Version: @PACKAGE_VERSION@
|
||||||
+Requires: xau
|
+Requires: xau
|
||||||
+Cflags: -I${includedir}
|
+Cflags: -I${includedir}
|
||||||
|
--- libXp-1.0.0/Makefile.am.add-proto-files 2005-05-18 16:33:36.000000000 -0400
|
||||||
|
+++ libXp-1.0.0/Makefile.am 2006-08-18 20:01:28.000000000 -0400
|
||||||
|
@@ -25,7 +25,12 @@
|
||||||
|
|
||||||
|
SUBDIRS = src man
|
||||||
|
|
||||||
|
+printdir = $(includedir)/X11/extensions
|
||||||
|
+print_HEADERS = \
|
||||||
|
+ $(top_srcdir)/include/X11/extensions/Print.h \
|
||||||
|
+ $(top_srcdir)/include/X11/extensions/Printstr.h
|
||||||
|
+
|
||||||
|
pkgconfigdir = $(libdir)/pkgconfig
|
||||||
|
-pkgconfig_DATA = xp.pc
|
||||||
|
+pkgconfig_DATA = xp.pc printproto.pc
|
||||||
|
|
||||||
|
-EXTRA_DIST = xp.pc.in autogen.sh
|
||||||
|
+EXTRA_DIST = xp.pc.in printproto.pc.in autogen.sh
|
||||||
|
--- libXp-1.0.0/configure.ac.add-proto-files 2005-12-14 19:24:30.000000000 -0500
|
||||||
|
+++ libXp-1.0.0/configure.ac 2006-08-18 20:01:28.000000000 -0400
|
||||||
|
@@ -36,7 +36,7 @@
|
||||||
|
AC_PROG_LIBTOOL
|
||||||
|
|
||||||
|
# Check for X and print proto
|
||||||
|
-PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau printproto)
|
||||||
|
+PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau)
|
||||||
|
|
||||||
|
AC_SUBST(XPRINT_CFLAGS)
|
||||||
|
AC_SUBST(XPRINT_LIBS)
|
||||||
|
@@ -48,5 +48,6 @@
|
||||||
|
AC_OUTPUT([Makefile
|
||||||
|
src/Makefile
|
||||||
|
man/Makefile
|
||||||
|
+ printproto.pc
|
||||||
|
xp.pc])
|
||||||
|
|
||||||
|
--- libXp-1.0.0/src/Makefile.am.add-proto-files 2005-12-02 23:41:50.000000000 -0500
|
||||||
|
+++ libXp-1.0.0/src/Makefile.am 2006-08-18 20:01:28.000000000 -0400
|
||||||
|
@@ -24,7 +24,7 @@
|
||||||
|
|
||||||
|
AM_CFLAGS = $(XPRINT_CFLAGS) $(MALLOC_ZERO_CFLAGS)
|
||||||
|
|
||||||
|
-INCLUDES = -I$(top_srcdir)/include/X11/extensions
|
||||||
|
+INCLUDES = -I$(top_srcdir)/include/
|
||||||
|
|
||||||
|
#
|
||||||
|
# Library version number. This must match old versions on
|
||||||
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
|
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
|
||||||
+++ libXp-1.0.0/Print.h 2006-08-18 19:28:36.000000000 -0400
|
+++ libXp-1.0.0/include/X11/extensions/Print.h 2006-08-18 20:01:28.000000000 -0400
|
||||||
@@ -0,0 +1,552 @@
|
@@ -0,0 +1,552 @@
|
||||||
+/* $Xorg: Print.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */
|
+/* $Xorg: Print.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */
|
||||||
+/******************************************************************************
|
+/******************************************************************************
|
||||||
@ -567,7 +613,7 @@
|
|||||||
+
|
+
|
||||||
+#endif /* _XpPrint_H_ */
|
+#endif /* _XpPrint_H_ */
|
||||||
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
|
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
|
||||||
+++ libXp-1.0.0/Printstr.h 2006-08-18 19:28:36.000000000 -0400
|
+++ libXp-1.0.0/include/X11/extensions/Printstr.h 2006-08-18 20:01:28.000000000 -0400
|
||||||
@@ -0,0 +1,783 @@
|
@@ -0,0 +1,783 @@
|
||||||
+/* $Xorg: Printstr.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */
|
+/* $Xorg: Printstr.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */
|
||||||
+/******************************************************************************
|
+/******************************************************************************
|
||||||
@ -1352,38 +1398,3 @@
|
|||||||
+_XFUNCPROTOEND
|
+_XFUNCPROTOEND
|
||||||
+
|
+
|
||||||
+#endif /* _XpPrintstr_H_ */
|
+#endif /* _XpPrintstr_H_ */
|
||||||
--- libXp-1.0.0/Makefile.am.add-proto-files 2005-05-18 16:33:36.000000000 -0400
|
|
||||||
+++ libXp-1.0.0/Makefile.am 2006-08-18 19:28:36.000000000 -0400
|
|
||||||
@@ -25,7 +25,12 @@
|
|
||||||
|
|
||||||
SUBDIRS = src man
|
|
||||||
|
|
||||||
+printdir = $(includedir)/X11/extensions
|
|
||||||
+print_HEADERS = \
|
|
||||||
+ Print.h \
|
|
||||||
+ Printstr.h
|
|
||||||
+
|
|
||||||
pkgconfigdir = $(libdir)/pkgconfig
|
|
||||||
-pkgconfig_DATA = xp.pc
|
|
||||||
+pkgconfig_DATA = xp.pc printproto.pc
|
|
||||||
|
|
||||||
-EXTRA_DIST = xp.pc.in autogen.sh
|
|
||||||
+EXTRA_DIST = xp.pc.in printproto.pc.in autogen.sh
|
|
||||||
--- libXp-1.0.0/configure.ac.add-proto-files 2005-12-14 19:24:30.000000000 -0500
|
|
||||||
+++ libXp-1.0.0/configure.ac 2006-08-18 19:29:20.000000000 -0400
|
|
||||||
@@ -36,7 +36,7 @@
|
|
||||||
AC_PROG_LIBTOOL
|
|
||||||
|
|
||||||
# Check for X and print proto
|
|
||||||
-PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau printproto)
|
|
||||||
+PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau)
|
|
||||||
|
|
||||||
AC_SUBST(XPRINT_CFLAGS)
|
|
||||||
AC_SUBST(XPRINT_LIBS)
|
|
||||||
@@ -48,5 +48,6 @@
|
|
||||||
AC_OUTPUT([Makefile
|
|
||||||
src/Makefile
|
|
||||||
man/Makefile
|
|
||||||
+ printproto.pc
|
|
||||||
xp.pc])
|
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user