libXp 1.0.2. Drags in a bunch of general cleanup, code changes are quite

limited and CVE-2013-2062 (#960362)
This commit is contained in:
Peter Hutterer 2013-07-01 13:56:31 +10:00
parent ded3564102
commit 2712080ab8
4 changed files with 107 additions and 63 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
libXp-1.0.0.tar.bz2 libXp-1.0.0.tar.bz2
printproto-1.0.3.tar.bz2 printproto-1.0.3.tar.bz2
/libXp-1.0.2.tar.bz2

View File

@ -1,19 +1,25 @@
--- /dev/null 2006-08-16 13:34:07.659756891 -0400 From bbf6d3783ba9f5cd1489dd6bb042915c685b41b0 Mon Sep 17 00:00:00 2001
+++ libXp-1.0.0/printproto.pc.in 2006-08-18 20:01:28.000000000 -0400 From: Peter Hutterer <peter.hutterer@who-t.net>
@@ -0,0 +1,10 @@ Date: Mon, 1 Jul 2013 15:04:04 +1000
+prefix=@prefix@ Subject: [PATCH] Patch printproto into libXp
+exec_prefix=@exec_prefix@
+libdir=@libdir@ ---
+includedir=@includedir@ Makefile.am | 9 +-
+ configure.ac | 3 +-
+Name: PrintProto include/X11/extensions/Print.h | 552 +++++++++++++++++++++++++++
+Description: Print extension headers include/X11/extensions/Printstr.h | 783 ++++++++++++++++++++++++++++++++++++++
+Version: @PACKAGE_VERSION@ printproto.pc.in | 10 +
+Requires: xau src/Makefile.am | 2 +-
+Cflags: -I${includedir} 6 files changed, 1355 insertions(+), 4 deletions(-)
--- libXp-1.0.0/Makefile.am.add-proto-files 2005-05-18 16:33:36.000000000 -0400 create mode 100644 include/X11/extensions/Print.h
+++ libXp-1.0.0/Makefile.am 2006-08-18 20:01:28.000000000 -0400 create mode 100644 include/X11/extensions/Printstr.h
@@ -25,7 +25,12 @@ create mode 100644 printproto.pc.in
diff --git a/Makefile.am b/Makefile.am
index 90655d5..2525cc1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,10 +23,15 @@ AM_CFLAGS = $(XPRINT_CFLAGS)
SUBDIRS = src man SUBDIRS = src man
@ -26,39 +32,37 @@
-pkgconfig_DATA = xp.pc -pkgconfig_DATA = xp.pc
+pkgconfig_DATA = xp.pc printproto.pc +pkgconfig_DATA = xp.pc printproto.pc
-EXTRA_DIST = xp.pc.in autogen.sh -EXTRA_DIST = xp.pc.in ChangeLog
+EXTRA_DIST = xp.pc.in printproto.pc.in autogen.sh +EXTRA_DIST = xp.pc.in printproto.pc.in ChangeLog
--- libXp-1.0.0/configure.ac.add-proto-files 2005-12-14 19:24:30.000000000 -0500 MAINTAINERCLEANFILES = ChangeLog
+++ libXp-1.0.0/configure.ac 2006-08-18 20:01:28.000000000 -0400
@@ -36,7 +36,7 @@ .PHONY: ChangeLog
diff --git a/configure.ac b/configure.ac
index c721461..b1e00b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,7 @@ XORG_DEFAULT_OPTIONS
AC_PROG_LIBTOOL AC_PROG_LIBTOOL
# Check for X and print proto # Check for X and print proto
-PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau printproto) -PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau printproto)
+PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau) +PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau)
AC_SUBST(XPRINT_CFLAGS) # Check for _XEatDataWords function that may be patched into older Xlib release
AC_SUBST(XPRINT_LIBS) SAVE_LIBS="$LIBS"
@@ -48,5 +48,6 @@ @@ -54,6 +54,7 @@ LIBS="$SAVE_LIBS"
AC_OUTPUT([Makefile AC_CONFIG_FILES([Makefile
src/Makefile src/Makefile
man/Makefile man/Makefile
+ printproto.pc + printproto.pc
xp.pc]) xp.pc])
AC_OUTPUT
--- libXp-1.0.0/src/Makefile.am.add-proto-files 2005-12-02 23:41:50.000000000 -0500 diff --git a/include/X11/extensions/Print.h b/include/X11/extensions/Print.h
+++ libXp-1.0.0/src/Makefile.am 2006-08-18 20:01:28.000000000 -0400 new file mode 100644
@@ -24,7 +24,7 @@ index 0000000..4c1b387
--- /dev/null
AM_CFLAGS = $(XPRINT_CFLAGS) $(MALLOC_ZERO_CFLAGS) +++ b/include/X11/extensions/Print.h
-INCLUDES = -I$(top_srcdir)/include/X11/extensions
+INCLUDES = -I$(top_srcdir)/include/
#
# Library version number. This must match old versions on
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
+++ libXp-1.0.0/include/X11/extensions/Print.h 2006-08-18 20:01:28.000000000 -0400
@@ -0,0 +1,552 @@ @@ -0,0 +1,552 @@
+/* $Xorg: Print.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */ +/* $Xorg: Print.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */
+/****************************************************************************** +/******************************************************************************
@ -612,8 +616,11 @@
+_XFUNCPROTOEND +_XFUNCPROTOEND
+ +
+#endif /* _XpPrint_H_ */ +#endif /* _XpPrint_H_ */
--- /dev/null 2006-08-16 13:34:07.659756891 -0400 diff --git a/include/X11/extensions/Printstr.h b/include/X11/extensions/Printstr.h
+++ libXp-1.0.0/include/X11/extensions/Printstr.h 2006-08-18 20:01:28.000000000 -0400 new file mode 100644
index 0000000..8fc9958
--- /dev/null
+++ b/include/X11/extensions/Printstr.h
@@ -0,0 +1,783 @@ @@ -0,0 +1,783 @@
+/* $Xorg: Printstr.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */ +/* $Xorg: Printstr.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */
+/****************************************************************************** +/******************************************************************************
@ -1317,7 +1324,7 @@
+ WindowPtr /* pWin */); + WindowPtr /* pWin */);
+ int (*PutDocumentData)( + int (*PutDocumentData)(
+ struct _XpContext * /* pContext */, + struct _XpContext * /* pContext */,
+ DrawablePtr /* pDraw */, + DrawablePtr /* pDraw */,
+ char * /* pData */, + char * /* pData */,
+ int /* len_data */, + int /* len_data */,
+ char * /* pDoc_fmt */, + char * /* pDoc_fmt */,
@ -1398,3 +1405,35 @@
+_XFUNCPROTOEND +_XFUNCPROTOEND
+ +
+#endif /* _XpPrintstr_H_ */ +#endif /* _XpPrintstr_H_ */
diff --git a/printproto.pc.in b/printproto.pc.in
new file mode 100644
index 0000000..bbc6ec8
--- /dev/null
+++ b/printproto.pc.in
@@ -0,0 +1,10 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: PrintProto
+Description: Print extension headers
+Version: @PACKAGE_VERSION@
+Requires: xau
+Cflags: -I${includedir}
diff --git a/src/Makefile.am b/src/Makefile.am
index f42b633..56121da 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,7 +24,7 @@ libXp_la_LIBADD = $(XPRINT_LIBS)
AM_CFLAGS = $(CWARNFLAGS) $(XPRINT_CFLAGS) $(MALLOC_ZERO_CFLAGS)
-AM_CPPFLAGS = -I$(top_srcdir)/include/X11/extensions
+AM_CPPFLAGS = -I$(top_srcdir)/include/
#
# Library version number. This must match old versions on
--
1.8.2.1

View File

@ -11,8 +11,8 @@
Summary: X.Org X11 libXp runtime library Summary: X.Org X11 libXp runtime library
Name: libXp Name: libXp
Version: 1.0.0 Version: 1.0.2
Release: 19%{?dist} Release: 1%{?dist}
License: MIT License: MIT
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://www.x.org URL: http://www.x.org
@ -87,7 +87,7 @@ rm -rf $RPM_BUILD_ROOT
%files %files
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc AUTHORS COPYING INSTALL ChangeLog %doc AUTHORS COPYING ChangeLog
%{_libdir}/libXp.so.6 %{_libdir}/libXp.so.6
%{_libdir}/libXp.so.6.2.0 %{_libdir}/libXp.so.6.2.0
@ -107,6 +107,10 @@ rm -rf $RPM_BUILD_ROOT
%endif %endif
%changelog %changelog
* Mon Jul 01 2013 Peter Hutterer <peter.hutterer@redhat.com> 1.0.2-1
- libXp 1.0.2. Drags in a bunch of general cleanup, code changes are quite
limited and CVE-2013-2062 (#960362)
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-19 * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

View File

@ -1 +1 @@
0f4ac39108c1ae8c443cdfac259b58fa libXp-1.0.0.tar.bz2 bb038577c7f4e42a1b675fa6451bc4aa libXp-1.0.2.tar.bz2