libXp 1.0.2. Drags in a bunch of general cleanup, code changes are quite
limited and CVE-2013-2062 (#960362)
This commit is contained in:
parent
ded3564102
commit
2712080ab8
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
libXp-1.0.0.tar.bz2
|
||||
printproto-1.0.3.tar.bz2
|
||||
/libXp-1.0.2.tar.bz2
|
||||
|
@ -1,19 +1,25 @@
|
||||
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
|
||||
+++ libXp-1.0.0/printproto.pc.in 2006-08-18 20:01:28.000000000 -0400
|
||||
@@ -0,0 +1,10 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+Name: PrintProto
|
||||
+Description: Print extension headers
|
||||
+Version: @PACKAGE_VERSION@
|
||||
+Requires: xau
|
||||
+Cflags: -I${includedir}
|
||||
--- libXp-1.0.0/Makefile.am.add-proto-files 2005-05-18 16:33:36.000000000 -0400
|
||||
+++ libXp-1.0.0/Makefile.am 2006-08-18 20:01:28.000000000 -0400
|
||||
@@ -25,7 +25,12 @@
|
||||
From bbf6d3783ba9f5cd1489dd6bb042915c685b41b0 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
Date: Mon, 1 Jul 2013 15:04:04 +1000
|
||||
Subject: [PATCH] Patch printproto into libXp
|
||||
|
||||
---
|
||||
Makefile.am | 9 +-
|
||||
configure.ac | 3 +-
|
||||
include/X11/extensions/Print.h | 552 +++++++++++++++++++++++++++
|
||||
include/X11/extensions/Printstr.h | 783 ++++++++++++++++++++++++++++++++++++++
|
||||
printproto.pc.in | 10 +
|
||||
src/Makefile.am | 2 +-
|
||||
6 files changed, 1355 insertions(+), 4 deletions(-)
|
||||
create mode 100644 include/X11/extensions/Print.h
|
||||
create mode 100644 include/X11/extensions/Printstr.h
|
||||
create mode 100644 printproto.pc.in
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 90655d5..2525cc1 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -23,10 +23,15 @@ AM_CFLAGS = $(XPRINT_CFLAGS)
|
||||
|
||||
SUBDIRS = src man
|
||||
|
||||
@ -26,39 +32,37 @@
|
||||
-pkgconfig_DATA = xp.pc
|
||||
+pkgconfig_DATA = xp.pc printproto.pc
|
||||
|
||||
-EXTRA_DIST = xp.pc.in autogen.sh
|
||||
+EXTRA_DIST = xp.pc.in printproto.pc.in autogen.sh
|
||||
--- libXp-1.0.0/configure.ac.add-proto-files 2005-12-14 19:24:30.000000000 -0500
|
||||
+++ libXp-1.0.0/configure.ac 2006-08-18 20:01:28.000000000 -0400
|
||||
@@ -36,7 +36,7 @@
|
||||
-EXTRA_DIST = xp.pc.in ChangeLog
|
||||
+EXTRA_DIST = xp.pc.in printproto.pc.in ChangeLog
|
||||
MAINTAINERCLEANFILES = ChangeLog
|
||||
|
||||
.PHONY: ChangeLog
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index c721461..b1e00b1 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -43,7 +43,7 @@ XORG_DEFAULT_OPTIONS
|
||||
AC_PROG_LIBTOOL
|
||||
|
||||
# Check for X and print proto
|
||||
-PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau printproto)
|
||||
+PKG_CHECK_MODULES(XPRINT, x11 xext xextproto xau)
|
||||
|
||||
AC_SUBST(XPRINT_CFLAGS)
|
||||
AC_SUBST(XPRINT_LIBS)
|
||||
@@ -48,5 +48,6 @@
|
||||
AC_OUTPUT([Makefile
|
||||
src/Makefile
|
||||
man/Makefile
|
||||
# Check for _XEatDataWords function that may be patched into older Xlib release
|
||||
SAVE_LIBS="$LIBS"
|
||||
@@ -54,6 +54,7 @@ LIBS="$SAVE_LIBS"
|
||||
AC_CONFIG_FILES([Makefile
|
||||
src/Makefile
|
||||
man/Makefile
|
||||
+ printproto.pc
|
||||
xp.pc])
|
||||
xp.pc])
|
||||
AC_OUTPUT
|
||||
|
||||
--- libXp-1.0.0/src/Makefile.am.add-proto-files 2005-12-02 23:41:50.000000000 -0500
|
||||
+++ libXp-1.0.0/src/Makefile.am 2006-08-18 20:01:28.000000000 -0400
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
AM_CFLAGS = $(XPRINT_CFLAGS) $(MALLOC_ZERO_CFLAGS)
|
||||
|
||||
-INCLUDES = -I$(top_srcdir)/include/X11/extensions
|
||||
+INCLUDES = -I$(top_srcdir)/include/
|
||||
|
||||
#
|
||||
# Library version number. This must match old versions on
|
||||
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
|
||||
+++ libXp-1.0.0/include/X11/extensions/Print.h 2006-08-18 20:01:28.000000000 -0400
|
||||
diff --git a/include/X11/extensions/Print.h b/include/X11/extensions/Print.h
|
||||
new file mode 100644
|
||||
index 0000000..4c1b387
|
||||
--- /dev/null
|
||||
+++ b/include/X11/extensions/Print.h
|
||||
@@ -0,0 +1,552 @@
|
||||
+/* $Xorg: Print.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */
|
||||
+/******************************************************************************
|
||||
@ -75,7 +79,7 @@
|
||||
+ ** o Revision and Name defines
|
||||
+ ** o Common defines and constants (e.g. Keywords, Masks)
|
||||
+ ** o Extension version structure
|
||||
+ **
|
||||
+ **
|
||||
+ ** Library and client subportion has:
|
||||
+ ** o Convience Marcos
|
||||
+ ** o Client side data structures
|
||||
@ -94,7 +98,7 @@
|
||||
+ ** (c) Copyright 1996 Digital Equipment Corp.
|
||||
+ ** (c) Copyright 1996 Fujitsu Limited
|
||||
+ ** (c) Copyright 1996 Hitachi, Ltd.
|
||||
+ **
|
||||
+ **
|
||||
+ ** Permission is hereby granted, free of charge, to any person obtaining a copy
|
||||
+ ** of this software and associated documentation files (the "Software"), to deal
|
||||
+ ** in the Software without restriction, including without limitation the rights
|
||||
@ -612,8 +616,11 @@
|
||||
+_XFUNCPROTOEND
|
||||
+
|
||||
+#endif /* _XpPrint_H_ */
|
||||
--- /dev/null 2006-08-16 13:34:07.659756891 -0400
|
||||
+++ libXp-1.0.0/include/X11/extensions/Printstr.h 2006-08-18 20:01:28.000000000 -0400
|
||||
diff --git a/include/X11/extensions/Printstr.h b/include/X11/extensions/Printstr.h
|
||||
new file mode 100644
|
||||
index 0000000..8fc9958
|
||||
--- /dev/null
|
||||
+++ b/include/X11/extensions/Printstr.h
|
||||
@@ -0,0 +1,783 @@
|
||||
+/* $Xorg: Printstr.h,v 1.3 2000/08/18 04:05:44 coskrey Exp $ */
|
||||
+/******************************************************************************
|
||||
@ -635,7 +642,7 @@
|
||||
+ ** (c) Copyright 1996 Digital Equipment Corp.
|
||||
+ ** (c) Copyright 1996 Fujitsu Limited
|
||||
+ ** (c) Copyright 1996 Hitachi, Ltd.
|
||||
+ **
|
||||
+ **
|
||||
+ ** Permission is hereby granted, free of charge, to any person obtaining a copy
|
||||
+ ** of this software and associated documentation files (the "Software"), to deal
|
||||
+ ** in the Software without restriction, including without limitation the rights
|
||||
@ -875,7 +882,7 @@
|
||||
+ STRING8 locale * locale *
|
||||
+ BYTE pad(locale) * unused *
|
||||
+ ************************************************************/
|
||||
+} xPrintCreateContextReq;
|
||||
+} xPrintCreateContextReq;
|
||||
+#define sz_xPrintCreateContextReq 16
|
||||
+
|
||||
+
|
||||
@ -884,7 +891,7 @@
|
||||
+ CARD8 printReqType; /* always X_PrintSetContext */
|
||||
+ CARD16 length B16;
|
||||
+ PCONTEXT printContext B32; /* print context */
|
||||
+} xPrintSetContextReq;
|
||||
+} xPrintSetContextReq;
|
||||
+#define sz_xPrintSetContextReq 8
|
||||
+
|
||||
+
|
||||
@ -892,7 +899,7 @@
|
||||
+ CARD8 reqType; /* always PrintReqCode */
|
||||
+ CARD8 printReqType; /* always X_PrintGetContext */
|
||||
+ CARD16 length B16;
|
||||
+} xPrintGetContextReq;
|
||||
+} xPrintGetContextReq;
|
||||
+#define sz_xPrintGetContextReq 4
|
||||
+
|
||||
+typedef struct {
|
||||
@ -915,7 +922,7 @@
|
||||
+ CARD8 printReqType; /* always X_PrintDestroyContext */
|
||||
+ CARD16 length B16;
|
||||
+ PCONTEXT printContext B32; /* print context */
|
||||
+} xPrintDestroyContextReq;
|
||||
+} xPrintDestroyContextReq;
|
||||
+#define sz_xPrintDestroyContextReq 8
|
||||
+
|
||||
+
|
||||
@ -924,7 +931,7 @@
|
||||
+ CARD8 printReqType; /* always X_PrintGetContextScreen */
|
||||
+ CARD16 length B16;
|
||||
+ PCONTEXT printContext B32; /* print context */
|
||||
+} xPrintGetContextScreenReq;
|
||||
+} xPrintGetContextScreenReq;
|
||||
+#define sz_xPrintGetContextScreenReq 8
|
||||
+
|
||||
+typedef struct {
|
||||
@ -949,7 +956,7 @@
|
||||
+ CARD8 saveData; /* save data boolean */
|
||||
+ CARD8 pad1;
|
||||
+ CARD16 pad2 B16;
|
||||
+} xPrintStartJobReq;
|
||||
+} xPrintStartJobReq;
|
||||
+#define sz_xPrintStartJobReq 8
|
||||
+
|
||||
+typedef struct _PrintEndJob {
|
||||
@ -970,7 +977,7 @@
|
||||
+ CARD8 type; /* type for document */
|
||||
+ CARD8 pad1;
|
||||
+ CARD16 pad2 B16;
|
||||
+} xPrintStartDocReq;
|
||||
+} xPrintStartDocReq;
|
||||
+#define sz_xPrintStartDocReq 8
|
||||
+
|
||||
+typedef struct _PrintEndDoc {
|
||||
@ -1011,7 +1018,7 @@
|
||||
+ CARD16 length B16;
|
||||
+ PCONTEXT printContext B32; /* print context */
|
||||
+ CARD32 maxBufferSize B32; /* maximum buffer size requested */
|
||||
+} xPrintGetDocumentDataReq;
|
||||
+} xPrintGetDocumentDataReq;
|
||||
+#define sz_xPrintGetDocumentDataReq 12
|
||||
+
|
||||
+typedef struct {
|
||||
@ -1039,7 +1046,7 @@
|
||||
+ CARD8 printReqType; /* always X_PrintStartPage */
|
||||
+ CARD16 length B16;
|
||||
+ WINDOW window B32; /* window */
|
||||
+} xPrintStartPageReq;
|
||||
+} xPrintStartPageReq;
|
||||
+#define sz_xPrintStartPageReq 8
|
||||
+
|
||||
+typedef struct _PrintEndPage {
|
||||
@ -1176,7 +1183,7 @@
|
||||
+ CARD8 printReqType; /* always X_PrintGetPageDimensions */
|
||||
+ CARD16 length B16;
|
||||
+ PCONTEXT printContext B32; /* print context */
|
||||
+} xPrintGetPageDimensionsReq;
|
||||
+} xPrintGetPageDimensionsReq;
|
||||
+#define sz_xPrintGetPageDimensionsReq 8
|
||||
+
|
||||
+typedef struct {
|
||||
@ -1201,7 +1208,7 @@
|
||||
+ CARD8 reqType; /* always PrintReqCode */
|
||||
+ CARD8 printReqType; /* always X_PrintQueryScreens */
|
||||
+ CARD16 length B16;
|
||||
+} xPrintQueryScreensReq;
|
||||
+} xPrintQueryScreensReq;
|
||||
+#define sz_xPrintQueryScreensReq 4
|
||||
+
|
||||
+typedef struct {
|
||||
@ -1286,7 +1293,7 @@
|
||||
+ * Server-only definitions shared between the extension and DDX layers.
|
||||
+ *
|
||||
+ */
|
||||
+
|
||||
+
|
||||
+/*
|
||||
+ * Internal return code used to indicate that the requesting
|
||||
+ * client has been suspended.
|
||||
@ -1317,7 +1324,7 @@
|
||||
+ WindowPtr /* pWin */);
|
||||
+ int (*PutDocumentData)(
|
||||
+ struct _XpContext * /* pContext */,
|
||||
+ DrawablePtr /* pDraw */,
|
||||
+ DrawablePtr /* pDraw */,
|
||||
+ char * /* pData */,
|
||||
+ int /* len_data */,
|
||||
+ char * /* pDoc_fmt */,
|
||||
@ -1398,3 +1405,35 @@
|
||||
+_XFUNCPROTOEND
|
||||
+
|
||||
+#endif /* _XpPrintstr_H_ */
|
||||
diff --git a/printproto.pc.in b/printproto.pc.in
|
||||
new file mode 100644
|
||||
index 0000000..bbc6ec8
|
||||
--- /dev/null
|
||||
+++ b/printproto.pc.in
|
||||
@@ -0,0 +1,10 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+Name: PrintProto
|
||||
+Description: Print extension headers
|
||||
+Version: @PACKAGE_VERSION@
|
||||
+Requires: xau
|
||||
+Cflags: -I${includedir}
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index f42b633..56121da 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -24,7 +24,7 @@ libXp_la_LIBADD = $(XPRINT_LIBS)
|
||||
|
||||
AM_CFLAGS = $(CWARNFLAGS) $(XPRINT_CFLAGS) $(MALLOC_ZERO_CFLAGS)
|
||||
|
||||
-AM_CPPFLAGS = -I$(top_srcdir)/include/X11/extensions
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/include/
|
||||
|
||||
#
|
||||
# Library version number. This must match old versions on
|
||||
--
|
||||
1.8.2.1
|
||||
|
||||
|
10
libXp.spec
10
libXp.spec
@ -11,8 +11,8 @@
|
||||
|
||||
Summary: X.Org X11 libXp runtime library
|
||||
Name: libXp
|
||||
Version: 1.0.0
|
||||
Release: 19%{?dist}
|
||||
Version: 1.0.2
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.x.org
|
||||
@ -87,7 +87,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS COPYING INSTALL ChangeLog
|
||||
%doc AUTHORS COPYING ChangeLog
|
||||
%{_libdir}/libXp.so.6
|
||||
%{_libdir}/libXp.so.6.2.0
|
||||
|
||||
@ -107,6 +107,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jul 01 2013 Peter Hutterer <peter.hutterer@redhat.com> 1.0.2-1
|
||||
- libXp 1.0.2. Drags in a bunch of general cleanup, code changes are quite
|
||||
limited and CVE-2013-2062 (#960362)
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user