libXmu 1.1.3
This commit is contained in:
parent
a893e2c24b
commit
b2a47398b0
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ libXmu-1.0.5.tar.bz2
|
|||||||
/libXmu-1.1.0.tar.bz2
|
/libXmu-1.1.0.tar.bz2
|
||||||
/libXmu-1.1.1.tar.bz2
|
/libXmu-1.1.1.tar.bz2
|
||||||
/libXmu-1.1.2.tar.bz2
|
/libXmu-1.1.2.tar.bz2
|
||||||
|
/libXmu-1.1.3.tar.bz2
|
||||||
|
@ -1,182 +0,0 @@
|
|||||||
From bc78541e9a9a95bbd5413d62bfc114ddc9265c36 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alan Coopersmith <alan.coopersmith@oracle.com>
|
|
||||||
Date: Sat, 5 May 2018 11:26:17 -0700
|
|
||||||
Subject: [PATCH 1/2] Convert tabs to spaces in StrToWidg.c
|
|
||||||
|
|
||||||
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
|
|
||||||
---
|
|
||||||
src/StrToWidg.c | 106 ++++++++++++++++++++++++------------------------
|
|
||||||
1 file changed, 53 insertions(+), 53 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/StrToWidg.c b/src/StrToWidg.c
|
|
||||||
index c22b827..6aace95 100644
|
|
||||||
--- a/src/StrToWidg.c
|
|
||||||
+++ b/src/StrToWidg.c
|
|
||||||
@@ -53,7 +53,7 @@ in this Software without prior written authorization from The Open Group.
|
|
||||||
/*ARGSUSED*/
|
|
||||||
void
|
|
||||||
XmuCvtStringToWidget(XrmValuePtr args, Cardinal *num_args,
|
|
||||||
- XrmValuePtr fromVal, XrmValuePtr toVal)
|
|
||||||
+ XrmValuePtr fromVal, XrmValuePtr toVal)
|
|
||||||
{
|
|
||||||
static Widget widget, *widgetP, parent;
|
|
||||||
XrmName name = XrmStringToName(fromVal->addr);
|
|
||||||
@@ -61,55 +61,55 @@ XmuCvtStringToWidget(XrmValuePtr args, Cardinal *num_args,
|
|
||||||
|
|
||||||
if (*num_args != 1)
|
|
||||||
{
|
|
||||||
- i = 0;
|
|
||||||
- XtErrorMsg("wrongParameters", "cvtStringToWidget", "xtToolkitError",
|
|
||||||
- "StringToWidget conversion needs parent arg", NULL, &i);
|
|
||||||
+ i = 0;
|
|
||||||
+ XtErrorMsg("wrongParameters", "cvtStringToWidget", "xtToolkitError",
|
|
||||||
+ "StringToWidget conversion needs parent arg", NULL, &i);
|
|
||||||
}
|
|
||||||
|
|
||||||
parent = *(Widget*)args[0].addr;
|
|
||||||
/* try to match names of normal children */
|
|
||||||
if (XtIsComposite(parent))
|
|
||||||
{
|
|
||||||
- i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
- for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
- i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.xrm_name == name)
|
|
||||||
- {
|
|
||||||
- widget = *widgetP;
|
|
||||||
- done(&widget, Widget);
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
+ i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
+ for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
+ i; i--, widgetP++)
|
|
||||||
+ if ((*widgetP)->core.xrm_name == name)
|
|
||||||
+ {
|
|
||||||
+ widget = *widgetP;
|
|
||||||
+ done(&widget, Widget);
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* try to match names of popup children */
|
|
||||||
i = parent->core.num_popups;
|
|
||||||
for (widgetP = parent->core.popup_list; i; i--, widgetP++)
|
|
||||||
if ((*widgetP)->core.xrm_name == name)
|
|
||||||
{
|
|
||||||
- widget = *widgetP;
|
|
||||||
- done(&widget, Widget);
|
|
||||||
- }
|
|
||||||
+ widget = *widgetP;
|
|
||||||
+ done(&widget, Widget);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* try to match classes of normal children */
|
|
||||||
if (XtIsComposite(parent))
|
|
||||||
{
|
|
||||||
- i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
- for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
- i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.widget_class->core_class.xrm_class == name)
|
|
||||||
- {
|
|
||||||
- widget = *widgetP;
|
|
||||||
- done(&widget, Widget);
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
+ i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
+ for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
+ i; i--, widgetP++)
|
|
||||||
+ if ((*widgetP)->core.widget_class->core_class.xrm_class == name)
|
|
||||||
+ {
|
|
||||||
+ widget = *widgetP;
|
|
||||||
+ done(&widget, Widget);
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* try to match classes of popup children */
|
|
||||||
i = parent->core.num_popups;
|
|
||||||
for (widgetP = parent->core.popup_list; i; i--, widgetP++)
|
|
||||||
if ((*widgetP)->core.widget_class->core_class.xrm_class == name)
|
|
||||||
{
|
|
||||||
- widget = *widgetP;
|
|
||||||
- done(&widget, Widget);
|
|
||||||
- }
|
|
||||||
+ widget = *widgetP;
|
|
||||||
+ done(&widget, Widget);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
XtStringConversionWarning(fromVal->addr, XtRWidget);
|
|
||||||
toVal->addr = NULL;
|
|
||||||
@@ -118,47 +118,47 @@ XmuCvtStringToWidget(XrmValuePtr args, Cardinal *num_args,
|
|
||||||
|
|
||||||
#undef done
|
|
||||||
|
|
||||||
-#define newDone(type, value) \
|
|
||||||
- { \
|
|
||||||
- if (toVal->addr != NULL) { \
|
|
||||||
- if (toVal->size < sizeof(type)) { \
|
|
||||||
- toVal->size = sizeof(type); \
|
|
||||||
- return False; \
|
|
||||||
- } \
|
|
||||||
- *(type*)(toVal->addr) = (value); \
|
|
||||||
- } \
|
|
||||||
- else { \
|
|
||||||
- static type static_val; \
|
|
||||||
- static_val = (value); \
|
|
||||||
- toVal->addr = (XtPointer)&static_val; \
|
|
||||||
- } \
|
|
||||||
- toVal->size = sizeof(type); \
|
|
||||||
- return True; \
|
|
||||||
- }
|
|
||||||
+#define newDone(type, value) \
|
|
||||||
+ { \
|
|
||||||
+ if (toVal->addr != NULL) { \
|
|
||||||
+ if (toVal->size < sizeof(type)) { \
|
|
||||||
+ toVal->size = sizeof(type); \
|
|
||||||
+ return False; \
|
|
||||||
+ } \
|
|
||||||
+ *(type*)(toVal->addr) = (value); \
|
|
||||||
+ } \
|
|
||||||
+ else { \
|
|
||||||
+ static type static_val; \
|
|
||||||
+ static_val = (value); \
|
|
||||||
+ toVal->addr = (XtPointer)&static_val; \
|
|
||||||
+ } \
|
|
||||||
+ toVal->size = sizeof(type); \
|
|
||||||
+ return True; \
|
|
||||||
+ }
|
|
||||||
|
|
||||||
|
|
||||||
/*ARGSUSED*/
|
|
||||||
Boolean
|
|
||||||
XmuNewCvtStringToWidget(Display *dpy, XrmValue *args, Cardinal *num_args,
|
|
||||||
- XrmValue *fromVal, XrmValue *toVal,
|
|
||||||
- XtPointer *converter_data)
|
|
||||||
+ XrmValue *fromVal, XrmValue *toVal,
|
|
||||||
+ XtPointer *converter_data)
|
|
||||||
{
|
|
||||||
Widget *widgetP, parent;
|
|
||||||
XrmName name = XrmStringToName(fromVal->addr);
|
|
||||||
int i;
|
|
||||||
|
|
||||||
if (*num_args != 1)
|
|
||||||
- XtAppWarningMsg(XtDisplayToApplicationContext(dpy),
|
|
||||||
- "wrongParameters","cvtStringToWidget","xtToolkitError",
|
|
||||||
- "String To Widget conversion needs parent argument",
|
|
||||||
- (String *)NULL, (Cardinal *)NULL);
|
|
||||||
+ XtAppWarningMsg(XtDisplayToApplicationContext(dpy),
|
|
||||||
+ "wrongParameters","cvtStringToWidget","xtToolkitError",
|
|
||||||
+ "String To Widget conversion needs parent argument",
|
|
||||||
+ (String *)NULL, (Cardinal *)NULL);
|
|
||||||
|
|
||||||
parent = *(Widget*)args[0].addr;
|
|
||||||
/* try to match names of normal children */
|
|
||||||
if (XtIsComposite(parent))
|
|
||||||
{
|
|
||||||
- i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
- for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
+ i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
+ for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
i; i--, widgetP++)
|
|
||||||
if ((*widgetP)->core.xrm_name == name)
|
|
||||||
newDone(Widget, *widgetP);
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
@ -1,33 +0,0 @@
|
|||||||
From 22d9c590901e121936f50dee97dc60c4f7defb63 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alan Coopersmith <alan.coopersmith@oracle.com>
|
|
||||||
Date: Mon, 2 Dec 2013 13:00:05 -0800
|
|
||||||
Subject: [PATCH] ShapeEllipseOrRoundedRectangle: Check height AND width, not
|
|
||||||
width twice
|
|
||||||
|
|
||||||
Fixed to match check in ShapeOval()
|
|
||||||
https://bugs.freedesktop.org/show_bug.cgi?id=72245
|
|
||||||
|
|
||||||
Fixes cppcheck warning:
|
|
||||||
[ShapeWidg.c:204]: (style) Same expression on both sides of '||'.
|
|
||||||
|
|
||||||
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
|
|
||||||
---
|
|
||||||
src/ShapeWidg.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/ShapeWidg.c b/src/ShapeWidg.c
|
|
||||||
index 32388ee..3ca7116 100644
|
|
||||||
--- a/src/ShapeWidg.c
|
|
||||||
+++ b/src/ShapeWidg.c
|
|
||||||
@@ -201,7 +201,7 @@ ShapeEllipseOrRoundedRectangle(Widget w, Bool ellipse, int ew, int eh)
|
|
||||||
GC gc;
|
|
||||||
unsigned long mask;
|
|
||||||
|
|
||||||
- if (width < 3 || width < 3)
|
|
||||||
+ if (width < 3 || height < 3)
|
|
||||||
return;
|
|
||||||
width += w->core.border_width << 1;
|
|
||||||
height += w->core.border_width << 1;
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
@ -1,241 +0,0 @@
|
|||||||
From 5bd4eb821bd9e88c3a131de9a8b781f5184e22b1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alan Coopersmith <alan.coopersmith@oracle.com>
|
|
||||||
Date: Sat, 5 May 2018 11:32:12 -0700
|
|
||||||
Subject: [PATCH 2/2] Apply standard X.Org formatting & bracketing to
|
|
||||||
StrToWidg.c
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Makes code easier for humans to read and gets rid of gcc warning:
|
|
||||||
|
|
||||||
StrToWidg.c: In function ‘XmuCvtStringToWidget’:
|
|
||||||
StrToWidg.c:107:3: warning: this ‘for’ clause does not guard... [-Wmisleading-indentation]
|
|
||||||
for (widgetP = parent->core.popup_list; i; i--, widgetP++)
|
|
||||||
^~~
|
|
||||||
StrToWidg.c:114:5: note: ...this statement, but the latter is misleadingly indented as if it were guarded by the ‘for’
|
|
||||||
XtStringConversionWarning(fromVal->addr, XtRWidget);
|
|
||||||
^~~~~~~~~~~~~~~~~~~~~~~~~
|
|
||||||
|
|
||||||
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
|
|
||||||
---
|
|
||||||
src/StrToWidg.c | 150 ++++++++++++++++++++++++------------------------
|
|
||||||
1 file changed, 74 insertions(+), 76 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/StrToWidg.c b/src/StrToWidg.c
|
|
||||||
index 6aace95..b6288d4 100644
|
|
||||||
--- a/src/StrToWidg.c
|
|
||||||
+++ b/src/StrToWidg.c
|
|
||||||
@@ -59,57 +59,54 @@ XmuCvtStringToWidget(XrmValuePtr args, Cardinal *num_args,
|
|
||||||
XrmName name = XrmStringToName(fromVal->addr);
|
|
||||||
Cardinal i;
|
|
||||||
|
|
||||||
- if (*num_args != 1)
|
|
||||||
- {
|
|
||||||
+ if (*num_args != 1) {
|
|
||||||
i = 0;
|
|
||||||
XtErrorMsg("wrongParameters", "cvtStringToWidget", "xtToolkitError",
|
|
||||||
"StringToWidget conversion needs parent arg", NULL, &i);
|
|
||||||
}
|
|
||||||
|
|
||||||
- parent = *(Widget*)args[0].addr;
|
|
||||||
+ parent = *(Widget *) args[0].addr;
|
|
||||||
/* try to match names of normal children */
|
|
||||||
- if (XtIsComposite(parent))
|
|
||||||
- {
|
|
||||||
- i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
- for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
- i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.xrm_name == name)
|
|
||||||
- {
|
|
||||||
+ if (XtIsComposite(parent)) {
|
|
||||||
+ i = ((CompositeWidget) parent)->composite.num_children;
|
|
||||||
+ for (widgetP = ((CompositeWidget) parent)->composite.children;
|
|
||||||
+ i; i--, widgetP++) {
|
|
||||||
+ if ((*widgetP)->core.xrm_name == name) {
|
|
||||||
widget = *widgetP;
|
|
||||||
done(&widget, Widget);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* try to match names of popup children */
|
|
||||||
i = parent->core.num_popups;
|
|
||||||
- for (widgetP = parent->core.popup_list; i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.xrm_name == name)
|
|
||||||
- {
|
|
||||||
+ for (widgetP = parent->core.popup_list; i; i--, widgetP++) {
|
|
||||||
+ if ((*widgetP)->core.xrm_name == name) {
|
|
||||||
widget = *widgetP;
|
|
||||||
done(&widget, Widget);
|
|
||||||
}
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* try to match classes of normal children */
|
|
||||||
- if (XtIsComposite(parent))
|
|
||||||
- {
|
|
||||||
- i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
- for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
- i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.widget_class->core_class.xrm_class == name)
|
|
||||||
- {
|
|
||||||
+ if (XtIsComposite(parent)) {
|
|
||||||
+ i = ((CompositeWidget) parent)->composite.num_children;
|
|
||||||
+ for (widgetP = ((CompositeWidget) parent)->composite.children;
|
|
||||||
+ i; i--, widgetP++) {
|
|
||||||
+ if ((*widgetP)->core.widget_class->core_class.xrm_class == name) {
|
|
||||||
widget = *widgetP;
|
|
||||||
done(&widget, Widget);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* try to match classes of popup children */
|
|
||||||
i = parent->core.num_popups;
|
|
||||||
- for (widgetP = parent->core.popup_list; i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.widget_class->core_class.xrm_class == name)
|
|
||||||
- {
|
|
||||||
+ for (widgetP = parent->core.popup_list; i; i--, widgetP++) {
|
|
||||||
+ if ((*widgetP)->core.widget_class->core_class.xrm_class == name) {
|
|
||||||
widget = *widgetP;
|
|
||||||
done(&widget, Widget);
|
|
||||||
}
|
|
||||||
+ }
|
|
||||||
|
|
||||||
XtStringConversionWarning(fromVal->addr, XtRWidget);
|
|
||||||
toVal->addr = NULL;
|
|
||||||
@@ -149,77 +146,78 @@ XmuNewCvtStringToWidget(Display *dpy, XrmValue *args, Cardinal *num_args,
|
|
||||||
|
|
||||||
if (*num_args != 1)
|
|
||||||
XtAppWarningMsg(XtDisplayToApplicationContext(dpy),
|
|
||||||
- "wrongParameters","cvtStringToWidget","xtToolkitError",
|
|
||||||
+ "wrongParameters", "cvtStringToWidget",
|
|
||||||
+ "xtToolkitError",
|
|
||||||
"String To Widget conversion needs parent argument",
|
|
||||||
- (String *)NULL, (Cardinal *)NULL);
|
|
||||||
+ (String *) NULL, (Cardinal *) NULL);
|
|
||||||
|
|
||||||
- parent = *(Widget*)args[0].addr;
|
|
||||||
+ parent = *(Widget *) args[0].addr;
|
|
||||||
/* try to match names of normal children */
|
|
||||||
- if (XtIsComposite(parent))
|
|
||||||
- {
|
|
||||||
- i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
- for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
- i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.xrm_name == name)
|
|
||||||
- newDone(Widget, *widgetP);
|
|
||||||
- }
|
|
||||||
+ if (XtIsComposite(parent)) {
|
|
||||||
+ i = ((CompositeWidget) parent)->composite.num_children;
|
|
||||||
+ for (widgetP = ((CompositeWidget) parent)->composite.children;
|
|
||||||
+ i; i--, widgetP++) {
|
|
||||||
+ if ((*widgetP)->core.xrm_name == name)
|
|
||||||
+ newDone(Widget, *widgetP);
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* try to match names of popup children */
|
|
||||||
i = parent->core.num_popups;
|
|
||||||
- for (widgetP = parent->core.popup_list; i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.xrm_name == name)
|
|
||||||
- newDone(Widget, *widgetP);
|
|
||||||
+ for (widgetP = parent->core.popup_list; i; i--, widgetP++) {
|
|
||||||
+ if ((*widgetP)->core.xrm_name == name)
|
|
||||||
+ newDone(Widget, *widgetP);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* try to match classes of normal children */
|
|
||||||
- if (XtIsComposite(parent))
|
|
||||||
- {
|
|
||||||
- i = ((CompositeWidget)parent)->composite.num_children;
|
|
||||||
- for (widgetP = ((CompositeWidget)parent)->composite.children;
|
|
||||||
- i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.widget_class->core_class.xrm_class == name)
|
|
||||||
- newDone(Widget, *widgetP);
|
|
||||||
- }
|
|
||||||
+ if (XtIsComposite(parent)) {
|
|
||||||
+ i = ((CompositeWidget) parent)->composite.num_children;
|
|
||||||
+ for (widgetP = ((CompositeWidget) parent)->composite.children;
|
|
||||||
+ i; i--, widgetP++) {
|
|
||||||
+ if ((*widgetP)->core.widget_class->core_class.xrm_class == name)
|
|
||||||
+ newDone(Widget, *widgetP);
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* try to match classes of popup children */
|
|
||||||
i = parent->core.num_popups;
|
|
||||||
- for (widgetP = parent->core.popup_list; i; i--, widgetP++)
|
|
||||||
- if ((*widgetP)->core.widget_class->core_class.xrm_class == name)
|
|
||||||
- newDone(Widget, *widgetP);
|
|
||||||
+ for (widgetP = parent->core.popup_list; i; i--, widgetP++) {
|
|
||||||
+ if ((*widgetP)->core.widget_class->core_class.xrm_class == name)
|
|
||||||
+ newDone(Widget, *widgetP);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
- XtDisplayStringConversionWarning(dpy, (String)fromVal->addr, XtRWidget);
|
|
||||||
- return (False);
|
|
||||||
+ XtDisplayStringConversionWarning(dpy, (String) fromVal->addr, XtRWidget);
|
|
||||||
+ return (False);
|
|
||||||
}
|
|
||||||
|
|
||||||
/*ARGSUSED*/
|
|
||||||
Boolean
|
|
||||||
XmuCvtWidgetToString(Display *dpy, XrmValuePtr args, Cardinal *num_args,
|
|
||||||
- XrmValuePtr fromVal, XrmValuePtr toVal,
|
|
||||||
- XtPointer *data)
|
|
||||||
+ XrmValuePtr fromVal, XrmValuePtr toVal, XtPointer *data)
|
|
||||||
{
|
|
||||||
- static String buffer;
|
|
||||||
- Cardinal size;
|
|
||||||
- Widget widget;
|
|
||||||
-
|
|
||||||
- widget = *(Widget *)fromVal->addr;
|
|
||||||
-
|
|
||||||
- if (widget)
|
|
||||||
- buffer = XrmQuarkToString(widget->core.xrm_name);
|
|
||||||
- else
|
|
||||||
- buffer = "(null)";
|
|
||||||
-
|
|
||||||
- size = strlen(buffer) + 1;
|
|
||||||
- if (toVal->addr != NULL)
|
|
||||||
- {
|
|
||||||
- if (toVal->size < size)
|
|
||||||
- {
|
|
||||||
- toVal->size = size;
|
|
||||||
- return (False);
|
|
||||||
- }
|
|
||||||
- strcpy((char *)toVal->addr, buffer);
|
|
||||||
+ static String buffer;
|
|
||||||
+ Cardinal size;
|
|
||||||
+ Widget widget;
|
|
||||||
+
|
|
||||||
+ widget = *(Widget *) fromVal->addr;
|
|
||||||
+
|
|
||||||
+ if (widget)
|
|
||||||
+ buffer = XrmQuarkToString(widget->core.xrm_name);
|
|
||||||
+ else
|
|
||||||
+ buffer = "(null)";
|
|
||||||
+
|
|
||||||
+ size = strlen(buffer) + 1;
|
|
||||||
+ if (toVal->addr != NULL) {
|
|
||||||
+ if (toVal->size < size) {
|
|
||||||
+ toVal->size = size;
|
|
||||||
+ return (False);
|
|
||||||
+ }
|
|
||||||
+ strcpy((char *) toVal->addr, buffer);
|
|
||||||
+ }
|
|
||||||
+ else {
|
|
||||||
+ toVal->addr = (XPointer) buffer;
|
|
||||||
}
|
|
||||||
- else
|
|
||||||
- toVal->addr = (XPointer)buffer;
|
|
||||||
- toVal->size = sizeof(String);
|
|
||||||
+ toVal->size = sizeof(String);
|
|
||||||
|
|
||||||
- return (True);
|
|
||||||
+ return (True);
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
14
libXmu.spec
14
libXmu.spec
@ -2,17 +2,13 @@
|
|||||||
|
|
||||||
Summary: X.Org X11 libXmu/libXmuu runtime libraries
|
Summary: X.Org X11 libXmu/libXmuu runtime libraries
|
||||||
Name: libXmu
|
Name: libXmu
|
||||||
Version: 1.1.2
|
Version: 1.1.3
|
||||||
Release: 13%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.x.org
|
URL: http://www.x.org
|
||||||
|
|
||||||
Source0: https://www.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
|
Source0: https://www.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
|
||||||
|
|
||||||
Patch1: 0001-ShapeEllipseOrRoundedRectangle-Check-height-AND-widt.patch
|
|
||||||
Patch2: 0001-Convert-tabs-to-spaces-in-StrToWidg.c.patch
|
|
||||||
Patch3: 0002-Apply-standard-X.Org-formatting-bracketing-to-StrToW.patch
|
|
||||||
|
|
||||||
BuildRequires: autoconf automake libtool
|
BuildRequires: autoconf automake libtool
|
||||||
BuildRequires: xorg-x11-util-macros
|
BuildRequires: xorg-x11-util-macros
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
@ -32,9 +28,6 @@ X.Org X11 libXmu development package
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .width_height_fix
|
|
||||||
%patch2 -p1 -b .formatting1
|
|
||||||
%patch3 -p1 -b .formatting2
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -v --install --force
|
autoreconf -v --install --force
|
||||||
@ -93,6 +86,9 @@ rm -rf $RPM_BUILD_ROOT%{_docdir}
|
|||||||
%{_libdir}/pkgconfig/xmuu.pc
|
%{_libdir}/pkgconfig/xmuu.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 20 2019 Adam Jackson <ajax@redhat.com> - 1.1.3-1
|
||||||
|
- libXmu 1.1.3
|
||||||
|
|
||||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-13
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-13
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libXmu-1.1.2.tar.bz2) = eba4e3d10f7d75ba8464881fb69f295a89774a4b37793197d75f3312e3a342b2df8b7e13e3f5c887962704329b5347ff2f3395e229af9dadf46a93b1e8613cfc
|
SHA512 (libXmu-1.1.3.tar.bz2) = 8c6cc65b22aa031ad870dd92736681a068a0878a425a53dbed909943da1136c4a24034d467cfd3785c3a8d78f66850b69f1ebe1eb24aaf9bc176b1d171a5c762
|
||||||
|
Loading…
Reference in New Issue
Block a user