libX11 1.3.5
This commit is contained in:
parent
926552e6e9
commit
4d071e5f5a
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
libX11-1.3.4.tar.bz2
|
libX11-1.3.4.tar.bz2
|
||||||
|
libX11-1.3.5.tar.bz2
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 54a963608d23d35cd9233b2223f880ac3671f10b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jamey Sharp <jamey@minilop.net>
|
|
||||||
Date: Fri, 06 Aug 2010 22:51:56 +0000
|
|
||||||
Subject: Fix use-after-free in _XReply on X errors.
|
|
||||||
|
|
||||||
_XReply would always call dequeue_pending_request on errors. When it
|
|
||||||
got an error for the current request, it would call dequeue, then break
|
|
||||||
out of the loop; then, if it had an error in the event queue, it would
|
|
||||||
compare it with the sequence number of the now-freed pending request.
|
|
||||||
_XReply already stored that sequence number in dpy->last_request_read
|
|
||||||
before freeing it, so look at that instead.
|
|
||||||
|
|
||||||
Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=29412
|
|
||||||
|
|
||||||
Signed-off-by: Jamey Sharp <jamey@minilop.net>
|
|
||||||
Signed-off-by: Josh Triplett <josh@joshtriplett.org>
|
|
||||||
(cherry picked from commit 4b8ff7db39f2fe7ef12968d462aaf3f9054b6c18)
|
|
||||||
---
|
|
||||||
diff --git a/src/xcb_io.c b/src/xcb_io.c
|
|
||||||
index dac7622..72881d8 100644
|
|
||||||
--- a/src/xcb_io.c
|
|
||||||
+++ b/src/xcb_io.c
|
|
||||||
@@ -579,7 +579,7 @@ Status _XReply(Display *dpy, xReply *rep, int extra, Bool discard)
|
|
||||||
xcb_generic_event_t *event = dpy->xcb->next_event;
|
|
||||||
unsigned long event_sequence = dpy->last_request_read;
|
|
||||||
widen(&event_sequence, event->full_sequence);
|
|
||||||
- if(event_sequence == current->sequence)
|
|
||||||
+ if(event_sequence == dpy->last_request_read)
|
|
||||||
{
|
|
||||||
error = (xcb_generic_error_t *) event;
|
|
||||||
dpy->xcb->next_event = NULL;
|
|
||||||
--
|
|
||||||
cgit v0.8.3-6-g21f6
|
|
10
libX11.spec
10
libX11.spec
@ -3,8 +3,8 @@
|
|||||||
|
|
||||||
Summary: Core X11 protocol client library
|
Summary: Core X11 protocol client library
|
||||||
Name: libX11
|
Name: libX11
|
||||||
Version: 1.3.4
|
Version: 1.3.5
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.x.org
|
URL: http://www.x.org
|
||||||
@ -16,7 +16,6 @@ Source0: http://xorg.freedesktop.org/archive/individual/lib/%{name}-%{version}.t
|
|||||||
#Source1: make-git-snapshot.sh
|
#Source1: make-git-snapshot.sh
|
||||||
|
|
||||||
Patch2: dont-forward-keycode-0.patch
|
Patch2: dont-forward-keycode-0.patch
|
||||||
Patch3: 54a963608d23d35cd9233b2223f880ac3671f10b.patch
|
|
||||||
BuildRequires: xorg-x11-util-macros
|
BuildRequires: xorg-x11-util-macros
|
||||||
BuildRequires: pkgconfig(xproto) >= 7.0.15
|
BuildRequires: pkgconfig(xproto) >= 7.0.15
|
||||||
BuildRequires: xorg-x11-xtrans-devel >= 1.0.3-4
|
BuildRequires: xorg-x11-xtrans-devel >= 1.0.3-4
|
||||||
@ -48,7 +47,6 @@ X.Org X11 libX11 development package
|
|||||||
%setup -q
|
%setup -q
|
||||||
#setup -q -n %{tarball}-%{gitdate}
|
#setup -q -n %{tarball}-%{gitdate}
|
||||||
%patch2 -p1 -b .dont-forward-keycode-0
|
%patch2 -p1 -b .dont-forward-keycode-0
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# sodding libtool
|
# sodding libtool
|
||||||
@ -115,6 +113,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man5/*.5*
|
%{_mandir}/man5/*.5*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 12 2010 Peter Hutterer <peter.hutterer@redhat.com> 1.3.5-1
|
||||||
|
- libX11 1.3.5
|
||||||
|
- Drop 54a96360 patch, upstream.
|
||||||
|
|
||||||
* Tue Aug 10 2010 Bill Nottingham <notting@redhat.com> - 1.3.4-3
|
* Tue Aug 10 2010 Bill Nottingham <notting@redhat.com> - 1.3.4-3
|
||||||
- Merge upstream commit 54a96360, fixes use-after-free (fd.o 29412)
|
- Merge upstream commit 54a96360, fixes use-after-free (fd.o 29412)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user