updated to 1.0.6
- updated source URL - dropped obsolete patch hunks and rebased patches
This commit is contained in:
parent
3c4da48585
commit
f81210a0d9
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
libEMF-1.0.4.tar.gz
|
||||
/libEMF-1.0.6.tar.gz
|
||||
|
@ -1,47 +1,7 @@
|
||||
--- libEMF-1.0.3/libemf/libemf.h.amd64 2004-11-11 23:33:43.000000000 +0100
|
||||
+++ libEMF-1.0.3/libemf/libemf.h 2006-11-19 00:54:37.000000000 +0100
|
||||
@@ -306,6 +306,7 @@
|
||||
fread( &word, sizeof(INT16), 1, fp_ );
|
||||
return *this;
|
||||
}
|
||||
+#if !(defined(_LP64) || defined(__alpha__))
|
||||
/*!
|
||||
* Output a double word (long) to the stream (swabbed).
|
||||
* \param word word (long) to output.
|
||||
@@ -374,6 +375,7 @@
|
||||
fread( &long_, sizeof(LONG), 1, fp_ );
|
||||
return *this;
|
||||
}
|
||||
+#endif
|
||||
/*!
|
||||
* Output a (long) int to the stream (swabbed).
|
||||
* \param int_ (long) int to output.
|
||||
--- libEMF-1.0.3/include/libEMF/wine/winbase.h.amd64 2004-07-29 08:20:38.000000000 +0200
|
||||
+++ libEMF-1.0.3/include/libEMF/wine/winbase.h 2006-11-19 00:55:17.000000000 +0100
|
||||
@@ -1802,6 +1802,7 @@
|
||||
VOID WINAPI SetLastError(DWORD);
|
||||
#endif /* __i386__ && __GNUC__ */
|
||||
|
||||
+#if 0
|
||||
/* FIXME: should handle platforms where sizeof(void*) != sizeof(long) */
|
||||
static inline PVOID WINAPI InterlockedCompareExchangePointer( PVOID *dest, PVOID xchg, PVOID compare )
|
||||
{
|
||||
@@ -1812,6 +1813,7 @@
|
||||
{
|
||||
return (PVOID)InterlockedExchange( (PLONG)dest, (LONG)val );
|
||||
}
|
||||
+#endif
|
||||
|
||||
#ifdef __WINE__
|
||||
#define GetCurrentProcess() ((HANDLE)0xffffffff)
|
||||
--- libEMF-1.0.3/include/libEMF/wine/winnt.h.amd64 2005-08-07 17:50:12.000000000 +0200
|
||||
+++ libEMF-1.0.3/include/libEMF/wine/winnt.h 2006-11-19 00:54:37.000000000 +0100
|
||||
@@ -29,10 +29,14 @@
|
||||
|
||||
/* Architecture dependent settings. */
|
||||
/* These are hardcoded to avoid dependencies on config.h in Winelib apps. */
|
||||
-#if defined(__i386__)
|
||||
+#if defined(__i386__) || defined(__x86_64__)
|
||||
diff -up libEMF-1.0.6/include/libEMF/wine/winnt.h.amd64 libEMF-1.0.6/include/libEMF/wine/winnt.h
|
||||
--- libEMF-1.0.6/include/libEMF/wine/winnt.h.amd64 2012-05-24 17:52:51.000000000 +0200
|
||||
+++ libEMF-1.0.6/include/libEMF/wine/winnt.h 2012-09-03 22:49:49.000000000 +0200
|
||||
@@ -37,6 +37,10 @@
|
||||
# undef WORDS_BIGENDIAN
|
||||
# undef BITFIELDS_BIGENDIAN
|
||||
# define ALLOW_UNALIGNED_ACCESS
|
||||
@ -52,41 +12,21 @@
|
||||
#elif defined(__sparc__)
|
||||
# define WORDS_BIGENDIAN
|
||||
# define BITFIELDS_BIGENDIAN
|
||||
@@ -222,8 +226,13 @@
|
||||
typedef unsigned short WORD, *PWORD, *LPWORD;
|
||||
@@ -238,7 +242,7 @@ typedef unsigned short WORD, *PWO
|
||||
typedef int INT, *PINT, *LPINT;
|
||||
typedef unsigned int UINT, *PUINT, *LPUINT;
|
||||
+#if defined(_LP64) || defined(__alpha__)
|
||||
+typedef unsigned int DWORD, *PDWORD, *LPDWORD;
|
||||
+typedef unsigned int ULONG, *PULONG, *LPULONG;
|
||||
+#else
|
||||
typedef unsigned long DWORD, *PDWORD, *LPDWORD;
|
||||
typedef unsigned long ULONG, *PULONG, *LPULONG;
|
||||
+#endif
|
||||
typedef float FLOAT, *PFLOAT, *LPFLOAT;
|
||||
typedef double DOUBLE, *PDOUBLE, *LPDOUBLE;
|
||||
typedef double DATE;
|
||||
@@ -263,7 +272,11 @@
|
||||
/* Not sure this is correct. Probably should depend on the compiler, too. */
|
||||
-#if defined( __x86_64__)
|
||||
+#if defined( __x86_64__) || defined(__alpha__)
|
||||
typedef unsigned int DWORD, *PDWORD, *LPDWORD;
|
||||
typedef unsigned int ULONG, *PULONG, *LPULONG;
|
||||
#else
|
||||
@@ -284,7 +288,7 @@ typedef VOID *PVOID, *LPV
|
||||
typedef BYTE BOOLEAN, *PBOOLEAN;
|
||||
typedef char CHAR, *PCHAR;
|
||||
typedef short SHORT, *PSHORT;
|
||||
+#if defined(_LP64) || defined(__alpha__)
|
||||
+typedef int LONG, *PLONG, *LPLONG;
|
||||
+#else
|
||||
-#if defined(__x86_64__)
|
||||
+#if defined(__x86_64__) || defined(__alpha__)
|
||||
typedef int LONG, *PLONG, *LPLONG;
|
||||
#else
|
||||
typedef long LONG, *PLONG, *LPLONG;
|
||||
+#endif
|
||||
|
||||
/* Some systems might have wchar_t, but we really need 16 bit characters */
|
||||
#ifndef WINE_WCHAR_DEFINED
|
||||
@@ -652,6 +665,11 @@
|
||||
|
||||
#endif /* __i386__ */
|
||||
|
||||
+#ifdef __x86_64__
|
||||
+#define CONTEXT_FULL 1
|
||||
+typedef struct _CONTEXT CONTEXT;
|
||||
+#endif
|
||||
+
|
||||
/* Alpha context definitions */
|
||||
#ifdef _ALPHA_
|
||||
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff -up libEMF-1.0.3/include/libEMF/wine/winnt.h.axp libEMF-1.0.3/include/libEMF/wine/winnt.h
|
||||
--- libEMF-1.0.3/include/libEMF/wine/winnt.h.axp 2007-12-03 22:35:49.000000000 +0100
|
||||
+++ libEMF-1.0.3/include/libEMF/wine/winnt.h 2007-12-03 22:37:10.000000000 +0100
|
||||
@@ -671,7 +671,7 @@ typedef struct _CONTEXT CONTEXT;
|
||||
#endif
|
||||
diff -up libEMF-1.0.6/include/libEMF/wine/winnt.h.axp libEMF-1.0.6/include/libEMF/wine/winnt.h
|
||||
--- libEMF-1.0.6/include/libEMF/wine/winnt.h.axp 2012-09-03 22:50:29.000000000 +0200
|
||||
+++ libEMF-1.0.6/include/libEMF/wine/winnt.h 2012-09-03 22:52:12.000000000 +0200
|
||||
@@ -901,7 +901,7 @@ PVOID WINAPI RtlVirtualUnwin
|
||||
#endif /* __x86_64__ */
|
||||
|
||||
/* Alpha context definitions */
|
||||
-#ifdef _ALPHA_
|
||||
|
11
libEMF.spec
11
libEMF.spec
@ -1,13 +1,13 @@
|
||||
Summary: A library for generating Enhanced Metafiles
|
||||
Summary(pl): Biblioteka do generowania plików w formacie Enhanced Metafile
|
||||
Name: libEMF
|
||||
Version: 1.0.4
|
||||
Release: 5%{?dist}
|
||||
Version: 1.0.6
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+ and GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://libemf.sourceforge.net/
|
||||
|
||||
Source0: http://downloads.sourceforge.net/pstoedit/%{name}-%{version}.tar.gz
|
||||
Source0: http://downloads.sourceforge.net/project/libemf/libemf/%{version}/libEMF-%{version}.tar.gz
|
||||
# Source0-md5: a4e91fd8077ce5f540f569e20e8ef7ff
|
||||
Patch0: %{name}-amd64.patch
|
||||
Patch1: %{name}-axp.patch
|
||||
@ -90,6 +90,11 @@ make check
|
||||
%{_includedir}/libEMF
|
||||
|
||||
%changelog
|
||||
* Mon Sep 03 2012 Dominik 'Rathann' Mierzejewski <rpm@greysector.net> 1.0.6-1
|
||||
- updated to 1.0.6
|
||||
- updated source URL
|
||||
- dropped obsolete patch hunks and rebased patches
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user