- update to newest version
- remove patches fixed in upstream: progress_overflow, empty_argument
This commit is contained in:
parent
e9145bf501
commit
f4494087d4
@ -1 +1,2 @@
|
|||||||
lftp-3.6.1.tar.gz
|
lftp-3.6.1.tar.gz
|
||||||
|
lftp-3.6.3.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up lftp-3.5.14/src/FileCopy.cc.test lftp-3.5.14/src/FileCopy.cc
|
|
||||||
--- lftp-3.5.14/src/FileCopy.cc.test 2007-12-11 09:48:03.000000000 +0100
|
|
||||||
+++ lftp-3.5.14/src/FileCopy.cc 2007-12-11 09:48:36.000000000 +0100
|
|
||||||
@@ -514,6 +514,6 @@ const char *FileCopy::GetPercentDoneStr(
|
|
||||||
return "";
|
|
||||||
- static char buf[6];
|
|
||||||
+ static char buf[8];
|
|
||||||
- sprintf(buf,"(%d%%) ",pct);
|
|
||||||
+ snprintf(buf,8,"(%d%%) ",pct);
|
|
||||||
return buf;
|
|
||||||
}
|
|
||||||
float FileCopy::GetRate()
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up lftp-3.6.1/src/HttpDir.cc.empty_argument lftp-3.6.1/src/HttpDir.cc
|
|
||||||
--- lftp-3.6.1/src/HttpDir.cc.empty_argument 2007-08-29 13:20:13.000000000 +0200
|
|
||||||
+++ lftp-3.6.1/src/HttpDir.cc 2008-01-25 14:00:43.000000000 +0100
|
|
||||||
@@ -70,6 +70,8 @@ static bool find_value(const char *scan,
|
|
||||||
if(*scan=='"' || *scan=='\'')
|
|
||||||
quote=*scan++;
|
|
||||||
|
|
||||||
+ if(match)
|
|
||||||
+ store.set("");
|
|
||||||
while(scan<more && (quote ? *scan!=quote : !is_ascii_space(*scan)))
|
|
||||||
{
|
|
||||||
if(match)
|
|
13
lftp.spec
13
lftp.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A sophisticated file transfer program
|
Summary: A sophisticated file transfer program
|
||||||
Name: lftp
|
Name: lftp
|
||||||
Version: 3.6.1
|
Version: 3.6.3
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source0: ftp://ftp.yar.ru/lftp/lftp-%{version}.tar.gz
|
Source0: ftp://ftp.yar.ru/lftp/lftp-%{version}.tar.gz
|
||||||
@ -9,9 +9,6 @@ URL: http://lftp.yar.ru/
|
|||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: ncurses-devel, openssl-devel, pkgconfig, readline-devel, gettext
|
BuildRequires: ncurses-devel, openssl-devel, pkgconfig, readline-devel, gettext
|
||||||
|
|
||||||
Patch1: lftp-3.5.14-progress_overflow.patch
|
|
||||||
Patch2: lftp-3.6.1-empty_argument.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
LFTP is a sophisticated ftp/http file transfer program. Like bash, it has job
|
LFTP is a sophisticated ftp/http file transfer program. Like bash, it has job
|
||||||
control and uses the readline library for input. It has bookmarks, built-in
|
control and uses the readline library for input. It has bookmarks, built-in
|
||||||
@ -20,8 +17,6 @@ reliability in mind.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .progress_overflow
|
|
||||||
%patch2 -p1 -b .empty_argument
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
if pkg-config openssl ; then
|
if pkg-config openssl ; then
|
||||||
@ -86,6 +81,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%config /etc/ld.so.conf.d/*
|
%config /etc/ld.so.conf.d/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 25 2008 Martin Nagy <mnagy@redhat.com> - 3.6.3-1
|
||||||
|
- update to newest version
|
||||||
|
- remove patches fixed in upstream: progress_overflow, empty_argument
|
||||||
|
|
||||||
* Tue Feb 12 2008 Martin Nagy <mnagy@redhat.com> - 3.6.1-2
|
* Tue Feb 12 2008 Martin Nagy <mnagy@redhat.com> - 3.6.1-2
|
||||||
- fix library paths (#432468)
|
- fix library paths (#432468)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user