updated to latest upstream 4.5.0
This commit is contained in:
parent
b11dd19533
commit
3cdfbc090d
1
.gitignore
vendored
1
.gitignore
vendored
@ -29,3 +29,4 @@ lftp-4.0.10.tar.xz
|
||||
/lftp-4.4.14.tar.xz
|
||||
/lftp-4.4.15.tar.xz
|
||||
/lftp-4.4.16.tar.xz
|
||||
/lftp-4.5.0.tar.xz
|
||||
|
@ -1,411 +0,0 @@
|
||||
diff -up lftp-4.4.10/doc/lftp.1.man lftp-4.4.10/doc/lftp.1
|
||||
--- lftp-4.4.10/doc/lftp.1.man 2013-10-08 07:08:56.000000000 +0200
|
||||
+++ lftp-4.4.10/doc/lftp.1 2013-10-12 15:35:37.468984511 +0200
|
||||
@@ -1,5 +1,5 @@
|
||||
.\"
|
||||
-.\" lftp.1 - Sophisticated ftp program
|
||||
+.\" lftp.1 - Sophisticated file transfer program
|
||||
.\"
|
||||
.\" This file is part of lftp.
|
||||
.\"
|
||||
@@ -61,19 +61,19 @@ lftp \- Sophisticated file transfer prog
|
||||
This man page documents lftp version 4.4.14.
|
||||
|
||||
.SH "DESCRIPTION"
|
||||
-\fBlftp\fR is a file transfer program that allows sophisticated ftp, http
|
||||
+\fBlftp\fR is a file transfer program that allows sophisticated FTP, HTTP
|
||||
and other connections to other hosts. If \fIsite\fR is specified then lftp
|
||||
will connect to that site otherwise a connection has to be established with
|
||||
the open command.
|
||||
.PP
|
||||
-\fBlftp\fP can handle several file access methods - ftp, ftps, http, https,
|
||||
-hftp, fish, sftp and file (https and ftps are only available when lftp is
|
||||
+\fBlftp\fP can handle several file access methods - FTP, FTPS, HTTP, HTTPS,
|
||||
+HFTP, FISH, SFTP and file (HTTPS and FTPS are only available when lftp is
|
||||
compiled with GNU TLS or OpenSSL library). You can specify the method to use in `open
|
||||
-URL' command, e.g. `open http://www.us.kernel.org/pub/linux'. hftp is
|
||||
-ftp-over-http-proxy protocol. It can be used automatically instead of ftp
|
||||
+URL' command, e.g. `open http://www.us.kernel.org/pub/linux'. HFTP is
|
||||
+ftp-over-http-proxy protocol. It can be used automatically instead of FTP
|
||||
if ftp:proxy is set to `http://proxy[:port]'. Fish is a protocol working
|
||||
over an ssh connection to a unix account. SFtp is a protocol implemented
|
||||
-in ssh2 as sftp subsystem.
|
||||
+in SSH2 as SFTP subsystem.
|
||||
.PP
|
||||
Besides FTP-like protocols, lftp has support for BitTorrent protocol
|
||||
as `torrent' command. Seeding is also supported.
|
||||
@@ -81,8 +81,8 @@ as `torrent' command. Seeding is also su
|
||||
.PP
|
||||
Every operation in \fBlftp\fP is reliable, that is any non-fatal error is
|
||||
handled properly and the operation is repeated. So if downloading breaks, it
|
||||
-will be restarted from the point automatically. Even if ftp server
|
||||
-does not support REST command, \fBlftp\fP will try to retrieve the file from
|
||||
+will be restarted from the point automatically. Even if FTP server
|
||||
+does not support the REST command, \fBlftp\fP will try to retrieve the file from
|
||||
the very beginning until the file is transferred completely.
|
||||
|
||||
\fBlftp\fP has shell-like command syntax allowing you to launch several
|
||||
@@ -95,8 +95,8 @@ commands allow redirecting their output
|
||||
pipe to external command. Commands can be executed conditionally based
|
||||
on termination status of previous command (&&, ||).
|
||||
.PP
|
||||
-If you exit \fBlftp\fP when some jobs are not finished yet, \fBlftp\fP will move
|
||||
-itself to nohup mode in background. The same happens when you have a
|
||||
+If you exit \fBlftp\fP before all jobs are not finished yet, \fBlftp\fP will move
|
||||
+itself to nohup mode in background. The same thing happens with a
|
||||
real modem hangup or when you close an xterm.
|
||||
.PP
|
||||
\fBlftp\fP has built-in mirror which can download or update a whole directory
|
||||
@@ -119,7 +119,7 @@ all variables and their values or `set \
|
||||
Variable names can be abbreviated and prefix can be omitted unless the
|
||||
rest becomes ambiguous.
|
||||
.PP
|
||||
-If lftp was compiled with OpenSSL (configure \-\-with\-openssl), then it includes software developed
|
||||
+If lftp was compiled with OpenSSL (configure \-\-with\-openssl) it includes software developed
|
||||
by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/)
|
||||
|
||||
.SS Commands
|
||||
@@ -235,11 +235,11 @@ the debug output to a file.
|
||||
|
||||
.BR echo " [" \-n "] \fIstring\fR"
|
||||
.PP
|
||||
-guess what it does.
|
||||
+Prints (echos) the given string to the display.
|
||||
|
||||
.BR eval " [" -f " \fIformat\fR ] " \fIargs...\fR
|
||||
.PP
|
||||
-without -f it just executes given arguments as a command. With -f, arguments
|
||||
+without -f it executes given arguments as a command. With -f, arguments
|
||||
are transformed into a new command. The format can contain plain text and
|
||||
placeholders $0...$9 and $@, corresponding to the arguments.
|
||||
|
||||
@@ -278,7 +278,7 @@ put ftp://...
|
||||
mput ftp://.../*
|
||||
mget \-O ftp://... ftp://.../*
|
||||
.De
|
||||
-or other combinations to get FXP transfer (directly between two ftp servers).
|
||||
+or other combinations to get FXP transfer (directly between two FTP servers).
|
||||
lftp would fallback to plain copy (via client) if FXP transfer cannot be
|
||||
initiated or ftp:use-fxp is false.
|
||||
|
||||
@@ -576,7 +576,7 @@ not match to excludes after the include,
|
||||
and the first check is exclude. Directories are matched with a slash appended.
|
||||
.PP
|
||||
Note that symbolic links are not created when uploading to remote server,
|
||||
-because ftp protocol cannot do it. To upload files the links refer
|
||||
+because FTP protocol cannot do it. To upload files the links refer
|
||||
to, use `mirror \-RL' command (treat symbolic links as files).
|
||||
.PP
|
||||
For options \-\-newer\-than and \-\-older\-than you can either specify a
|
||||
@@ -597,9 +597,9 @@ Verbosity level can be selected using \-
|
||||
only newer files even if size is different. By default older files are transferred and replace newer ones.
|
||||
.PP
|
||||
You can mirror between two servers if you specify URLs instead of directories.
|
||||
-FXP is used automatically for transfers between ftp servers, if possible.
|
||||
+FXP is automatically used for transfers between FTP servers, if possible.
|
||||
.PP
|
||||
-Some ftp servers hide dot-files by default (e.g. \fI.htaccess\fP), and show
|
||||
+Some FTP servers hide dot-files by default (e.g. \fI.htaccess\fP), and show
|
||||
them only when LIST command is used with \-a option. In such case try to use
|
||||
`set ftp:list-options \-a'.
|
||||
|
||||
@@ -665,7 +665,7 @@ List remote file names
|
||||
.BR "[" \-u " \fIuser\fP[", "\fIpass\fP]]"
|
||||
.BR "[" \-p " \fIport\fP] \fIhost\fP|\fIurl\fP"
|
||||
.PP
|
||||
-Select an ftp server.
|
||||
+Select a FTP server.
|
||||
|
||||
.B pget
|
||||
.RI [ OPTS ]
|
||||
@@ -980,7 +980,7 @@ Print \fBlftp\fR version.
|
||||
Wait for specified job to terminate. If jobno is omitted, wait for last
|
||||
backgrounded job.
|
||||
.PP
|
||||
-`wait all' waits for all jobs termination.
|
||||
+`wait all' waits for all jobs to terminate.
|
||||
|
||||
.B zcat
|
||||
\fIfiles\fP
|
||||
@@ -1298,23 +1298,23 @@ Send this string in ACCT command after l
|
||||
The closure for this setting has format \fIuser@host\fP.
|
||||
.TP
|
||||
.BR ftp:anon-pass \ (string)
|
||||
-sets the password used for anonymous ftp access authentication.
|
||||
+sets the password used for anonymous FTP access authentication.
|
||||
Default is "lftp@".
|
||||
.TP
|
||||
.BR ftp:anon-user \ (string)
|
||||
-sets the user name used for anonymous ftp access authentication.
|
||||
+sets the user name used for anonymous FTP access authentication.
|
||||
Default is "anonymous".
|
||||
.TP
|
||||
.BR ftp:auto-sync-mode \ (regex)
|
||||
if first server message matches this regex, turn on sync mode for that host.
|
||||
.TP
|
||||
.BR ftp:charset \ (string)
|
||||
-the character set used by ftp server in requests, replies and file listings.
|
||||
+the character set used by FTP server in requests, replies and file listings.
|
||||
Default is empty which means the same as local. This setting is only used
|
||||
when the server does not support UTF8.
|
||||
.TP
|
||||
.BR ftp:client \ (string)
|
||||
-the name of ftp client to send with CLNT command, if supported by server.
|
||||
+the name of FTP client to send with CLNT command, if supported by server.
|
||||
If it is empty, then no CLNT command will be sent.
|
||||
.TP
|
||||
.BR ftp:bind-data-socket \ (boolean)
|
||||
@@ -1329,14 +1329,14 @@ instead of the one returned by PASV comm
|
||||
Default is true.
|
||||
.TP
|
||||
.BR ftp:fxp-passive-source \ (boolean)
|
||||
-if true, lftp will try to set up source ftp server in passive mode first,
|
||||
+if true, lftp will try to set up source FTP server in passive mode first,
|
||||
otherwise destination one. If first attempt fails, lftp tries to set them up
|
||||
the other way. If the other disposition fails too, lftp falls back to plain
|
||||
copy. See also ftp:use-fxp.
|
||||
.TP
|
||||
.BR ftp:home \ (string)
|
||||
Initial directory. Default is empty string which means auto. Set this to `/'
|
||||
-if you don't like the look of %2F in ftp URLs. The closure for this setting
|
||||
+if you don't like the look of %2F in FTP URLs. The closure for this setting
|
||||
has format \fIuser@host\fP.
|
||||
.TP
|
||||
.BR ftp:ignore-pasv-address \ (boolean)
|
||||
@@ -1355,11 +1355,11 @@ Default is empty.
|
||||
.TP
|
||||
.BR ftp:nop-interval \ (seconds)
|
||||
delay between NOOP commands when downloading tail of a file. This is useful
|
||||
-for ftp servers which send "Transfer complete" message before flushing
|
||||
+for FTP servers which send "Transfer complete" message before flushing
|
||||
data transfer. In such cases NOOP commands can prevent connection timeout.
|
||||
.TP
|
||||
.BR ftp:passive-mode \ (boolean)
|
||||
-sets passive ftp mode. This can be useful if you are behind a firewall or a
|
||||
+sets passive FTP mode. This can be useful if you are behind a firewall or a
|
||||
dumb masquerading router. In passive mode lftp uses PASV command, not the
|
||||
PORT command which is used in active mode. In passive mode lftp itself
|
||||
makes the data connection to the server; in active mode the server connects
|
||||
@@ -1377,13 +1377,13 @@ Format is min-max, or `full' or `any' to
|
||||
use EPSV as preferred passive mode. Default is `false'.
|
||||
.TP
|
||||
.BR ftp:proxy \ (URL)
|
||||
-specifies ftp proxy to use.
|
||||
-To disable proxy set this to empty string. Note that it is an ftp proxy which
|
||||
-uses ftp protocol, not ftp over http. Default value is taken from environment
|
||||
-variable \fBftp_proxy\fP if it starts with ``ftp://''. If your ftp proxy
|
||||
+specifies FTP proxy to use.
|
||||
+To disable proxy set this to empty string. Note that it is a FTP proxy which
|
||||
+uses FTP protocol, not FTP over HTTP. Default value is taken from environment
|
||||
+variable \fBftp_proxy\fP if it starts with ``ftp://''. If your FTP proxy
|
||||
requires authentication, specify user name and password in the URL.
|
||||
-If ftp:proxy starts with http:// then hftp protocol (ftp over http proxy) is used instead
|
||||
-of ftp automatically.
|
||||
+If ftp:proxy starts with http:// then hftp protocol (FTP over HTTP proxy) is used instead
|
||||
+of FTP automatically.
|
||||
.TP
|
||||
.BR ftp:proxy-auth-type \ (string)
|
||||
When set to ``joined'', lftp sends ``user@proxy_user@ftp.example.org'' as
|
||||
@@ -1406,7 +1406,7 @@ then proxy password. The site user and p
|
||||
.TP
|
||||
.BR ftp:rest-list \ (boolean)
|
||||
allow usage of REST command before LIST command. This might be useful for
|
||||
-large directories, but some ftp servers silently ignore REST before LIST.
|
||||
+large directories, but some FTP servers silently ignore REST before LIST.
|
||||
.TP
|
||||
.BR ftp:rest-stor \ (boolean)
|
||||
if false, lftp will not try to use REST before STOR. This can be useful
|
||||
@@ -1433,8 +1433,8 @@ do not send plain text password over the
|
||||
skey/opie is not available, assume failed login. Off by default.
|
||||
.TP
|
||||
.BR ftp:ssl-allow \ (boolean)
|
||||
-if true, try to negotiate SSL connection with ftp server for non-anonymous
|
||||
-access. Default is true. This and other ssl settings are only available if lftp was compiled
|
||||
+if true, try to negotiate SSL connection with FTP server for non-anonymous
|
||||
+access. Default is true. This and other SSL settings are only available if lftp was compiled
|
||||
with an ssl/tls library.
|
||||
.TP
|
||||
.BR ftp:ssl-auth \ (string)
|
||||
@@ -1451,17 +1451,17 @@ if true, refuse to send password in clea
|
||||
Default is false.
|
||||
.TP
|
||||
.BR ftp:ssl-protect-data \ (boolean)
|
||||
-if true, request ssl connection for data transfers. This is cpu-intensive
|
||||
+if true, request SSL connection for data transfers. This is cpu-intensive
|
||||
but provides privacy. Default is false.
|
||||
.TP
|
||||
.BR ftp:ssl-protect-fxp \ (boolean)
|
||||
-if true, request ssl connection for data transfer between two ftp servers
|
||||
-in FXP mode. CPSV or SSCN command will be used in that case. If ssl connection
|
||||
+if true, request SSL connection for data transfer between two FTP servers
|
||||
+in FXP mode. CPSV or SSCN command will be used in that case. If SSL connection
|
||||
fails for some reason, lftp would try unprotected FXP transfer unless
|
||||
ftp:ssl-force is set for any of the two servers. Default is false.
|
||||
.TP
|
||||
.BR ftp:ssl-protect-list \ (boolean)
|
||||
-if true, request ssl connection for file list transfers. Default is true.
|
||||
+if true, request SSL connection for file list transfers. Default is true.
|
||||
.TP
|
||||
.BR ftp:ssl-use-ccc \ (boolean)
|
||||
if true, lftp would issue CCC command after logon, thus disable
|
||||
@@ -1477,10 +1477,10 @@ relaxed.
|
||||
.TP
|
||||
.BR ftp:sync-mode \ (boolean)
|
||||
if true, lftp will send one command at a time and wait for
|
||||
-response. This might be useful if you are using a buggy ftp server or
|
||||
+response. This might be useful if you are using a buggy FTP server or
|
||||
router. When it is off, lftp sends a pack of commands and waits for
|
||||
responses - it speeds up operation when round trip time is significant.
|
||||
-Unfortunately it does not work with all ftp servers and some routers have
|
||||
+Unfortunately it does not work with all FTP servers and some routers have
|
||||
troubles with it, so it is on by default.
|
||||
.TP
|
||||
.BR ftp:timezone \ (string)
|
||||
@@ -1604,11 +1604,11 @@ allow server/proxy side caching for ftp-
|
||||
specify corresponding HTTP request header.
|
||||
.TP
|
||||
.BR hftp:proxy \ (URL)
|
||||
-specifies http proxy for ftp-over-http protocol (hftp). The protocol hftp
|
||||
-cannot work without a http proxy, obviously.
|
||||
+specifies HTTP proxy for FTP-over-HTTP protocol (hftp). The protocol hftp
|
||||
+cannot work without a HTTP proxy, obviously.
|
||||
Default value is taken from environment
|
||||
variable \fBftp_proxy\fP if it starts with ``http://'', otherwise from
|
||||
-environment variable \fBhttp_proxy\fP. If your ftp proxy
|
||||
+environment variable \fBhttp_proxy\fP. If your FTP proxy
|
||||
requires authentication, specify user name and password in the URL.
|
||||
.TP
|
||||
.BR hftp:use-allprop \ (boolean)
|
||||
@@ -1655,23 +1655,23 @@ send this cookie to server. A closure is
|
||||
set cookie/www.somehost.com "param=value"
|
||||
.TP
|
||||
.BR http:post-content-type " (string)"
|
||||
-specifies value of Content-Type http request header for POST method.
|
||||
+specifies value of Content-Type HTTP request header for POST method.
|
||||
Default is ``application/x-www-form-urlencoded''.
|
||||
.TP
|
||||
.BR http:proxy \ (URL)
|
||||
-specifies http proxy. It is used when lftp works over http protocol.
|
||||
+specifies HTTP proxy. It is used when lftp works over HTTP protocol.
|
||||
Default value is taken from environment variable \fBhttp_proxy\fP.
|
||||
If your proxy requires authentication, specify user name and password
|
||||
in the URL.
|
||||
.TP
|
||||
.BR http:put-method " (PUT or POST)"
|
||||
-specifies which http method to use on put.
|
||||
+specifies which HTTP method to use on put.
|
||||
.TP
|
||||
.BR http:put-content-type " (string)"
|
||||
-specifies value of Content-Type http request header for PUT method.
|
||||
+specifies value of Content-Type HTTP request header for PUT method.
|
||||
.TP
|
||||
.BR http:referer " (string)"
|
||||
-specifies value for Referer http request header. Single dot `.' expands
|
||||
+specifies value for Referer HTTP request header. Single dot `.' expands
|
||||
to current directory URL. Default is `.'. Set to empty string to disable
|
||||
Referer header.
|
||||
.TP
|
||||
@@ -1684,11 +1684,11 @@ otherwise it will send an empty request
|
||||
.TP
|
||||
.BR http:use-mkcol \ (boolean)
|
||||
if set to off, lftp will try to use `PUT' instead of `MKCOL' to create
|
||||
-directories with http protocol. Default is on.
|
||||
+directories with HTTP protocol. Default is on.
|
||||
.TP
|
||||
.BR http:use-propfind \ (boolean)
|
||||
if set to off, lftp will not try to use `PROPFIND' to get directory contents
|
||||
-with http protocol and use `GET' instead. Default is on.
|
||||
+with HTTP protocol and use `GET' instead. Default is on.
|
||||
.TP
|
||||
.BR http:user-agent " (string)"
|
||||
the string lftp sends in User-Agent header of HTTP request.
|
||||
@@ -1777,7 +1777,7 @@ contains comma separated list of domains
|
||||
Default is taken from environment variable \fBno_proxy\fP.
|
||||
.TP
|
||||
.BR net:persist-retries " (number)"
|
||||
-ignore this number of hard errors. Useful to login to buggy ftp servers which
|
||||
+ignore this number of hard errors. Useful to login to buggy FTP servers which
|
||||
reply 5xx when there is too many users.
|
||||
.TP
|
||||
.BR net:reconnect-interval-base \ (seconds)
|
||||
@@ -1787,12 +1787,12 @@ operation.
|
||||
.TP
|
||||
.BR net:reconnect-interval-max \ (seconds)
|
||||
sets maximum reconnect interval. When current interval after multiplication
|
||||
-by net:reconnect-interval-multiplier reachs this value (or exceeds it), it
|
||||
+by net:reconnect-interval-multiplier reaches this value (or exceeds it), it
|
||||
is reset back to net:reconnect-interval-base.
|
||||
.TP
|
||||
.BR net:reconnect-interval-multiplier \ (real\ number)
|
||||
sets multiplier by which base interval is multiplied each time new attempt
|
||||
-to perform an operation fails. When the interval reachs maximum, it is reset
|
||||
+to perform an operation fails. When the interval reaches maximum, it is reset
|
||||
to base value. See net:reconnect-interval-base and net:reconnect-interval-max.
|
||||
.TP
|
||||
.BR net:socket-bind-ipv4 " (ipv4 address)"
|
||||
@@ -1810,7 +1810,7 @@ default.
|
||||
.TP
|
||||
.BR net:socket-maxseg \ (bytes)
|
||||
use given size for TCP_MAXSEG socket option. Not all operating systems support
|
||||
-this option, but linux does.
|
||||
+this option, but Linux does.
|
||||
.TP
|
||||
.BR net:timeout " (time interval)"
|
||||
sets the network protocol timeout.
|
||||
@@ -1823,9 +1823,9 @@ save pget transfer status this often. Se
|
||||
The status is saved to a file with suffix \fI.lftp-pget-status\fP.
|
||||
.TP
|
||||
.BR sftp:charset \ (string)
|
||||
-the character set used by sftp server in file names and file listings.
|
||||
+the character set used by SFTP server in file names and file listings.
|
||||
Default is empty which means the same as local. This setting is only used
|
||||
-for sftp protocol version prior to 4. Version 4 and later always use UTF-8.
|
||||
+for SFTP protocol version prior to 4. Version 4 and later always use UTF-8.
|
||||
.TP
|
||||
.BR sftp:connect-program \ (string)
|
||||
the program to use for connecting to remote server. It should support `\-l' option
|
||||
@@ -1848,7 +1848,7 @@ Default is `sftp'. You can use rsh as tr
|
||||
set sftp:connect-program rsh
|
||||
set sftp:server-program /usr/libexec/openssh/sftp-server
|
||||
.De
|
||||
-Similarly you can run sftp over ssh1.
|
||||
+Similarly you can run SFTP over SSH1.
|
||||
.TP
|
||||
.BR sftp:size-read \ (number)
|
||||
Block size for reading. Default is 0x8000.
|
||||
@@ -1886,7 +1886,7 @@ if set to yes, then verify server's cert
|
||||
Certificate Authority and not be on Certificate Revocation List.
|
||||
.TP
|
||||
.BR torrent:ip " (ipv4 address)"
|
||||
-IP address to send to the tracker. Specify it if you are using an http proxy.
|
||||
+IP address to send to the tracker. Specify it if you are using an HTTP proxy.
|
||||
.TP
|
||||
.BR torrent:ipv6 " (ipv6 address)"
|
||||
IPv6 address to send to the tracker. By default, first found global unicast address is used.
|
||||
@@ -1990,7 +1990,7 @@ They can also have a prefix: 0 - octal,
|
||||
.SS FTP asynchronous mode (pipelining)
|
||||
.PP
|
||||
.B Lftp
|
||||
-can speed up ftp operations by sending several commands at once and
|
||||
+can speed up FTP operations by sending several commands at once and
|
||||
then checking all the responses. See ftp:sync-mode variable. Sometimes
|
||||
this does not work, thus synchronous mode is the default. You can try
|
||||
to turn synchronous mode off and see if it works for you. It is known
|
||||
@@ -2000,7 +2000,7 @@ incorrectly in the case of several FTP c
|
||||
RFC959 says: ``The user-process sending another command before the
|
||||
completion reply would be in violation of protocol; but server-FTP
|
||||
processes should queue any commands that arrive while a preceding
|
||||
-command is in progress''. Also, RFC1123 says: ``Implementors MUST
|
||||
+command is in progress''. Also, RFC1123 says: ``Implementers MUST
|
||||
NOT assume any correspondence between READ boundaries on the control
|
||||
connection and the Telnet EOL sequences (CR LF).'' and ``a single READ
|
||||
from the control connection may include more than one FTP command''.
|
||||
@@ -2099,7 +2099,7 @@ The directory is used to store DHT id an
|
||||
File name suffix is the host name.
|
||||
.TP
|
||||
.I "~/.netrc"
|
||||
-The file is consulted to get default login and password to ftp server.
|
||||
+The file is consulted to get default login and password to FTP server.
|
||||
Passwords are also searched here if an URL with user name but with no
|
||||
password is used.
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -up lftp-4.4.8/doc/lftp.1.doc-rename lftp-4.4.8/doc/lftp.1
|
||||
--- lftp-4.4.8/doc/lftp.1.doc-rename 2013-11-27 12:00:35.472739297 +0100
|
||||
+++ lftp-4.4.8/doc/lftp.1 2013-11-27 12:03:06.101770435 +0100
|
||||
@@ -1938,6 +1938,9 @@ of the file.
|
||||
.BR xfer:verify-command \ (string)
|
||||
the command to validate file integrity. The only argument is the path to
|
||||
the file.
|
||||
+.TP
|
||||
+.BR xfer:auto-rename (boolean)
|
||||
+suggested filenames provided by the server are used if user explicitly sets this option to ’on’. As this could be security risk, default is off.
|
||||
|
||||
.PP
|
||||
The name of a variable can be abbreviated unless it becomes
|
@ -1,12 +0,0 @@
|
||||
diff -up lftp-4.4.8/src/FileCopy.cc.overwrite lftp-4.4.8/src/FileCopy.cc
|
||||
--- lftp-4.4.8/src/FileCopy.cc.overwrite 2013-11-28 10:42:18.374656024 +0100
|
||||
+++ lftp-4.4.8/src/FileCopy.cc 2013-11-28 10:42:58.224631188 +0100
|
||||
@@ -1414,7 +1414,7 @@ int FileCopyPeerFDStream::Do()
|
||||
{
|
||||
const char *new_name=dir_file(dirname(stream->full_name),suggested_filename);
|
||||
struct stat st;
|
||||
- if(lstat(new_name,&st)==-1 && errno==ENOENT) {
|
||||
+ if((lstat(new_name,&st)==-1 && errno==ENOENT) || ResMgr::QueryBool("xfer:clobber",0)) {
|
||||
debug((5,"copy: renaming `%s' to `%s'\n",stream->full_name.get(),suggested_filename.get()));
|
||||
if(rename(stream->full_name,new_name)==-1)
|
||||
debug((3,"rename(%s, %s): %s\n",stream->full_name.get(),new_name,strerror(errno)));
|
11
lftp.spec
11
lftp.spec
@ -1,6 +1,6 @@
|
||||
Summary: A sophisticated file transfer program
|
||||
Name: lftp
|
||||
Version: 4.4.16
|
||||
Version: 4.5.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Internet
|
||||
@ -11,9 +11,6 @@ BuildRequires: ncurses-devel, gnutls-devel, pkgconfig, readline-devel, gettext
|
||||
BuildRequires: zlib-devel
|
||||
|
||||
Patch1: lftp-4.0.9-date_fmt.patch
|
||||
Patch2: lftp-4.2.0-man.patch
|
||||
Patch3: lftp-4.4.13-doc-rename.patch
|
||||
Patch4: lftp-4.4.13-overwrite.patch
|
||||
|
||||
%description
|
||||
LFTP is a sophisticated ftp/http file transfer program. Like bash, it has job
|
||||
@ -34,9 +31,6 @@ Utility scripts for use with lftp.
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .date_fmt
|
||||
%patch2 -p1 -b .man
|
||||
%patch3 -p1 -b .doc-rename
|
||||
%patch4 -p1 -b .overwrite
|
||||
|
||||
#sed -i.rpath -e '/lftp_cv_openssl/s|-R.*lib||' configure
|
||||
sed -i.norpath -e \
|
||||
@ -99,6 +93,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri May 23 2014 Jiri Skala <jskala@redhat.com> - 4.5.0-1
|
||||
- updated to latest upstream 4.5.0
|
||||
|
||||
* Fri May 09 2014 Jiri Skala <jskala@redhat.com> - 4.4.16-1
|
||||
- updated to latest upstream 4.4.16
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user