- fixed bug in ls via http - corrupted file names containing spaces
This commit is contained in:
parent
9529dd2a30
commit
178f8f025d
12
lftp-3.7.14-decode.patch
Normal file
12
lftp-3.7.14-decode.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up lftp-3.7.14/src/url.cc.decode lftp-3.7.14/src/url.cc
|
||||
--- lftp-3.7.14/src/url.cc.decode 2009-03-20 12:20:14.000000000 +0100
|
||||
+++ lftp-3.7.14/src/url.cc 2009-06-10 15:36:30.000000000 +0200
|
||||
@@ -366,7 +366,7 @@ int url::decode_string(char *str)
|
||||
*o++=*p++;
|
||||
}
|
||||
*o=0;
|
||||
- return p-str;
|
||||
+ return o-str;
|
||||
}
|
||||
|
||||
const char *url::decode(const char *p)
|
10
lftp.spec
10
lftp.spec
@ -1,7 +1,7 @@
|
||||
Summary: A sophisticated file transfer program
|
||||
Name: lftp
|
||||
Version: 3.7.14
|
||||
Release: 1%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.yar.ru/lftp/lftp-%{version}.tar.gz
|
||||
@ -9,6 +9,8 @@ URL: http://lftp.yar.ru/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: ncurses-devel, gnutls-devel, pkgconfig, readline-devel, gettext
|
||||
|
||||
Patch1: lftp-3.7.14-decode.patch
|
||||
|
||||
%description
|
||||
LFTP is a sophisticated ftp/http file transfer program. Like bash, it has job
|
||||
control and uses the readline library for input. It has bookmarks, built-in
|
||||
@ -17,6 +19,9 @@ reliability in mind.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .decode
|
||||
|
||||
#sed -i.rpath -e '/lftp_cv_openssl/s|-R.*lib||' configure
|
||||
sed -i.norpath -e \
|
||||
'/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib64 |' \
|
||||
@ -74,6 +79,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/liblftp-tasks.so.*
|
||||
|
||||
%changelog
|
||||
* Wed Jun 10 2009 Jiri Skala <jskala@redhat.com> - 3.7.14-3
|
||||
- fixed bug in ls via http - corrupted file names containing spaces
|
||||
|
||||
* Fri May 22 2009 Jiri Skala <jskala@redhat.com> - 3.7.14-1
|
||||
- rebase to latest upstream release; among others fixes #474413
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user