- upgrade to upstream version 3.6.1
- remove rpath and make some spec file changes for review (#225984) - remove old patches - fix core dumping when html tag has its argument empty - use own libtool
This commit is contained in:
parent
57abc4eecd
commit
16aafc0230
12
lftp-3.6.1-empty_argument.patch
Normal file
12
lftp-3.6.1-empty_argument.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up lftp-3.6.1/src/HttpDir.cc.empty_argument lftp-3.6.1/src/HttpDir.cc
|
||||||
|
--- lftp-3.6.1/src/HttpDir.cc.empty_argument 2007-08-29 13:20:13.000000000 +0200
|
||||||
|
+++ lftp-3.6.1/src/HttpDir.cc 2008-01-25 14:00:43.000000000 +0100
|
||||||
|
@@ -70,6 +70,8 @@ static bool find_value(const char *scan,
|
||||||
|
if(*scan=='"' || *scan=='\'')
|
||||||
|
quote=*scan++;
|
||||||
|
|
||||||
|
+ if(match)
|
||||||
|
+ store.set("");
|
||||||
|
while(scan<more && (quote ? *scan!=quote : !is_ascii_space(*scan)))
|
||||||
|
{
|
||||||
|
if(match)
|
41
lftp.spec
41
lftp.spec
@ -7,9 +7,10 @@ Group: Applications/Internet
|
|||||||
Source0: ftp://ftp.yar.ru/lftp/lftp-%{version}.tar.gz
|
Source0: ftp://ftp.yar.ru/lftp/lftp-%{version}.tar.gz
|
||||||
URL: http://lftp.yar.ru/
|
URL: http://lftp.yar.ru/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: ncurses-devel, openssl-devel, pkgconfig, readline-devel, libtool, gettext, chrpath
|
BuildRequires: ncurses-devel, openssl-devel, pkgconfig, readline-devel, gettext
|
||||||
|
|
||||||
Patch1: lftp-3.5.14-progress_overflow.patch
|
Patch1: lftp-3.5.14-progress_overflow.patch
|
||||||
|
Patch2: lftp-3.6.1-empty_argument.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
LFTP is a sophisticated ftp/http file transfer program. Like bash, it has job
|
LFTP is a sophisticated ftp/http file transfer program. Like bash, it has job
|
||||||
@ -20,68 +21,48 @@ reliability in mind.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .progress_overflow
|
%patch1 -p1 -b .progress_overflow
|
||||||
|
%patch2 -p1 -b .empty_argument
|
||||||
|
|
||||||
%build
|
%build
|
||||||
if pkg-config openssl ; then
|
if pkg-config openssl ; then
|
||||||
CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
|
CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
|
||||||
LDFLAGS=`pkg-config --libs-only-L openssl`; export LDFLAGS
|
LDFLAGS=`pkg-config --libs-only-L openssl`; export LDFLAGS
|
||||||
fi
|
fi
|
||||||
LDFLAGS="-L`pwd`/src/.libs $LDFLAGS"; export LDFLAGS
|
|
||||||
%configure --with-modules --disable-static --with-openssl=/usr --with-debug --disable-rpath
|
%configure --with-modules --disable-static --with-openssl=/usr --with-debug --disable-rpath
|
||||||
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
export tagname=CC
|
export tagname=CC
|
||||||
make LIBTOOL=%{_bindir}/libtool %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%{?!DEBUG: %define DEBUG 0}
|
|
||||||
%if %{DEBUG}
|
|
||||||
%define debug_package %{nil}
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
export tagname=CC
|
export tagname=CC
|
||||||
make LIBTOOL=%{_bindir}/libtool DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' install
|
make DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' install
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.la
|
||||||
chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/*
|
chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/*
|
||||||
chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.so
|
chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.so
|
||||||
iconv -f ISO88591 -t UTF8 NEWS -o NEWS.tmp
|
iconv -f ISO88591 -t UTF8 NEWS -o NEWS.tmp
|
||||||
|
touch -r NEWS NEWS.tmp
|
||||||
mv -f NEWS.tmp NEWS
|
mv -f NEWS.tmp NEWS
|
||||||
# Remove files from $RPM_BUILD_ROOT that we aren't shipping.
|
# Remove files from $RPM_BUILD_ROOT that we aren't shipping.
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.a
|
rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.a
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/liblftp-jobs.*a
|
rm -f $RPM_BUILD_ROOT%{_libdir}/liblftp-jobs.*a
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/liblftp-tasks.*a
|
rm -f $RPM_BUILD_ROOT%{_libdir}/liblftp-tasks.*a
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/liblftp-*.so
|
rm -f $RPM_BUILD_ROOT%{_libdir}/liblftp-*.so
|
||||||
# Remove rpath
|
|
||||||
chrpath --delete $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/proto-http.so
|
|
||||||
chrpath --delete $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/liblftp-network.so
|
|
||||||
chrpath --delete $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/proto-sftp.so
|
|
||||||
chrpath --delete $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/proto-ftp.so
|
|
||||||
chrpath --delete $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/proto-fish.so
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
|
|
||||||
echo "%{_libdir}/lftp/%{version}" > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{name}-%{_arch}.conf
|
|
||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
%if %{DEBUG}
|
|
||||||
%{_libdir}/rpm/brp-compress
|
|
||||||
exit 0
|
|
||||||
%endif
|
|
||||||
:;
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun
|
%postun -p /sbin/ldconfig
|
||||||
if [ "$1" = 0 ]; then
|
|
||||||
/sbin/ldconfig
|
|
||||||
fi
|
|
||||||
exit 0
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc BUGS COPYING ChangeLog FAQ FEATURES README* NEWS THANKS TODO
|
%doc BUGS COPYING ChangeLog FAQ FEATURES README* NEWS THANKS TODO
|
||||||
%config(noreplace) %{_sysconfdir}/lftp.conf
|
%config(noreplace) %{_sysconfdir}/lftp.conf
|
||||||
%config /etc/ld.so.conf.d/*
|
|
||||||
|
|
||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
@ -102,10 +83,12 @@ exit 0
|
|||||||
%{_libdir}/liblftp-tasks*
|
%{_libdir}/liblftp-tasks*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Jan 23 2008 Martin Nagy <mnagy@redhat.com> - 3.6.1-1
|
* Mon Feb 11 2008 Martin Nagy <mnagy@redhat.com> - 3.6.1-1
|
||||||
- upgrade to upstream version 3.6.1
|
- upgrade to upstream version 3.6.1
|
||||||
- remove rpath and make some spec file changes for review (#225984)
|
- remove rpath and make some spec file changes for review (#225984)
|
||||||
- remove old patches
|
- remove old patches
|
||||||
|
- fix core dumping when html tag has its argument empty
|
||||||
|
- use own libtool
|
||||||
|
|
||||||
* Tue Dec 13 2007 Martin Nagy <mnagy@redhat.com> - 3.5.14-3
|
* Tue Dec 13 2007 Martin Nagy <mnagy@redhat.com> - 3.5.14-3
|
||||||
- Fixed coredumping when downloading (#414051)
|
- Fixed coredumping when downloading (#414051)
|
||||||
|
Loading…
Reference in New Issue
Block a user