Rebase to 581.2
Resolves:#1954859
This commit is contained in:
parent
cfe05cef25
commit
a99f1f96fd
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/less-551.tar.gz
|
||||
/less-568.tar.gz
|
||||
/less-575.tar.gz
|
||||
/less-581.2.tar.gz
|
||||
|
@ -4,17 +4,12 @@ Date: Fri, 22 Jan 2021 09:49:13 -0500
|
||||
Subject: [PATCH] Test for fsync on tty
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
configure.ac | 14 +++++++++++++-
|
||||
1 file changed, 13 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 918807967473e01af6c5d78b1737c2d06f96b426..ce478adc1ea2d37c2b22eb46fc2b55d2ba49244e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -219,10 +219,12 @@ AH_TEMPLATE([HAVE_STAT_INO],
|
||||
[Define HAVE_STAT_INO if your struct stat has st_ino and st_dev.])
|
||||
AH_TEMPLATE([HAVE_TIME_T],
|
||||
Modified for less 581.2 Filip Januš <fjanus@redhat.com>
|
||||
diff -ur less-581.2/configure.ac less_fsync/configure.ac
|
||||
--- less-581.2/configure.ac 2021-04-28 17:00:08.000000000 +0200
|
||||
+++ less_fsync/configure.ac 2021-05-06 10:59:07.560062397 +0200
|
||||
@@ -221,6 +221,8 @@
|
||||
[Define HAVE_TIME_T if your system supports the "time_t" type.])
|
||||
AH_TEMPLATE([HAVE_STRERROR],
|
||||
[Define HAVE_STRERROR if you have the strerror() function.])
|
||||
@ -23,24 +18,16 @@ index 918807967473e01af6c5d78b1737c2d06f96b426..ce478adc1ea2d37c2b22eb46fc2b55d2
|
||||
AH_TEMPLATE([HAVE_FILENO],
|
||||
[Define HAVE_FILENO if you have the fileno() macro.])
|
||||
AH_TEMPLATE([HAVE_ERRNO],
|
||||
[Define HAVE_ERRNO if you have the errno variable.])
|
||||
AH_TEMPLATE([MUST_DEFINE_ERRNO],
|
||||
@@ -272,11 +274,11 @@ AC_MSG_CHECKING(for ANSI function prototypes)
|
||||
AC_TRY_COMPILE([], [int f(int a) { return a; }],
|
||||
[AC_MSG_RESULT(yes); AC_DEFINE(HAVE_ANSI_PROTOS)], [AC_MSG_RESULT(no)])
|
||||
@@ -274,7 +276,7 @@
|
||||
|
||||
# Checks for library functions.
|
||||
AC_TYPE_SIGNAL
|
||||
-AC_CHECK_FUNCS([fchmod fsync nanosleep poll popen realpath _setjmp sigprocmask sigsetmask snprintf stat system usleep])
|
||||
+AC_CHECK_FUNCS([fchmod nanosleep poll popen realpath _setjmp sigprocmask sigsetmask snprintf stat system usleep])
|
||||
-AC_CHECK_FUNCS([fchmod fsync nanosleep poll popen realpath _setjmp sigprocmask sigsetmask snprintf stat system ttyname usleep])
|
||||
+AC_CHECK_FUNCS([fchmod nanosleep poll popen realpath _setjmp sigprocmask sigsetmask snprintf stat system ttyname usleep])
|
||||
|
||||
# AC_CHECK_FUNCS may not work for inline functions, so test these separately.
|
||||
AC_MSG_CHECKING(for memcpy)
|
||||
AC_TRY_LINK([
|
||||
#if HAVE_STRING_H
|
||||
@@ -319,10 +321,20 @@ AC_TRY_LINK([
|
||||
#if HAVE_ERRNO_H
|
||||
#include <errno.h>
|
||||
@@ -321,6 +323,16 @@
|
||||
#endif], [static char *x; x = strerror(0);],
|
||||
[AC_MSG_RESULT(yes); AC_DEFINE(HAVE_STRERROR)], [AC_MSG_RESULT(no)])
|
||||
|
||||
@ -57,8 +44,3 @@ index 918807967473e01af6c5d78b1737c2d06f96b426..ce478adc1ea2d37c2b22eb46fc2b55d2
|
||||
AC_MSG_CHECKING(for sys_errlist)
|
||||
AC_TRY_LINK(, [extern char *sys_errlist[]; static char **x; x = sys_errlist;],
|
||||
[AC_MSG_RESULT(yes); AC_DEFINE(HAVE_SYS_ERRLIST)], [AC_MSG_RESULT(no)])
|
||||
|
||||
AC_CHECK_TYPES([sigset_t],,,[#include <signal.h>])
|
||||
--
|
||||
2.29.2
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: A text file browser similar to more, but better
|
||||
Name: less
|
||||
Version: 575
|
||||
Release: 2%{?dist}
|
||||
Version: 581.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+ or BSD
|
||||
Source0: https://www.greenwoodsoftware.com/less/%{name}-%{version}.tar.gz
|
||||
Source1: lesspipe.sh
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (less-575.tar.gz) = 04f4526a2d5286ade7321f46c9cd1584e44d75ad5275b5623d346930c6f78d933e29edaca6ccf86b5d8422102c830f2ae097a295a914a8da9fd6260f131c78bc
|
||||
SHA512 (less-581.2.tar.gz) = b1189396c798d7cb8655175f31b1af6163dcf8e8d7a72531161cc8396e72e0cf5858ce7b39173be603f9f16eda498f2805cf42c2b92ec6970fd9d2b603fb7b92
|
||||
|
Loading…
Reference in New Issue
Block a user