Update to 481, fixes (#1231493)
This commit is contained in:
parent
00941dc566
commit
81a5028f51
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
|||||||
/less-471.tar.gz
|
/less-471.tar.gz
|
||||||
/less-478.tar.gz
|
/less-478.tar.gz
|
||||||
/less-479.tar.gz
|
/less-479.tar.gz
|
||||||
|
/less-481.tar.gz
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
--- less-394/line.c.search 2005-12-03 21:20:32.000000000 +0100
|
|
||||||
+++ less-394/line.c 2006-02-15 11:23:25.308694376 +0100
|
|
||||||
@@ -1125,6 +1125,14 @@
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+ if (c == '\0')
|
|
||||||
+ {
|
|
||||||
+ /*
|
|
||||||
+ * Pretend the line ended here
|
|
||||||
+ */
|
|
||||||
+ new_pos = ch_tell();
|
|
||||||
+ break;
|
|
||||||
+ }
|
|
||||||
linebuf[n++] = c;
|
|
||||||
c = ch_forw_get();
|
|
||||||
}
|
|
||||||
@@ -1198,6 +1206,14 @@
|
|
||||||
*to = *fm;
|
|
||||||
n = size_linebuf - old_size_linebuf;
|
|
||||||
}
|
|
||||||
+ if (c == '\0')
|
|
||||||
+ {
|
|
||||||
+ /*
|
|
||||||
+ * Pretend the line ended here
|
|
||||||
+ */
|
|
||||||
+ new_pos = ch_tell() + 1;
|
|
||||||
+ break;
|
|
||||||
+ }
|
|
||||||
linebuf[--n] = c;
|
|
||||||
}
|
|
||||||
if (linep != NULL)
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -pruN less-458.orig/charset.c less-458/charset.c
|
|
||||||
--- less-458.orig/charset.c 2013-04-05 01:55:05.000000000 +0900
|
|
||||||
+++ less-458/charset.c 2014-03-10 19:47:09.850026052 +0900
|
|
||||||
@@ -970,7 +970,7 @@ static struct wchar_range ubin_table[] =
|
|
||||||
{ 0x2064, 0x2069} /* Cn */,
|
|
||||||
{ 0x206A, 0x206F} /* Cf */,
|
|
||||||
{ 0x2072, 0x2073} /* Cn */, { 0x208F, 0x208F} /* Cn */,
|
|
||||||
- { 0x2095, 0x209F} /* Cn */, { 0x20B6, 0x20CF} /* Cn */,
|
|
||||||
+ { 0x2095, 0x209F} /* Cn */, { 0x20BB, 0x20CF} /* Cn */,
|
|
||||||
{ 0x20F0, 0x20FF} /* Cn */, { 0x214F, 0x2152} /* Cn */,
|
|
||||||
{ 0x2185, 0x218F} /* Cn */, { 0x23E8, 0x23FF} /* Cn */,
|
|
||||||
{ 0x2427, 0x243F} /* Cn */, { 0x244B, 0x245F} /* Cn */,
|
|
11
less.spec
11
less.spec
@ -1,16 +1,14 @@
|
|||||||
Summary: A text file browser similar to more, but better
|
Summary: A text file browser similar to more, but better
|
||||||
Name: less
|
Name: less
|
||||||
Version: 479
|
Version: 481
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+ or BSD
|
License: GPLv3+ or BSD
|
||||||
Group: Applications/Text
|
Group: Applications/Text
|
||||||
Source: http://www.greenwoodsoftware.com/less/%{name}-%{version}.tar.gz
|
Source: http://www.greenwoodsoftware.com/less/%{name}-%{version}.tar.gz
|
||||||
Source1: lesspipe.sh
|
Source1: lesspipe.sh
|
||||||
Source2: less.sh
|
Source2: less.sh
|
||||||
Source3: less.csh
|
Source3: less.csh
|
||||||
Source4: less.zsh
|
|
||||||
Patch1: less-444-Foption.v2.patch
|
Patch1: less-444-Foption.v2.patch
|
||||||
Patch2: less-394-search.patch
|
|
||||||
Patch4: less-394-time.patch
|
Patch4: less-394-time.patch
|
||||||
Patch5: less-418-fsync.patch
|
Patch5: less-418-fsync.patch
|
||||||
Patch6: less-436-manpage-add-old-bot-option.patch
|
Patch6: less-436-manpage-add-old-bot-option.patch
|
||||||
@ -38,7 +36,6 @@ files, and you'll use it frequently.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p2 -b .Foption
|
%patch1 -p2 -b .Foption
|
||||||
%patch2 -p1 -b .search
|
|
||||||
%patch4 -p1 -b .time
|
%patch4 -p1 -b .time
|
||||||
%patch5 -p1 -b .fsync
|
%patch5 -p1 -b .fsync
|
||||||
%patch6 -p1 -b .manpage-add-old-bot-option
|
%patch6 -p1 -b .manpage-add-old-bot-option
|
||||||
@ -61,7 +58,6 @@ mkdir -p $RPM_BUILD_ROOT/etc/profile.d
|
|||||||
install -p %{SOURCE1} $RPM_BUILD_ROOT/%{_bindir}
|
install -p %{SOURCE1} $RPM_BUILD_ROOT/%{_bindir}
|
||||||
install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT/etc/profile.d
|
install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT/etc/profile.d
|
||||||
install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT/etc/profile.d
|
install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT/etc/profile.d
|
||||||
install -p -m 644 %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc README NEWS INSTALL
|
%doc README NEWS INSTALL
|
||||||
@ -71,6 +67,9 @@ install -p -m 644 %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 2 2015 Viktor Jancik <vjancik@redhat.com> - 481-1
|
||||||
|
- Update to version 481, fixes #1231493
|
||||||
|
|
||||||
* Wed Sep 2 2015 Viktor Jancik <vjancik@redhat.com> - 479-3
|
* Wed Sep 2 2015 Viktor Jancik <vjancik@redhat.com> - 479-3
|
||||||
- Added missing double quotes in profile.d scripts
|
- Added missing double quotes in profile.d scripts
|
||||||
- Corrected license information
|
- Corrected license information
|
||||||
|
5
less.zsh
5
less.zsh
@ -1,5 +0,0 @@
|
|||||||
#!/bin/zsh
|
|
||||||
# less initialization script (sh)
|
|
||||||
if [[ -x /usr/bin/lesspipe.sh && -z "$LESSOPEN" ]] ; then
|
|
||||||
export LESSOPEN="|/usr/bin/lesspipe.sh %s"
|
|
||||||
fi
|
|
Loading…
Reference in New Issue
Block a user