- upgrade to 409
- remove useless/obsolete patches - add autoconf buildrequires
This commit is contained in:
parent
ca77dd8342
commit
3e1aa86328
@ -1 +1 @@
|
||||
less-406.tar.gz
|
||||
less-409.tar.gz
|
||||
|
@ -1,28 +0,0 @@
|
||||
--- less-394/jump.c.fixline 2005-12-03 21:20:32.000000000 +0100
|
||||
+++ less-394/jump.c 2006-01-16 15:12:00.000000000 +0100
|
||||
@@ -30,7 +30,7 @@
|
||||
public void
|
||||
jump_forw()
|
||||
{
|
||||
- POSITION pos;
|
||||
+ POSITION pos, end_pos;
|
||||
|
||||
if (ch_end_seek())
|
||||
{
|
||||
@@ -42,11 +42,15 @@ jump_forw()
|
||||
* Go back one line from the end of the file
|
||||
* to get to the beginning of the last line.
|
||||
*/
|
||||
- pos = back_line(ch_tell());
|
||||
+ pos = back_line(end_pos = ch_tell());
|
||||
if (pos == NULL_POSITION)
|
||||
jump_loc((POSITION)0, sc_height-1);
|
||||
else
|
||||
+ {
|
||||
jump_loc(pos, sc_height-1);
|
||||
+ if (position(sc_height-1) != end_pos)
|
||||
+ repaint();
|
||||
+ }
|
||||
}
|
||||
|
||||
/*
|
@ -1,12 +0,0 @@
|
||||
--- less-394/jump.c.goend 2006-10-25 11:04:49.000000000 +0200
|
||||
+++ less-394/jump.c 2006-10-25 11:31:47.000000000 +0200
|
||||
@@ -42,7 +42,9 @@
|
||||
* Go back one line from the end of the file
|
||||
* to get to the beginning of the last line.
|
||||
*/
|
||||
+ pos_clear();
|
||||
pos = back_line(end_pos = ch_tell());
|
||||
+
|
||||
if (pos == NULL_POSITION)
|
||||
jump_loc((POSITION)0, sc_height-1);
|
||||
else
|
15
less.spec
15
less.spec
@ -1,23 +1,21 @@
|
||||
Summary: A text file browser similar to more, but better
|
||||
Name: less
|
||||
Version: 406
|
||||
Release: 12%{?dist}
|
||||
Version: 409
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: Applications/Text
|
||||
Source: http://www.greenwoodsoftware.com/less/%{name}-%{version}.tar.gz
|
||||
Source1: lesspipe.sh
|
||||
Source2: less.sh
|
||||
Source3: less.csh
|
||||
Patch0: less-382-fixline.patch
|
||||
Patch1: less-406-Foption.patch
|
||||
Patch3: less-394-goend.patch
|
||||
Patch4: less-394-time.patch
|
||||
|
||||
URL: http://www.greenwoodsoftware.com/less/
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: which
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: pcre-devel
|
||||
BuildRequires: autoconf
|
||||
|
||||
%description
|
||||
The less utility is a text file browser that resembles more, but has
|
||||
@ -31,9 +29,7 @@ files, and you'll use it frequently.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .fixline
|
||||
%patch1 -p1 -b .Foption
|
||||
%patch3 -p1 -b .goend
|
||||
%patch4 -p1 -b .time
|
||||
chmod -R a+w *
|
||||
chmod 644 lessecho.c lesskey.c version.c LICENSE
|
||||
@ -63,6 +59,11 @@ ls -la $RPM_BUILD_ROOT/etc/profile.d
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Mon Oct 22 2007 Ivana Varekova <varekova@redhat.com> - 409-1
|
||||
- upgrade to 409
|
||||
- remove useless/obsolete patches
|
||||
- add autoconf buildrequires
|
||||
|
||||
* Mon Oct 1 2007 Ivana Varekova <varekova@redhat.com> - 406-12
|
||||
- change license tag
|
||||
- fix 312591 - add which dependency
|
||||
|
Loading…
Reference in New Issue
Block a user