46 lines
1.5 KiB
Diff
46 lines
1.5 KiB
Diff
diff -up ./configure.ac.pkg-config ./configure.ac
|
|
--- ./configure.ac.pkg-config 2011-08-23 03:30:10.000000000 +1000
|
|
+++ ./configure.ac 2013-04-16 11:03:09.418009954 +1000
|
|
@@ -16,7 +16,6 @@ AC_PROG_AWK
|
|
AC_PROG_CC
|
|
AC_PROG_CPP
|
|
AC_PROG_INSTALL
|
|
-AC_PROG_LIBTOOL
|
|
AC_PROG_LN_S
|
|
AC_PROG_MAKE_SET
|
|
|
|
@@ -105,5 +104,5 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM()],
|
|
# Checks for library functions.
|
|
AC_CHECK_FUNCS([fmemopen])
|
|
|
|
-AC_CONFIG_FILES([Makefile src/endianness.h src/Makefile prog/Makefile])
|
|
+AC_CONFIG_FILES([Makefile lept.pc src/endianness.h src/Makefile prog/Makefile])
|
|
AC_OUTPUT
|
|
diff -up ./lept.pc.in.pkg-config ./lept.pc.in
|
|
--- ./lept.pc.in.pkg-config 2013-04-16 10:48:38.238982664 +1000
|
|
+++ ./lept.pc.in 2013-04-16 10:48:38.238982664 +1000
|
|
@@ -0,0 +1,10 @@
|
|
+libdir=@libdir@
|
|
+includedir=@includedir@/leptonica
|
|
+
|
|
+Name: leptonica
|
|
+Description: An open source C library for efficient image processing and image analysis operations
|
|
+Version: @VERSION@
|
|
+Libs: -L${libdir} -llept
|
|
+Libs.private: @ZLIB_LIBS@ @LIBPNG_LIBS@ @JPEG_LIBS@ @GIFLIB_LIBS@ @LIBTIFF_LIBS@ @LIBWEBP_LIBS@
|
|
+Cflags: -I${includedir}
|
|
+
|
|
diff -up ./Makefile.am.pkg-config ./Makefile.am
|
|
--- ./Makefile.am.pkg-config 2010-11-09 05:09:39.000000000 +1000
|
|
+++ ./Makefile.am 2013-04-16 10:48:38.239982664 +1000
|
|
@@ -2,6 +2,9 @@ ACLOCAL_AMFLAGS = -I m4
|
|
AUTOMAKE_OPTIONS = foreign
|
|
EXTRA_DIST = config README.html leptonica-license.txt moller52.jpg version-notes.html make-for-auto make-for-local autobuild
|
|
|
|
+pkgconfigdir = $(libdir)/pkgconfig
|
|
+pkgconfig_DATA = lept.pc
|
|
+
|
|
if ENABLE_PROGRAMS
|
|
PROGRAMS_SUBDIR = prog
|
|
endif
|