Fix broken pkg-config file
This commit is contained in:
parent
caa0a1c920
commit
e2486ca5bc
@ -6,7 +6,7 @@
|
||||
|
||||
Name: leptonica
|
||||
Version: 1.82.0
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Summary: C library for efficient image processing and image analysis operations
|
||||
|
||||
License: Leptonica
|
||||
@ -177,6 +177,9 @@ ln -s %{mingw64_libdir}/libleptonica.dll.a %{buildroot}%{mingw64_libdir}/liblept
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 24 2022 Sandro Mani <manisandro@gmail.com> - 1.82.0-6
|
||||
- Fix broken pkg-config file
|
||||
|
||||
* Thu Feb 24 2022 Sandro Mani <manisandro@gmail.com> - 1.82.0-5
|
||||
- Make mingw subpackages noarch
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -rupN leptonica-1.82.0/CMakeLists.txt leptonica-1.82.0-new/CMakeLists.txt
|
||||
--- leptonica-1.82.0/CMakeLists.txt 2021-09-22 23:23:41.000000000 +0200
|
||||
+++ leptonica-1.82.0-new/CMakeLists.txt 2022-02-22 23:06:47.081641319 +0100
|
||||
+++ leptonica-1.82.0-new/CMakeLists.txt 2022-02-24 21:41:07.900608047 +0100
|
||||
@@ -57,7 +57,7 @@ if(UNIX)
|
||||
option(SYM_LINK "Create symlink leptonica -> lept on UNIX" OFF)
|
||||
endif()
|
||||
@ -21,8 +21,8 @@ diff -rupN leptonica-1.82.0/CMakeLists.txt leptonica-1.82.0-new/CMakeLists.txt
|
||||
${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig-version.cmake
|
||||
diff -rupN leptonica-1.82.0/src/CMakeLists.txt leptonica-1.82.0-new/src/CMakeLists.txt
|
||||
--- leptonica-1.82.0/src/CMakeLists.txt 2021-09-22 23:23:41.000000000 +0200
|
||||
+++ leptonica-1.82.0-new/src/CMakeLists.txt 2022-02-22 23:06:02.035449743 +0100
|
||||
@@ -17,11 +17,11 @@ endif()
|
||||
+++ leptonica-1.82.0-new/src/CMakeLists.txt 2022-02-24 21:42:58.487369993 +0100
|
||||
@@ -17,15 +17,14 @@ endif()
|
||||
string(REPLACE "-O3" "-O2" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
|
||||
|
||||
add_library (leptonica ${src} ${hdr})
|
||||
@ -32,12 +32,17 @@ diff -rupN leptonica-1.82.0/src/CMakeLists.txt leptonica-1.82.0-new/src/CMakeLis
|
||||
if (WIN32)
|
||||
-set_target_properties (leptonica PROPERTIES OUTPUT_NAME leptonica-${VERSION_PLAIN})
|
||||
-set_target_properties (leptonica PROPERTIES DEBUG_OUTPUT_NAME leptonica-${VERSION_PLAIN}d)
|
||||
-else()
|
||||
+set_target_properties (leptonica PROPERTIES SUFFIX "-5${CMAKE_SHARED_LIBRARY_SUFFIX}")
|
||||
+set_target_properties (leptonica PROPERTIES SUFFIX "-5${CMAKE_SHARED_LIBRARY_SUFFIX}")
|
||||
else()
|
||||
+endif()
|
||||
set_target_properties (leptonica PROPERTIES OUTPUT_NAME leptonica)
|
||||
set_target_properties (leptonica PROPERTIES DEBUG_OUTPUT_NAME leptonica)
|
||||
@@ -70,7 +70,7 @@ if (UNIX)
|
||||
-endif()
|
||||
|
||||
if (BUILD_SHARED_LIBS)
|
||||
target_compile_definitions (leptonica PRIVATE -DLIBLEPT_EXPORTS)
|
||||
@@ -70,7 +69,7 @@ if (UNIX)
|
||||
${CMAKE_COMMAND} -E create_symlink "$<TARGET_FILE:leptonica>" ${old_target}
|
||||
DEPENDS ${PROJECT_NAME}
|
||||
COMMENT "Creating lept symlink")
|
||||
@ -46,7 +51,7 @@ diff -rupN leptonica-1.82.0/src/CMakeLists.txt leptonica-1.82.0-new/src/CMakeLis
|
||||
endif(SYM_LINK)
|
||||
endif()
|
||||
|
||||
@@ -89,7 +89,7 @@ else()
|
||||
@@ -89,7 +88,7 @@ else()
|
||||
export(TARGETS leptonica APPEND FILE ${CMAKE_BINARY_DIR}/LeptonicaTargets.cmake)
|
||||
endif()
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user