Update to 1.83.0

This commit is contained in:
Sandro Mani 2022-12-21 15:25:46 +01:00
parent 603afa3cab
commit ca424997c9
4 changed files with 35 additions and 40 deletions

1
.gitignore vendored
View File

@ -17,3 +17,4 @@
/leptonica-1.81.0.tar.gz /leptonica-1.81.0.tar.gz
/leptonica-1.81.1.tar.gz /leptonica-1.81.1.tar.gz
/leptonica-1.82.0.tar.gz /leptonica-1.82.0.tar.gz
/leptonica-1.83.0.tar.gz

View File

@ -5,8 +5,8 @@
%endif %endif
Name: leptonica Name: leptonica
Version: 1.82.0 Version: 1.83.0
Release: 8%{?dist} Release: 1%{?dist}
Summary: C library for efficient image processing and image analysis operations Summary: C library for efficient image processing and image analysis operations
License: Leptonica License: Leptonica
@ -142,7 +142,7 @@ ln -s %{mingw64_libdir}/libleptonica.dll.a %{buildroot}%{mingw64_libdir}/liblept
%files %files
%license leptonica-license.txt %license leptonica-license.txt
%doc README.html version-notes.html %doc README.html version-notes.html
%{_libdir}/libleptonica.so.5* %{_libdir}/libleptonica.so.6*
%files devel %files devel
%{_includedir}/%{name} %{_includedir}/%{name}
@ -157,7 +157,7 @@ ln -s %{mingw64_libdir}/libleptonica.dll.a %{buildroot}%{mingw64_libdir}/liblept
%files -n mingw32-%{name} %files -n mingw32-%{name}
%license leptonica-license.txt %license leptonica-license.txt
%{mingw32_bindir}/*.exe %{mingw32_bindir}/*.exe
%{mingw32_bindir}/libleptonica-5.dll %{mingw32_bindir}/libleptonica-6.dll
%{mingw32_includedir}/leptonica/ %{mingw32_includedir}/leptonica/
%{mingw32_libdir}/liblept.dll.a %{mingw32_libdir}/liblept.dll.a
%{mingw32_libdir}/libleptonica.dll.a %{mingw32_libdir}/libleptonica.dll.a
@ -168,7 +168,7 @@ ln -s %{mingw64_libdir}/libleptonica.dll.a %{buildroot}%{mingw64_libdir}/liblept
%files -n mingw64-%{name} %files -n mingw64-%{name}
%license leptonica-license.txt %license leptonica-license.txt
%{mingw64_bindir}/*.exe %{mingw64_bindir}/*.exe
%{mingw64_bindir}/libleptonica-5.dll %{mingw64_bindir}/libleptonica-6.dll
%{mingw64_includedir}/leptonica/ %{mingw64_includedir}/leptonica/
%{mingw64_libdir}/liblept.dll.a %{mingw64_libdir}/liblept.dll.a
%{mingw64_libdir}/libleptonica.dll.a %{mingw64_libdir}/libleptonica.dll.a
@ -177,6 +177,9 @@ ln -s %{mingw64_libdir}/libleptonica.dll.a %{buildroot}%{mingw64_libdir}/liblept
%changelog %changelog
* Wed Dec 21 2022 Sandro Mani <manisandro@gmail.com> - 1.83.0-1
- Update to 1.83.0
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.82.0-8 * Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.82.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

View File

@ -1,48 +1,39 @@
diff -rupN leptonica-1.82.0/CMakeLists.txt leptonica-1.82.0-new/CMakeLists.txt diff -rupN leptonica-1.83.0/CMakeLists.txt leptonica-1.83.0-new/CMakeLists.txt
--- leptonica-1.82.0/CMakeLists.txt 2021-09-22 23:23:41.000000000 +0200 --- leptonica-1.83.0/CMakeLists.txt 2022-12-20 22:54:49.000000000 +0100
+++ leptonica-1.82.0-new/CMakeLists.txt 2022-02-24 21:41:07.900608047 +0100 +++ leptonica-1.83.0-new/CMakeLists.txt 2022-12-21 10:50:17.667061152 +0100
@@ -57,7 +57,7 @@ if(UNIX) @@ -60,7 +60,7 @@ option(LIBWEBP_SUPPORT "Build with WebP
option(SYM_LINK "Create symlink leptonica -> lept on UNIX" OFF) option(OPENJPEG_SUPPORT "Build with OpenJPEG support" ON)
endif()
-set(leptonica_INSTALL_CMAKE_DIR "lib/cmake/leptonica" set(leptonica_INSTALL_CMAKE_DIR
+set(leptonica_INSTALL_CMAKE_DIR "lib${LIB_SUFFIX}/cmake/leptonica" - "lib/cmake/leptonica"
+ "lib${LIB_SUFFIX}/cmake/leptonica"
CACHE STRING "Install destination for CMake package files") CACHE STRING "Install destination for CMake package files")
if(NOT SW_BUILD) if(NOT SW_BUILD)
@@ -275,7 +275,7 @@ configure_file( @@ -307,7 +307,7 @@ configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/cmake/templates/LeptonicaConfig.cmake.in ${CMAKE_CURRENT_SOURCE_DIR}/cmake/templates/LeptonicaConfig.cmake.in
${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig.cmake @ONLY) ${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig.cmake @ONLY)
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/lept.pc DESTINATION lib/pkgconfig) -install(FILES ${CMAKE_CURRENT_BINARY_DIR}/lept.pc DESTINATION lib/pkgconfig)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/lept.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig) +install(FILES ${CMAKE_CURRENT_BINARY_DIR}/lept.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig)
install(FILES install(FILES ${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig.cmake
${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig.cmake ${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig-version.cmake
${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig-version.cmake DESTINATION ${leptonica_INSTALL_CMAKE_DIR})
diff -rupN leptonica-1.82.0/src/CMakeLists.txt leptonica-1.82.0-new/src/CMakeLists.txt diff -rupN leptonica-1.83.0/src/CMakeLists.txt leptonica-1.83.0-new/src/CMakeLists.txt
--- leptonica-1.82.0/src/CMakeLists.txt 2021-09-22 23:23:41.000000000 +0200 --- leptonica-1.83.0/src/CMakeLists.txt 2022-12-20 22:54:49.000000000 +0100
+++ leptonica-1.82.0-new/src/CMakeLists.txt 2022-02-24 21:42:58.487369993 +0100 +++ leptonica-1.83.0-new/src/CMakeLists.txt 2022-12-21 12:21:04.107182989 +0100
@@ -17,15 +17,14 @@ endif() @@ -20,8 +20,8 @@ add_library (leptoni
string(REPLACE "-O3" "-O2" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}") set_target_properties (leptonica PROPERTIES VERSION 6.0.0)
set_target_properties (leptonica PROPERTIES SOVERSION 6)
add_library (leptonica ${src} ${hdr})
-set_target_properties (leptonica PROPERTIES VERSION ${VERSION_PLAIN})
+set_target_properties (leptonica PROPERTIES VERSION 5)
set_target_properties (leptonica PROPERTIES SOVERSION 5.4.0)
if (WIN32) if (WIN32)
-set_target_properties (leptonica PROPERTIES OUTPUT_NAME leptonica-${VERSION_PLAIN}) -set_target_properties (leptonica PROPERTIES OUTPUT_NAME leptonica-${VERSION_PLAIN})
-set_target_properties (leptonica PROPERTIES DEBUG_OUTPUT_NAME leptonica-${VERSION_PLAIN}d) -set_target_properties (leptonica PROPERTIES DEBUG_OUTPUT_NAME leptonica-${VERSION_PLAIN}d)
-else() +set_target_properties (leptonica PROPERTIES SUFFIX "-6${CMAKE_SHARED_LIBRARY_SUFFIX}")
+set_target_properties (leptonica PROPERTIES SUFFIX "-5${CMAKE_SHARED_LIBRARY_SUFFIX}") +set_target_properties (leptonica PROPERTIES SUFFIX "-6${CMAKE_SHARED_LIBRARY_SUFFIX}")
+set_target_properties (leptonica PROPERTIES SUFFIX "-5${CMAKE_SHARED_LIBRARY_SUFFIX}") else()
+endif()
set_target_properties (leptonica PROPERTIES OUTPUT_NAME leptonica) set_target_properties (leptonica PROPERTIES OUTPUT_NAME leptonica)
set_target_properties (leptonica PROPERTIES DEBUG_OUTPUT_NAME leptonica) set_target_properties (leptonica PROPERTIES DEBUG_OUTPUT_NAME leptonica)
-endif() @@ -70,7 +70,7 @@ if (UNIX)
if (BUILD_SHARED_LIBS)
target_compile_definitions (leptonica PRIVATE -DLIBLEPT_EXPORTS)
@@ -70,7 +69,7 @@ if (UNIX)
${CMAKE_COMMAND} -E create_symlink "$<TARGET_FILE:leptonica>" ${old_target} ${CMAKE_COMMAND} -E create_symlink "$<TARGET_FILE:leptonica>" ${old_target}
DEPENDS ${PROJECT_NAME} DEPENDS ${PROJECT_NAME}
COMMENT "Creating lept symlink") COMMENT "Creating lept symlink")
@ -51,7 +42,7 @@ diff -rupN leptonica-1.82.0/src/CMakeLists.txt leptonica-1.82.0-new/src/CMakeLis
endif(SYM_LINK) endif(SYM_LINK)
endif() endif()
@@ -89,7 +88,7 @@ else() @@ -89,7 +89,7 @@ else()
export(TARGETS leptonica APPEND FILE ${CMAKE_BINARY_DIR}/LeptonicaTargets.cmake) export(TARGETS leptonica APPEND FILE ${CMAKE_BINARY_DIR}/LeptonicaTargets.cmake)
endif() endif()

View File

@ -1 +1 @@
SHA512 (leptonica-1.82.0.tar.gz) = bddd7ebf12cf976e3ddd5a1d4c5c1307142b0f12e84523e30b3eb5a4f9c467deda73a5bff2b1fce86a17c35a55a92e70580e1b2c68372dd6fe03e4b171214568 SHA512 (leptonica-1.83.0.tar.gz) = 7eae1a2156888be106c6a04b1d55550f6fd316a338244aa2b0dc6fd21816e897e8b489b408882b6b2bbce4f5f2718ace7b765259af5470d9823e67d8d48addd3