Update to 1.84.1

This commit is contained in:
Sandro Mani 2024-01-05 12:24:56 +01:00
parent d4c75cc1a7
commit 93d3cf04f2
4 changed files with 16 additions and 12 deletions

1
.gitignore vendored
View File

@ -20,3 +20,4 @@
/leptonica-1.83.0.tar.gz /leptonica-1.83.0.tar.gz
/leptonica-1.83.1.tar.gz /leptonica-1.83.1.tar.gz
/leptonica-1.84.0.tar.gz /leptonica-1.84.0.tar.gz
/leptonica-1.84.1.tar.gz

View File

@ -11,8 +11,8 @@
%endif %endif
Name: leptonica Name: leptonica
Version: 1.84.0 Version: 1.84.1
Release: 2%{?dist} Release: 1%{?dist}
Summary: C library for efficient image processing and image analysis operations Summary: C library for efficient image processing and image analysis operations
License: Leptonica License: Leptonica
@ -197,6 +197,9 @@ ln -s %{mingw64_libdir}/libleptonica.dll.a %{buildroot}%{mingw64_libdir}/liblept
%changelog %changelog
* Fri Jan 05 2024 Sandro Mani <manisandro@gmail.com> - 1.84.1-1
- Update to 1.84.1
* Wed Dec 27 2023 Michael J Gruber <mjg@fedoraproject.org> - 1.84.0-2 * Wed Dec 27 2023 Michael J Gruber <mjg@fedoraproject.org> - 1.84.0-2
- Fix pkgconfig file regression (rhbz#2255937) - Fix pkgconfig file regression (rhbz#2255937)

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference leptonica-1.84.0-orig/CMakeLists.txt leptonica-1.84.0/CMakeLists.txt diff -rupN --no-dereference leptonica-1.84.1/CMakeLists.txt leptonica-1.84.1-new/CMakeLists.txt
--- leptonica-1.84.0-orig/CMakeLists.txt 2023-12-24 09:24:30.000000000 +0100 --- leptonica-1.84.1/CMakeLists.txt 2024-01-03 01:03:10.000000000 +0100
+++ leptonica-1.84.0/CMakeLists.txt 2023-12-27 13:49:02.576324545 +0100 +++ leptonica-1.84.1-new/CMakeLists.txt 2024-01-05 12:23:14.492871244 +0100
@@ -71,7 +71,7 @@ option(ENABLE_WEBP "Enable WebP support" @@ -71,7 +71,7 @@ option(ENABLE_WEBP "Enable WebP support"
option(ENABLE_OPENJPEG "Enable OpenJPEG support" ON) option(ENABLE_OPENJPEG "Enable OpenJPEG support" ON)
@ -30,9 +30,9 @@ diff -rupN --no-dereference leptonica-1.84.0-orig/CMakeLists.txt leptonica-1.84.
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig.cmake install(FILES ${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig.cmake
${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig-version.cmake ${CMAKE_CURRENT_BINARY_DIR}/LeptonicaConfig-version.cmake
DESTINATION ${leptonica_INSTALL_CMAKE_DIR}) DESTINATION ${leptonica_INSTALL_CMAKE_DIR})
diff -rupN --no-dereference leptonica-1.84.0-orig/prog/CMakeLists.txt leptonica-1.84.0/prog/CMakeLists.txt diff -rupN --no-dereference leptonica-1.84.1/prog/CMakeLists.txt leptonica-1.84.1-new/prog/CMakeLists.txt
--- leptonica-1.84.0-orig/prog/CMakeLists.txt 2023-12-24 09:24:30.000000000 +0100 --- leptonica-1.84.1/prog/CMakeLists.txt 2024-01-03 01:03:10.000000000 +0100
+++ leptonica-1.84.0/prog/CMakeLists.txt 2023-12-27 13:49:02.576324545 +0100 +++ leptonica-1.84.1-new/prog/CMakeLists.txt 2024-01-05 12:23:14.495871319 +0100
@@ -12,7 +12,7 @@ function(add_prog_target target) @@ -12,7 +12,7 @@ function(add_prog_target target)
if (BUILD_SHARED_LIBS) if (BUILD_SHARED_LIBS)
target_compile_definitions (${target} PRIVATE -DLIBLEPT_IMPORTS) target_compile_definitions (${target} PRIVATE -DLIBLEPT_IMPORTS)
@ -42,9 +42,9 @@ diff -rupN --no-dereference leptonica-1.84.0-orig/prog/CMakeLists.txt leptonica-
set_target_properties (${target} PROPERTIES FOLDER prog) set_target_properties (${target} PROPERTIES FOLDER prog)
endfunction(add_prog_target) endfunction(add_prog_target)
######################################## ########################################
diff -rupN --no-dereference leptonica-1.84.0-orig/src/CMakeLists.txt leptonica-1.84.0/src/CMakeLists.txt diff -rupN --no-dereference leptonica-1.84.1/src/CMakeLists.txt leptonica-1.84.1-new/src/CMakeLists.txt
--- leptonica-1.84.0-orig/src/CMakeLists.txt 2023-12-24 09:24:30.000000000 +0100 --- leptonica-1.84.1/src/CMakeLists.txt 2024-01-03 01:03:10.000000000 +0100
+++ leptonica-1.84.0/src/CMakeLists.txt 2023-12-27 14:34:36.751976070 +0100 +++ leptonica-1.84.1-new/src/CMakeLists.txt 2024-01-05 12:23:14.499871419 +0100
@@ -16,7 +16,10 @@ string(REPLACE "-O3" "-O2" CMAKE_C_FLAGS @@ -16,7 +16,10 @@ string(REPLACE "-O3" "-O2" CMAKE_C_FLAGS
add_library (leptonica ${src} ${hdr}) add_library (leptonica ${src} ${hdr})
set_target_properties (leptonica PROPERTIES VERSION 6.0.0) set_target_properties (leptonica PROPERTIES VERSION 6.0.0)

View File

@ -1 +1 @@
SHA512 (leptonica-1.84.0.tar.gz) = f4b2eebfa991e6a49432e13de86d57d8efe427216a757a47e6ed00babbb74c141f271b5a70aafbad9e4dedbdec0cb6245e6c0fb56e3c68c01b437022a05a9af2 SHA512 (leptonica-1.84.1.tar.gz) = 968a88d2074717e6f379d2f9b8f7f0d5193fe9b8856051e09e2b31c939689b196a4a9b2cde595ce76ff8ae2784680ef5e68c40709c051d3d23738e862968016f